[CSS] (encore!) pas compatible FF

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par rudddy, 30 Juin 2008.

  1. rudddy
    rudddy WRInaute passionné
    Inscrit:
    1 Août 2007
    Messages:
    2 125
    J'aime reçus:
    0
    Bonjour

    suite à mon précédent problème en CSS pour affiche mon div d'adsense (voir https://www.webrankinfo.com/forum/t/resolu-css-rajouter-une-div.95823/ ), mon site n'est plus compatible avec FF

    Par exemple sur :

    http://www.maison-de-retraite-paris.fr/ ... 75.p0.html

    les boutons contacts qui devraient en bas à droite de chaque ligne (voir sous IE) s'affichent n'importe comment ...

    voici le div correspondant :

    Code:
    #b-contact
    {
    width:136px;
    height: 34px;
    float: right;
    padding-top:10px;
    vertical-align:middle;
    }



    merci de votre aide
     
  2. HawkEye
    HawkEye WRInaute accro
    Inscrit:
    23 Février 2004
    Messages:
    13 858
    J'aime reçus:
    5
    Je peux me tromper, n'étant pas un dieu en matière de Stylesheet mais... il m'a toujours semblé que les id="" devaient être uniques. Ca vient peut-être de là.

    Qui plus est, je vois du float:right; sans éléments affublés d'un "clear: both;" ou "clear: right;" qui le suivent... c'est une piste également.
     
  3. rudddy
    rudddy WRInaute passionné
    Inscrit:
    1 Août 2007
    Messages:
    2 125
    J'aime reçus:
    0
    ne sois pas modeste

    ca marchait jusqu'au changement du post précédent ...

    je teste quand même pour dire que je ne suis pas fainéant ..
     
  4. rudddy
    rudddy WRInaute passionné
    Inscrit:
    1 Août 2007
    Messages:
    2 125
    J'aime reçus:
    0
    je te confirme que ça ne fonctionne pas mais au moins, le bouton n'est pas n'importe où.

    il ne me faut plus que l'aligner à droite maintenant ...
     
  5. bproductiv
    bproductiv WRInaute accro
    Inscrit:
    27 Décembre 2004
    Messages:
    3 677
    J'aime reçus:
    0
  6. rudddy
    rudddy WRInaute passionné
    Inscrit:
    1 Août 2007
    Messages:
    2 125
    J'aime reçus:
    0
    je suis d'accord avec toi mais quand pour le valider cela passe par des prises de tête je me dis autant en pas le valider ...
     
  7. bproductiv
    bproductiv WRInaute accro
    Inscrit:
    27 Décembre 2004
    Messages:
    3 677
    J'aime reçus:
    0
    alors ton problème restera comme ca, c'est dommage quand même.
     
  8. rudddy
    rudddy WRInaute passionné
    Inscrit:
    1 Août 2007
    Messages:
    2 125
    J'aime reçus:
    0
    ok

    les autres qui veulent m'aider sont les bienvenus ...
     
  9. webmasterlamogere
    webmasterlamogere WRInaute passionné
    Inscrit:
    17 Décembre 2006
    Messages:
    1 647
    J'aime reçus:
    1
    essaye de mettre la "class" sur le "a" et pas sur "img"
     
  10. Marie-Aude
    Marie-Aude WRInaute accro
    Inscrit:
    5 Juin 2006
    Messages:
    16 686
    J'aime reçus:
    154
    Je débugue uniquement des sites valides.
    Je ne vois pas pourquoi je me prendrais la tête à trouver "la bonne erreur" au milieu de tas d'autres si le webmaster ne se prend pas la tête :)
     
  11. rudddy
    rudddy WRInaute passionné
    Inscrit:
    1 Août 2007
    Messages:
    2 125
    J'aime reçus:
    0
    problème résolu

    merci à vous tous :)
     
  12. rudddy
    rudddy WRInaute passionné
    Inscrit:
    1 Août 2007
    Messages:
    2 125
    J'aime reçus:
    0
    au fait au passage j'ai quand même voulu aller dans votre sens et rendu valide la page

    mais le problème est revenu :-(


    donc maintenant bproductiv et marie aude je compte sur vous !!!! :))
     
  13. webmasterlamogere
    webmasterlamogere WRInaute passionné
    Inscrit:
    17 Décembre 2006
    Messages:
    1 647
    J'aime reçus:
    1
    met "a class=" à la place de "a id="
    et dans le css :
    Code:
    .b-contact { ...
     
  14. rudddy
    rudddy WRInaute passionné
    Inscrit:
    1 Août 2007
    Messages:
    2 125
    J'aime reçus:
    0
    merci j'avais essayé mais le problème est que quand je clique sur la gauche sur région parisienne, les boutons de droite partent en vrille sur FF ...
     
  15. Marie-Aude
    Marie-Aude WRInaute accro
    Inscrit:
    5 Juin 2006
    Messages:
    16 686
    J'aime reçus:
    154
    .separateur : rajoute un clear:float;
     
  16. rudddy
    rudddy WRInaute passionné
    Inscrit:
    1 Août 2007
    Messages:
    2 125
    J'aime reçus:
    0
    j'ai le même problème sous F avec les boutons contacts qui partent en vrille quand je clique à gauche sur région parisienne ...

    au passage clear: float : ça existe ?
     
  17. webmasterlamogere
    webmasterlamogere WRInaute passionné
    Inscrit:
    17 Décembre 2006
    Messages:
    1 647
    J'aime reçus:
    1
    c'est pas plutôt clear: both;
     
  18. rudddy
    rudddy WRInaute passionné
    Inscrit:
    1 Août 2007
    Messages:
    2 125
    J'aime reçus:
    0
    c'est ce que j'avais pensé masi ça résoud el problème des vrilles :)-)) mais ça envoie tout beaucoup plus bas ...
     
  19. webmasterlamogere
    webmasterlamogere WRInaute passionné
    Inscrit:
    17 Décembre 2006
    Messages:
    1 647
    J'aime reçus:
    1
    ta liste de départements dépasse du menu. il faut réduire le padding-left (ou margin-left)
    il faut peut-être ajouter le code suivant au div edito:
    Code:
    	overflow: auto;
    	zoom: 1;
    
     
  20. bproductiv
    bproductiv WRInaute accro
    Inscrit:
    27 Décembre 2004
    Messages:
    3 677
    J'aime reçus:
    0
    en regardant la sourec je viens de voir ca??
    Code:
    <div id="dDep" style="display:none;">
    	  <ul>
    	  <li><h2><strong><a href="maison-de-retraite-75.p0.html">Maison de retraite 75</a></strong></h2></li>
    	  <li><h2><strong><a href="maison-de-retraite-77.p0.html">Maison de retraite 77</a></strong></h2></li>
    
    	  <li><h2><strong><a href="maison-de-retraite-78.p0.html">Maison de retraite 78</a></strong></h2></li>
    	  <li><h2><strong><a href="maison-de-retraite-91.p0.html">Maison de retraite 91</a></strong></h2></li>
    	  <li><h2><strong><a href="maison-de-retraite-92.p0.html">Maison de retraite 92</a></strong></h2></li>
    	  <li><h2><strong><a href="maison-de-retraite-93.p0.html">Maison de retraite 93</a></strong></h2></li>
    	  <li><h2><strong><a href="maison-de-retraite-94.p0.html">Maison de retraite 94</a></strong></h2></li>
    	  <li><h2><strong><a href="maison-de-retraite-95.p0.html">Maison de retraite 95</a></strong></h2></li>
    
    	  <li><h2><strong><a href="/">Alzheimer</a></strong></h2></li>
    	  <li><h2><strong><a href="/">Parkinson</a></strong></h2></li>
    	  <li><h2><strong><a href="/">Aides financi&egrave;res</a></strong></h2></li>
    	  </ul>
    	  </div>
    
    Tu es pressé d'être pénalisé?
    Bon, il va falloir commencer à coder proprement et surtout SÉMANTIQUEMENT parce que là ce qui m'étonne c'est qu'il n'y ai QUE le bouton qui déconne.
     
  21. Marie-Aude
    Marie-Aude WRInaute accro
    Inscrit:
    5 Juin 2006
    Messages:
    16 686
    J'aime reçus:
    154
    Alors essaye juste clear:right;
     
  22. rudddy
    rudddy WRInaute passionné
    Inscrit:
    1 Août 2007
    Messages:
    2 125
    J'aime reçus:
    0
    c'est OK pour les boutons mais maintenant il y a tout le reste qui descend ...

    on avance :?
     
  23. Marie-Aude
    Marie-Aude WRInaute accro
    Inscrit:
    5 Juin 2006
    Messages:
    16 686
    J'aime reçus:
    154
    Pour être honnête, ton code est un peu chargé. Par exemple, quand tu fais les espaces avec les <br/> au lieu de les faire avec des margins et des paddings...
     
  24. rudddy
    rudddy WRInaute passionné
    Inscrit:
    1 Août 2007
    Messages:
    2 125
    J'aime reçus:
    0
    ceci explique cela ?
     
  25. rudddy
    rudddy WRInaute passionné
    Inscrit:
    1 Août 2007
    Messages:
    2 125
    J'aime reçus:
    0
    j'ai mis un padding, mais ca n'aide pas
     
Chargement...
Similar Threads - [CSS] (encore compatible Forum Date
[CSS] Application (non souhaitée) d'un effet au parent via :not(:hover) Développement d'un site Web ou d'une appli mobile 17 Novembre 2020
[CSS] Alignement de cadre. Développement d'un site Web ou d'une appli mobile 24 Mai 2013
[CSS] Aligner une image à coté d'une div en display:table-cell ? Développement d'un site Web ou d'une appli mobile 2 Mai 2012
[CSS] Alignement vertical du texte Développement d'un site Web ou d'une appli mobile 20 Avril 2011
[css] Petit souci pour le menu du jour! Développement d'un site Web ou d'une appli mobile 29 Août 2010
[css] Comment centrer un bloc css? Développement d'un site Web ou d'une appli mobile 25 Août 2010
[CSS] Comment faire apparaître le sous-menu ? Développement d'un site Web ou d'une appli mobile 22 Juillet 2010
[CSS] Overflow, float:right, et internet explorer Développement d'un site Web ou d'une appli mobile 10 Août 2009
[css] <li> image en vertical-align:bottom Développement d'un site Web ou d'une appli mobile 18 Juillet 2009
[CSS] bouton non cliquable Développement d'un site Web ou d'une appli mobile 16 Juillet 2009
[CSS] IE8 Développement d'un site Web ou d'une appli mobile 15 Juillet 2009
[CSS] decalage image et texte Développement d'un site Web ou d'une appli mobile 18 Juin 2009
[CSS] : scroller overflow et ie6 :-( Développement d'un site Web ou d'une appli mobile 12 Mai 2009
[CSS] bouton submit + image arriere plan Développement d'un site Web ou d'une appli mobile 20 Avril 2009
[CSS]Positionner la colonne centrale en haut du source Développement d'un site Web ou d'une appli mobile 29 Mars 2009
[Résolu] [CSS] Lien sur tout un div Développement d'un site Web ou d'une appli mobile 23 Février 2009
[CSS] L'élément body Développement d'un site Web ou d'une appli mobile 21 Décembre 2008
[CSS] : menus déroulants Développement d'un site Web ou d'une appli mobile 15 Décembre 2008
[CSS] : problème de mise en page FF3 Développement d'un site Web ou d'une appli mobile 31 Août 2008
[RESOLU] [CSS] : rajouter une div Développement d'un site Web ou d'une appli mobile 26 Juin 2008