Problème CSS : Firefox - Safari OK,Opéra - IE 7 KO

mikaweb

WRInaute discret
Bonsoir,

Voila j'ai un petit problème depuis que j'ai ajouté ceci à ma page web.

Sur Firefox et Safari ca fonctionne comme sa doit le faire, sous Opéra il y a un petit problème et sous IE7 c'est vraiment la catastrophe...
Code:
<p style="float:right;"><a title="S'inscrire au Fil RSS" class="ButtonRSS" href="http://feeds.feedburner.com/Gunnersfr">S'inscrire<span id="RSSIcon"/></a></p>
<p style="float:right;"><a class="ButtonReagir" href="<?php echo htmlspecialchars($donnees['lien_reaction']); ?>" title="Réagir à l'article sur le forum">Réagir<span id="ReactionIcon"/></a></p>

Sans ceci, aucun souci mais bon avec j'aime bien et si je pourrais éviter de m'en passer.
J'ai déjà décidé de mettre IE6 un peu de côté alors faut que j'assure avec ce qu'il reste.

Donc le souci, c'est avec les 2 boutons en bas de l'article. Firefox + Safari tout fonctionne impec, du moins sous Windows, et Opéra et IE7 il y a des problèmes.

Un souci d'alignement sur Opéra mais alors sur IE7 y a un gros souci que je comprends pas du tout.
Il me recopie 2x de trop une partie juste après le code donné ci-dessus. :?
Et il me foire complètement le :hover.

Puis le bas de page est complètement mal foutu....


http://v2.gunners.fr/article-287-van-pe ... ckham.html :(
 

Marie-Aude

WRInaute accro
Excuses moi mais quel est l'intérêt de faire un marquage aussi compliqué ?
Code:
<div style="float:right;"><a class="RSSIcon" href blabl>S'inscrire</a><a class="Reaction Icon"href="balb">Réagir</a></div>Tu n'as pas besoin d'accumuler les floats, tu simplifies le modèle de boite pour IE qui a toujours des petits problèmes avec ça...
 

mikaweb

WRInaute discret
Ca ne change rien au problème.
Ca me change un peu l'affichage, mais c'est moins bien qu'avant.
Avant ca me permettait de bien pouvoir garder les deux boutons l'un à côté de l'autre, du moins sous Firefox et Safari.

Sous IE7, j'ai toujours une partie qui est triplée alors qu'elle n'a pas lieu de l'être.
Je me demande d'ou peut bien venir ce problème.

ps: même sans ces float, j'ai le tout qui est triplé :idea: :idea: :idea: :?
 

Marie-Aude

WRInaute accro
sans doute dans ce que tu envoies via le php

Evidemment, avec mon marquage, il faut changer un peu le css, mais c'est beaucoup plus simple et moins "torturé" pour avoir les deux images cote à côte, il suffit de leur donner des marges.

Sinon regarde du côté du bug du double float avec IE, je ne sais plus exactement ce que c'est mais ça pourrait expliquer ces bizarreries
 

mikaweb

WRInaute discret
C'est mes spans, images par dessus une image qui foutent le boxon.
J'ai tout simplement enlever et puis tant pis.

Sinon il reste le petit souci du bas de page avec un méchant petit décalage ou il affiche mon body au lieu de mon footer. Uniquement sur la page des articles et sur Ie7 pour changer :roll:

Merci ;)

Je ferais de nouveaux tests par la suite... quand j'aurais plus de temps.
 

Marie-Aude

WRInaute accro
Ah oui j'avais pas vu que tu faisais comme ça, je croyais que tu fonctionnais avec un chagement de background en a:hover

Tu peux essayer de t'en sortir avec les z-index pour superposer
 

mikaweb

WRInaute discret
bproductiv a dit:
Normal tu ne ferme pas tes balises span(s)
Oh putain la boulette :lol:

Je les fermaient mais de la mauvaise facon.

<span id="" /> au lieu de <span></span>
Safari et Firefox le reconnaissait mais pas les deux autres.

Souci réglé à ce niveau :wink:

Merci
 

Discussions similaires

Haut