Problème de caractère suite à changement d'hébergeur

Discussion dans 'Administration d'un site Web' créé par JeromeRookie, 30 Avril 2006.

  1. JeromeRookie
    JeromeRookie WRInaute occasionnel
    Inscrit:
    11 Août 2003
    Messages:
    340
    J'aime reçus:
    0
    BOnjour,
    je viens de passer mon site d'un mutu a un dédié virtuel. Après deux jours de boulot et grace notamment à l'aide de certaines personnes ici, tout est fini ;-)
    ce site est une mine d'Or !!!!

    je n'ai plus qu'un petit souci : sur mon annuaire (et seulement sur mon annuaire ???) les caractères spéciaux ne s'affichent pas. vu que je fais de l'url rewriting, cela me pose un problème (voir exemple h**p://www.ateliermagique.com/annuaire/)

    quelqu'un sait-il d'ou cela peut venir ?
     
  2. alfred99
    alfred99 WRInaute occasionnel
    Inscrit:
    7 Décembre 2004
    Messages:
    432
    J'aime reçus:
    0
    Bonjour,
    Tu as le même phénomène dans ton forum.
    Il me semble que c'est une question de codage UTF-8 en ISO ou le contraire. Tu n'as rien changé à ce niveau ?
     
  3. JeromeRookie
    JeromeRookie WRInaute occasionnel
    Inscrit:
    11 Août 2003
    Messages:
    340
    J'aime reçus:
    0
    non rien.
    mais tu as raison, c'est pareil sur tous le site. Tous les accents sont mal interprétés (enfin pas tous car certains sont correctement affichés dans le forum....
    c'est en bdd que le pb est : ces carctères sont crées à l'extraction.... comment cela se fait-il ? j'ai fait l'exportation par phpmyadmin ? dois-je recommencer ou ou ai-je un moyen simple de repasser sur les données ?
     
  4. netsys
    netsys WRInaute passionné
    Inscrit:
    17 Juillet 2004
    Messages:
    1 010
    J'aime reçus:
    0
    Peut-être que le format de la base de données n'est pas le bon ?
     
  5. JeromeRookie
    JeromeRookie WRInaute occasionnel
    Inscrit:
    11 Août 2003
    Messages:
    340
    J'aime reçus:
    0
    que veux-tu dire ? cela peut se changer au niveau de la base ? n'est-ce pas plutot au moment de l'importation par mysql en commande ssh qu'il aurait fallu que je fasse qqchose ?
     
  6. chris81
    chris81 WRInaute discret
    Inscrit:
    8 Mars 2005
    Messages:
    164
    J'aime reçus:
    0
    bonjour

    j'ai le meme souci quant je passe ma page d'index dans spider simulator, il me resort une page avec des caractères bizares, alors que sur les autres pages rien d'étrange, j'ai cherché pendant un moment mai rien trouvé ! :?:
     
  7. JeromeRookie
    JeromeRookie WRInaute occasionnel
    Inscrit:
    11 Août 2003
    Messages:
    340
    J'aime reçus:
    0
    en fait, ce que j'aimerais bien savoir lors de l'export importation d'une bdd : faut-il se soucier à l'extraction ou à l'importation de la conservation des caractères spéciaux ?
     
  8. thierry8
    thierry8 WRInaute accro
    Inscrit:
    11 Juillet 2005
    Messages:
    2 728
    J'aime reçus:
    0
    Quel base de données avait tu sur l'ancien hébergeur et à présent sur le nouveau ?
     
  9. JeromeRookie
    JeromeRookie WRInaute occasionnel
    Inscrit:
    11 Août 2003
    Messages:
    340
    J'aime reçus:
    0
    sur le nouveau, j'ai MySQL 4.0.24
    sur l'ancien, j'avais : MySQL 4.1.15

    je prends soin à l'exportation de cocher MYSQL40 dans l'option compatibiliuté de l'exportation

    par ailleurs, j'ai remarqué deux choses :
    1 ) les caractères spéciaux sont conservés si on ne coche pas "TRANSMETTRE"
    il semble donc que ce soit le fait de demander à phpmyadmin de créer un fichier .sql qui transforme les caractères spéciaux....

    2)bien que je coche la case "Inclure la valeur courante de l'AUTO_INCREMENT", cette information n'apparait pas dans le fichier .... bizarre non ?
     
  10. thierry8
    thierry8 WRInaute accro
    Inscrit:
    11 Juillet 2005
    Messages:
    2 728
    J'aime reçus:
    0
    Je ne comprends pas une chose sur la page mentionnée je ne constate aucun problème..
    (*www.ateliermagique.com/annuaire/)
     
  11. JeromeRookie
    JeromeRookie WRInaute occasionnel
    Inscrit:
    11 Août 2003
    Messages:
    340
    J'aime reçus:
    0
    j'ai réglé le problème sur cette page en faisant les insert à la main. le problème napparait sur le forum
     
  12. thierry8
    thierry8 WRInaute accro
    Inscrit:
    11 Juillet 2005
    Messages:
    2 728
    J'aime reçus:
    0
    Bizarrement les sujets sont bien affichés, mais pas les discussions.

    Normalement avec une exportation au format mysql 4 il ne devrait pas y avoir de problèmes.
     
Chargement...
Similar Threads - Problème caractère suite Forum Date
Problème de URL indexé Google - suite de chiffres et caractères inconnue Débuter en référencement 16 Janvier 2010
Problème de caractères dans l'outil d'analyse des balises h1 h2 h3 Rédaction web et référencement 4 Août 2019
Problème de caractères Développement d'un site Web ou d'une appli mobile 12 Décembre 2017
Passage à PHP5.6, problème sur caractères accentués Développement d'un site Web ou d'une appli mobile 24 Juin 2015
Problème d'encodage caractère Google+ 6 Août 2014
Problème caractères accentués dans l'index google Crawl et indexation Google, sitemaps 4 Août 2013
Problème d'affichage du caractère ó Développement d'un site Web ou d'une appli mobile 9 Novembre 2012
Problème caractère arabe Développement d'un site Web ou d'une appli mobile 6 Septembre 2012
Problème caractère email Développement d'un site Web ou d'une appli mobile 27 Août 2012
Problème de lecture des caractères Développement d'un site Web ou d'une appli mobile 28 Juin 2012
problème lors d'une recherche en SQL et caractères spéciaux Développement d'un site Web ou d'une appli mobile 9 Août 2011
Problème caractère spécial Développement d'un site Web ou d'une appli mobile 9 Août 2011
Simplepie problème caractères spéciaux rss iso Développement d'un site Web ou d'une appli mobile 4 Août 2011
Formulaire de contact en UTF-8 - problème caractères russe Développement d'un site Web ou d'une appli mobile 6 Juin 2011
Problème de caractères Développement d'un site Web ou d'une appli mobile 17 Juin 2010
Problème caractere google Débuter en référencement 10 Juin 2010
Problème sitemap et caractère & Débuter en référencement 24 Mai 2010
Problème caractères avec include externe Développement d'un site Web ou d'une appli mobile 19 Mai 2010
Problème avec des caractère du style ()><...' URL Rewriting et .htaccess 18 Mars 2010
Problèmes avec les caractères accentués. Développement d'un site Web ou d'une appli mobile 11 Décembre 2009