Problème de réécriture d'url =(

Discussion dans 'URL Rewriting et .htaccess' créé par Makenko, 28 Mars 2012.

  1. Makenko
    Makenko Nouveau WRInaute
    Inscrit:
    12 Février 2009
    Messages:
    18
    J'aime reçus:
    0
    Bonjour à tous.

    Je viens de créer un nouveau site, pour la partie visible il me manque "que" le contenu et quelques améliorations. je voulais déjà vérifier que tout fonctionnait sur le serveur pour être opérationnel dès que le contenu est là. En local tout roule, mais une fois sur le serveur j'ai des problèmes avec mes réécritures d'url. Sur le serveur j'ai sur le htaccess :

    Code:
    Options +FollowSymlinks
    RewriteEngine on
    # page avec une variable g :
    RewriteRule ^(.*)/$   index.php?g=$1 [NC,QSA,L]
    # page avec une variable p :
    RewriteRule ^(.*).html$   index?p=$1 [NC,QSA,L]
    # page avec deux variable g et r:
    RewriteRule ^(.*)/(.*)-bento-box$   index.php?g=$1&r=$2 [NC,QSA,L]
    J'ai donc les liens suivants sur mon site :

    mon-site.fr/variable$g/ (fait appel à une page php qui prends les infos dans une bdd -> gamme de produits)
    monsite.fr/variable$p.html (fait appel à des pages php distinctes statiques comme les mentions légales ou contact)
    mon-site.fr/variable$g/variable$r-bento-box (fait appel à une page php qui prends les infos dans une bdd -> produit lui-même)

    - Le 1er problème concerne "mon-site.fr/variable$g/" et "mon-site.fr/variable$g/variable$r-bento-box" qui fonctionne absolument tout le temps SAUF avec une variable, en l’occurrence dento :
    mon-site.fr/accessoires/ -> pas de problème
    mon-site.fr/tralalatsoin-tsoi1/ -> pas de problème
    mon-site.fr/dento/ -> erreur 404
    là où c'est dingue c'est que "mon-site.fr/Dento/" fonctionne
    Même si la variable ne correspond à rien

    Exactement le même problème lorsqu'il y a deux variables, la première déconne exactement pareil

    - le second problème concerne les liens sous la forme monsite.fr/variable$p.html qui donnent également une erreur 404.

    Le htaccess et moi ça fait deux, j'étais content de moi quand tout fonctionnait en local. Une piste à explorer? merci par avance :)

    Je peux donner l'url du site si vous la voulez pour mieux "voir". Je le retirerai dès que le pb sera résolu.
     
  2. Makenko
    Makenko Nouveau WRInaute
    Inscrit:
    12 Février 2009
    Messages:
    18
    J'aime reçus:
    0
    Le problème n°2 est réglé, il ne reste plus que le problème unique avec la variable "dento" qui pose problème... Pour l'instant j'ai mis avec majuscule mais ça fait bidouille j'aime pas. J'aimerais savoir d'où ça provient..
     
Chargement...
Similar Threads - Problème réécriture Forum Date
Problème de réécriture d'url Développement d'un site Web ou d'une appli mobile 27 Février 2014
Problème de syntaxe en réécriture URL Rewriting et .htaccess 23 Octobre 2012
Problème de réécriture d'url. Je vois plus ou chercher URL Rewriting et .htaccess 14 Septembre 2012
Problème de réecriture d'URL .htaccess URL Rewriting et .htaccess 8 Août 2012
Problème de réécriture avec Arfooo URL Rewriting et .htaccess 20 Avril 2012
Problème réécriture et sous-dossiers URL Rewriting et .htaccess 3 Janvier 2012
Problème de réécriture sur un sous-domaine URL Rewriting et .htaccess 15 Septembre 2011
Problème classique de réécriture et de redirection 301 URL Rewriting et .htaccess 13 Avril 2011
problème de réécriture URL Rewriting et .htaccess 10 Novembre 2010
problème réécriture avec un cms URL Rewriting et .htaccess 27 Avril 2010