1. ⭐⭐⭐ Grosse PROMO en cours sur ma plateforme SEO My Ranking Metrics
    Rejeter la notice

Problème moteur de recherche interne

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par aiepepito, 11 Mars 2008.

  1. aiepepito
    aiepepito WRInaute discret
    Inscrit:
    19 Janvier 2005
    Messages:
    224
    J'aime reçus:
    0
    Bonjour à tous,

    J'ai un petit soucis avec un moteur de recherche interne sur un site; je m'explique :

    Il m'est impossible d'obtenir des résultats avec accents lors de mes requêtes SQL.
    J'ai essayé d'utiliser LIKE dans un premier temps puis REGEXP mais rien n'y fait.
    Mes tables sont encodées en utf8, il me semble que le problème doit être lié à ça. Y a t il une solution? Une astuce? Je me doute bien que oui mais à vrai dire je lutte vraiment pour la trouver...

    D'avance merci pour votre aide

    p.s: j'ai lu les autres topics ayant un sujet similaire mais n'ai trouvé réponse nul part
     
  2. serval2a
    serval2a WRInaute accro
    Inscrit:
    21 Mars 2005
    Messages:
    2 578
    J'aime reçus:
    0
    Bonjour,
    Tes pages sont dans le même encodage ?
    As-tu essayer de convertir en plus la variable du formulaire en UTF-8 ?
    @+
     
  3. e-kiwi
    e-kiwi WRInaute accro
    Inscrit:
    23 Décembre 2003
    Messages:
    13 260
    J'aime reçus:
    1
    euh, cela depend de la config mysql aussi, non ? je suis pas expert la dedans, mais je sais que sur mon serveur si je fais une requete sur "mange" il me sort aussi "mangé"
     
  4. aiepepito
    aiepepito WRInaute discret
    Inscrit:
    19 Janvier 2005
    Messages:
    224
    J'aime reçus:
    0
    La variable en question est passée en GET; ma requête est donc sur des caractères sans accents.
    Je pense pas qu'il puisse y avoir un rapport avec l'encodage de mes pages puisque mon soucis ne provient uniquement des (non) résultats de cette fameuse requête.

    Mes 2 tests ci-dessous ne me trouvent aucune correspondance alors que j'ai des formations sur les "base de données".

    SELECT * FROM formations WHERE LOWER(nom_formation) LIKE '%donne%'

    SELECT * FROM formations WHERE LOWER(nom_formation) REGEXP('donne')
     
  5. finstreet
    finstreet WRInaute accro
    Inscrit:
    10 Juillet 2005
    Messages:
    13 473
    J'aime reçus:
    1
    ils sont pas codés en HTML tes accents ?
     
  6. aiepepito
    aiepepito WRInaute discret
    Inscrit:
    19 Janvier 2005
    Messages:
    224
    J'aime reçus:
    0
    Non, ils sont justement encodés en utf8.
     
  7. serval2a
    serval2a WRInaute accro
    Inscrit:
    21 Mars 2005
    Messages:
    2 578
    J'aime reçus:
    0
    C'est sur le site de ton profil avec ce problème là
    search.php?method=recherche&result=24&prenom=mégane&order=1
    search.php?method=recherche&result=24&prenom=megane&order=1
    C'est ça ?
    Si oui, effectivement celà semble être un problème d'encodage les pages sont en ISO et si la base est en UTF-8 il va y avoir un problème, essaie un utf8_encode de ta variable quand tu la récupères.
     
  8. aiepepito
    aiepepito WRInaute discret
    Inscrit:
    19 Janvier 2005
    Messages:
    224
    J'aime reçus:
    0
    Non ca n'a absolument rien à voir avec le site de mon profil :)
    J'ai collé au dessus les requêtes en question (sur des formations informatiques).
     
  9. bproductiv
    bproductiv WRInaute accro
    Inscrit:
    27 Décembre 2004
    Messages:
    3 705
    J'aime reçus:
    0
    ta page utilise quel encodage? et ta base de donnée ?
     
Chargement...
Similar Threads - Problème moteur recherche Forum Date
Moteur de recherche interne, est ce un problème ? Débuter en référencement 30 Septembre 2015
Problème avec accents dans moteur de recherche perso Développement d'un site Web ou d'une appli mobile 27 Mai 2009
Problème d'affichage dans le moteur de recherche Google Crawl et indexation Google, sitemaps 4 Décembre 2008
Span sur 1ère lettre d'un mot, problème pour la compréhension des moteurs ? Débuter en référencement 8 Novembre 2010
Problème avec boite mail OVH e-commerce Mardi à 18:39
Search Console Problème d'ergonomie mobile sur GSC avec les URL distinctes Problèmes de référencement spécifiques à vos sites Mardi à 18:00
Probleme avec le crawl Mobile sur Search Console Crawl et indexation Google, sitemaps 14 Septembre 2019
Problème avec ...html dans un mail Administration d'un site Web 9 Septembre 2019
Problème de bot click AdSense 23 Août 2019
Problème échappement code HTML Développement d'un site Web ou d'une appli mobile 17 Août 2019
  1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies.
    Rejeter la notice