Probleme serveur dédié et site lent aidez moi svp

Discussion dans 'Administration d'un site Web' créé par mcflyde, 27 Mai 2006.

  1. mcflyde
    mcflyde Nouveau WRInaute
    Inscrit:
    21 Août 2004
    Messages:
    5
    J'aime reçus:
    0
    Bonjour,
    Voila j’ai un problème avec mes sites sur mon serveur dédié. Plusieurs fois dans la journée a n’importe quel heures de la nuit et du jour et pendant de longues minutes, Voir de longue heures, l’arrivé sur mes sites et longue. La page est longue a ce charger et un fois charger on peut surfer sur le site sans problème, a par si on actualise la page ou la ca rame aussi. Ca me le fais sur tout les site hébergé sur mon serveur et au même moment pour tous.
    Si je regarde dans plesk le proc ne sature pas et la bande passante de 20mbs me suffit largement par contre la ram et a 92% d’utilisation ce ki parait est normal avec linux.
    J’ai essayé sur un autre serveur chez un autre hébergeur et ça fais la même chose.
    Comme script j’ai Xtraceur pour les stats et ensuite les videos MB webfric, smartmovie et vidéo de star enfin cashprogram plutôt. La programmation de mes sites est en html tout simple pas de php et de bases de données .
    Même en virant tout les scripts et en essayant avec un page vierge en html sur un domaine rien a faire ca rame. Je n’arrive pas a trouver ce ki ralenti la totalité de mes sites pourtant j’ai tout viré et essayé.
    Au niveau des dns normalement c ok d’après mon hébergeur et mon registar.
    J’aimerai savoir comment je peux détecter le problème ? J’ai plesk comme admin ou je ne trouve rien pour contrôler et je me demande si il y a d’autre moyen de voir si apache fonctionne bien ou voir ce ki ce passe sur le serveur etc ….
    Mon hébergeur ma donner un accès Root . ça sert a quoi ? comment si connecter ?
    J’ai un serveur celeron 2.6 - 2048 de ram – 20 mbs de bande passante

    Merci par avance de votre aide
     
  2. Bool
    Bool WRInaute passionné
    Inscrit:
    26 Février 2004
    Messages:
    1 543
    J'aime reçus:
    0
    Hello,

    l'accès "root", en gros ça te permet de te connecter en SSH... et de faire ce que tu veux sur la machine. En gros la réponse de l'hébergeur ici c'est "démerdes toi". :)

    Après difficile d'en savoir plus : à vue de nez je parirais sur le nombre de slots Apache qui sature...
     
  3. biddybulle
    biddybulle WRInaute passionné
    Inscrit:
    30 Mai 2005
    Messages:
    1 428
    J'aime reçus:
    0
    qui t'as installé ce dédié ?
     
  4. mcflyde
    mcflyde Nouveau WRInaute
    Inscrit:
    21 Août 2004
    Messages:
    5
    J'aime reçus:
    0
    merci de vos réponse.
    Je suis chez oxyd mais le mois dernier j'étais chez c-dédié et ca ramé pareil ca viens surment d'un truc sur mes site mais je ne voit pas quoi. J'ai viré tout les scripts et ne vois rien qui pourrais faire ramer.
    Mes sites ont tous environ 100 méga de videos a télécharger.
    ca pourrais venir de la ?
     
  5. Bool
    Bool WRInaute passionné
    Inscrit:
    26 Février 2004
    Messages:
    1 543
    J'aime reçus:
    0
    J'ai toujours l'impression de "parler" dans le vide. ;)

    Donc : pour éviter de consommer trop de ressources, Apache bride le nombre de connexion parallèles qu'il utilise. Par défaut, ce doit être quelque chose comme 150 connexions. Avec un site "classique", qui n'a pas énormément de trafic, ça peut aller, et encore.
    Mes avec des videos, ça devient nettement plus complexe : une video ça prend "longtemps" à télécharger, les "slots de connexion" mettent donc longtemps à se libèrer... ce qui engendre un nombre de slot occupés bien plus important. Bref, en un rien de temps il n'y a plus de "place".

    Pour vérifier ça, en ligne de commande, quelque chose comme ça devrait aider :
    Code:
    apachectl status
    Et pour corriger : descendre le keepalived_timeout à 5 secondes ou carrément désactiver le keepalived si cela devient critique, augmenter le max client (attention à la mémoire consommée) tou t en augmentant proportionnellement les start / min_spare et max_spare.

    Si toujours rien n'y fait, remplacer Apache par lighttpd (quitte à déporter les videos sur un autre serveur), ou bien les transfèrer via FTP.
     
  6. Nathanos
    Nathanos Nouveau WRInaute
    Inscrit:
    20 Juin 2006
    Messages:
    1
    J'aime reçus:
    0
    Bonjour,

    J'ai le même problème mais sous apache2. Pourrais-je savoir où sont les lignes à modifier pour que le apache arrete de "ramer" svp? (fichier et ligne si possible).


    Merci

    Nathanos.
     
  7. osilade
    osilade Nouveau WRInaute
    Inscrit:
    29 Septembre 2005
    Messages:
    47
    J'aime reçus:
    0
    j'ai le meme probleme et j'essai des trucs mais pour l'instant cela n'est pas trés probant. Si je relance le serveur apache cela va speedé pendant quelques temps et puis petit a petit (moins d'une heure cependant) mon serveur va ramer comme un fou. J'essai un peu tout les trucs que je vois sur les forums mais pour le moment je n'ai pas trouvé "LE" truc ultime pour maitriser ca.
     
  8. Robinson
    Robinson WRInaute passionné
    Inscrit:
    26 Octobre 2005
    Messages:
    1 636
    J'aime reçus:
    0
    Vérifie ton espace disque et ta mémoire.
     
  9. osilade
    osilade Nouveau WRInaute
    Inscrit:
    29 Septembre 2005
    Messages:
    47
    J'aime reçus:
    0
    bon la mémoire cela peut etre un probleme j'ai 512 Mo pour l'espace disque j'ai 60 Go de libre donc de se coté la cela devrait aller.
     
  10. biddybulle
    biddybulle WRInaute passionné
    Inscrit:
    30 Mai 2005
    Messages:
    1 428
    J'aime reçus:
    0
    C'est pas ton swap qui serait un peu trop juste. Du coup au début tout va bien et comme il a pas le temps de se vider par rapport au besoin de mémoire qui augmente et bien il y a un moment ou ton serveur dédié finit par swapper en permanence d'ou une lenteur excécrable.
     
  11. Robinson
    Robinson WRInaute passionné
    Inscrit:
    26 Octobre 2005
    Messages:
    1 636
    J'aime reçus:
    0
    60Go de libre ok... mais tu possèdes certainement des partitions, vérifie chacune d'elle. Il m'est déjà arrivé des problèmes similaires.
     
Chargement...
Similar Threads - Probleme serveur dédié Forum Date
Probléme de serveur dédié, 400€ de réparation ? Administration d'un site Web 11 Décembre 2012
Problème emailing de mon serveur dédié Administration d'un site Web 20 Février 2011
Probleme de PHP sur serveur dédié Administration d'un site Web 24 Février 2009
Serveur dédié OVH. Probleme technique Administration d'un site Web 12 Avril 2008
Problème avec un serveur dédié OVH (MG CORE2QUAD) Administration d'un site Web 24 Janvier 2008
Problème sur les serveurs dédiés OVH ? Administration d'un site Web 25 Septembre 2007
Probléme sérveur dédié debian sarge Demandes d'avis et de conseils sur vos sites 31 Mars 2007
Problème serveur dédié Administration d'un site Web 22 Juillet 2006
Problème de sous domaine sur serveur dédié Administration d'un site Web 30 Mars 2006
Probleme serveur dedié Administration d'un site Web 15 Mars 2006
[Serveur dédié] RAM dispo et Problème de swap Administration d'un site Web 13 Septembre 2005
Problème méga urgent (serveur dédié) Administration d'un site Web 30 Mars 2005
Problème d'heure sur un serveur dédié Administration d'un site Web 29 Mars 2004
Problème serveur connexion simultanée Administration d'un site Web 19 Janvier 2022
Problème de temps de réponse serveur entre 2 site hébergé sur le même serveur Administration d'un site Web 22 Mars 2017
Problème avec le nouveau serveur Crawl et indexation Google, sitemaps 27 Août 2015
Problème de connectivité au serveur Problèmes de référencement spécifiques à vos sites 2 Juin 2014
Problème serveur mail suite changement DNS Administration d'un site Web 21 Novembre 2013
Probléme de serveur bloqué Problèmes de référencement spécifiques à vos sites 15 Novembre 2012
Probleme sous domaine vers autre site du serveur Administration d'un site Web 22 Octobre 2012