1. ✅ Apprenez une METHODE qui marche pour votre SEO ! Formation à distance avec Olivier Duffez et Fabien Facériès + aide pour prise en charge du financement
    Rejeter la notice

Problemes avec les é quant j'affiche le code sour

Discussion dans 'Problèmes de référencement spécifiques à vos sites' créé par klendrier, 17 Mai 2008.

  1. klendrier
    klendrier WRInaute discret
    Inscrit:
    20 Août 2005
    Messages:
    69
    J'aime reçus:
    0
    Bonjour,
    Voici tout d'abord le header de mon site:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <meta http-equiv="Content-Script-Type" content="text/javascript" />
    <meta http-equiv="Content-Style-Type" content="text/css" />
    <link rel="shortcut icon" type="image/png" href="/favicon.png" />
    <title>Mon titre</title>

    Tout mes caractères spéciaux type "é, è , à" sont codés en "&eacute;, &eagrav;" etc...
    Ma page s'affiche correctement et est valide W3C...
    En revanche lorsque j'affiche le code source de ma page dans IE ou Firefox, je vois plein de &eacute, &eagrav; .... J'ai tester sur d'autres sites avec le meme Doctpe que le mien et leur code source s'affiche correctement!
    Après une heure de recherche sans succès je m'en remets à vous pour explique ce phénomene bizarre...
    En fait je ne vodrais pas que Google vois aussi tous ces &eacute ! ce qui serait pas du tout bon pour le ref!
    Merci pour votre aide.
     
  2. Marie-Aude
    Marie-Aude WRInaute accro
    Inscrit:
    5 Juin 2006
    Messages:
    16 368
    J'aime reçus:
    2
    Ton code source s'affiche sans codage, tel que tu l'as saisi.
    Les sites qui s'affichent "correctement" ont donc saisi dans le code source un é et pas un &eacute;
     
  3. YoyoS
    YoyoS WRInaute accro
    Inscrit:
    14 Septembre 2006
    Messages:
    3 249
    J'aime reçus:
    0
    Il faut coder les accents avec des codes de type &eacute; pour un encodage iso-jesaispukoi

    Hors toi, tu as un encodage en utf-8 et tu n'as pas à encoder tes caractères, tu as juste à taper é pour écrire é :)
     
Chargement...
Similar Threads - Problemes &eacute quant Forum Date
Search Console Problèmes chargements images Crawl et indexation Google, sitemaps 3 Septembre 2020
Problème OVH et Problèmes de WHOIS Demandes d'avis et de conseils sur vos sites 30 Avril 2020
Problèmes des redirections 301 en transparence Noms de domaine et référencement 12 Mars 2020
Problèmes migration NDD Crawl et indexation Google, sitemaps 21 Février 2020
Search Console Premier référencement et problèmes Débuter en référencement 11 Novembre 2019
Test d'optimisation mobile : Problèmes de chargement de la page Débuter en référencement 10 Novembre 2019
Problèmes d'indexation et robots.txt Crawl et indexation Google, sitemaps 14 Octobre 2019
Problèmes 'Produits' dans Search Console Référencement Google 24 Février 2019
Analyse google search console : liste des problèmes d'indexation Crawl et indexation Google, sitemaps 13 Janvier 2019
Problèmes d'indexation à cause de ressources bloquées (robots.xt) Crawl et indexation Google, sitemaps 22 Novembre 2018