[Résolu] Pb affichage sous Mac

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par opale-cia, 10 Juillet 2006.

  1. opale-cia
    opale-cia WRInaute occasionnel
    Inscrit:
    27 Juillet 2005
    Messages:
    307
    J'aime reçus:
    0
    Bonjour,

    J'ai un petit problème d'affichage du site -http://www.alaingodon.com sous mac, l'image du header et du footer n'apparait pas.

    Si les mac user de WRI pouvaient confirmer... et si qqun a une solution à proposer...

    Merci
     
  2. davman
    davman WRInaute discret
    Inscrit:
    7 Janvier 2005
    Messages:
    96
    J'aime reçus:
    0
    je confirme, je ne vois pas les images non plus sous safari, mais ça marche sous IE

    peut-être que Safari a du mal avec les CSS ?
    Pas assez calé pour te dire...
     
  3. opale-cia
    opale-cia WRInaute occasionnel
    Inscrit:
    27 Juillet 2005
    Messages:
    307
    J'aime reçus:
    0
    Merci de ta réponse, c'est deja pas mal que ca marche sous IE
     
  4. Lord_Coder
    Lord_Coder WRInaute discret
    Inscrit:
    15 Avril 2006
    Messages:
    118
    J'aime reçus:
    0
    Il ya une très grande erreur dans ton css , encadre les chemins vers les images avec deux guillemets ( ou apostrophes ), pour plus d'infos sur l'erreur , valide ton CSS avec w3.org .
    En effet , il vaut mieux faire url('image.png') au lieu de url(image.png) , car ce dernier pose de gros problémes avec certains navigateurs !
     
  5. opale-cia
    opale-cia WRInaute occasionnel
    Inscrit:
    27 Juillet 2005
    Messages:
    307
    J'aime reçus:
    0
    Merci Lord_Coder, je pense que ça venait de là...

    J'adore la réactivité de ce forum.
     
  6. Lord_Coder
    Lord_Coder WRInaute discret
    Inscrit:
    15 Avril 2006
    Messages:
    118
    J'aime reçus:
    0
    Euh de rien , mais il faut que tu valides aussi ta page HTML pour qu'elle ne posera pas aussi des problémes de compatibilité , en effet , elle a 18 erreurs , valide-la avec ce validateur -http://validator.w3.org/ , les premiéres erreurs que tu vas trouver sont à cause du signe & dans tes URLs , tu dois alors l'écrire comme ça & et pas & , car y a dans tes URLs des paramétres après le & comme img , donc certains navigateurs vont penser que &img est un caractére spécial , mais vu qu'il n'existe pas , il vont rencontrer une erreur , &img me parrait juste .

    Si tu veux que les erreurs soient automatiquement corrigées , tu pourra télécharger l'extension HTML Tidy pour FireFox .
    Si tu vois qu'elle indique des warnings , ça veut dire que ces erreurs peuvent être corrigées avec HTML Tidy , mais si ça indique error , donc l'erreur est compliqué et ne peut pas être corrigée automatiquement , donc c'est à toi de la corriger .
     
Chargement...
Similar Threads - [Résolu] affichage Forum Date
RSS, affichage de texte provenant d'un fichier externe [résolu] Développement d'un site Web ou d'une appli mobile 14 Décembre 2008
Prb d'affichage des couleurs sous firefox [RESOLU] Développement d'un site Web ou d'une appli mobile 8 Août 2007
Mod phpbb affichage derniers messages du forum [Résolu] Développement d'un site Web ou d'une appli mobile 12 Juillet 2007
[résolu]Problème affichage DIV sous Firefox Développement d'un site Web ou d'une appli mobile 15 Avril 2007
[résolu] Encore un mauvais affichage sous IE Développement d'un site Web ou d'une appli mobile 28 Mars 2007
[résolu] Problème d'affichage (IE/firefox) avec images Développement d'un site Web ou d'une appli mobile 16 Janvier 2007
[resolu] affichage des chiffres apres la virgule Développement d'un site Web ou d'une appli mobile 26 Juin 2006
[Résolu]Problème affichage numéro Développement d'un site Web ou d'une appli mobile 19 Avril 2006
CSS: pb affichage avec des liens secondaire[RESOLU] Développement d'un site Web ou d'une appli mobile 10 Avril 2006
[RESOLU] Affichage de liens seulement pour l'Admin sur phpBB Développement d'un site Web ou d'une appli mobile 12 Janvier 2006
Spip - Affichage bizarre [résolu] Administration d'un site Web 10 Mai 2005
Problème affichage [résolu] Administration d'un site Web 20 Avril 2005
Problème images en https (forum phpbb) [résolu] Développement d'un site Web ou d'une appli mobile 18 Novembre 2017
[Résolu] Redirection 301 FR vers EN sur Prestashop uniquement sur outils Google ? Problèmes de référencement spécifiques à vos sites 11 Septembre 2017
[résolu] Passage à HTTPS, comment tester une page ? Développement d'un site Web ou d'une appli mobile 7 Septembre 2017
[Résolu] Redirection d'une famille d'URL URL Rewriting et .htaccess 9 Mars 2017
[Résolu] Diaporama et SEO Débuter en référencement 17 Janvier 2017
[résolu]Redirection monsite.fr/index.html sur monsite.fr et seo URL Rewriting et .htaccess 16 Janvier 2017
[resolu]Publicité facebook lié au compte instagram Facebook 12 Décembre 2016
[résolu] Récupérer des valeurs issues de javascript pour les mettre en base MySQL Développement d'un site Web ou d'une appli mobile 18 Juillet 2016