[résolu] Problem avec un background image

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par h4ni, 30 Décembre 2007.

  1. h4ni
    h4ni WRInaute occasionnel
    Inscrit:
    11 Juillet 2005
    Messages:
    427
    J'aime reçus:
    0
    Bonsoir,
    dans le header de mon site (ce dernier a une resolution 1024) j'affiche un background de 1440px * 255px ( il es assez large pour la comptabilité avec les grands ecrans)
    et je l'affiche en css de cette manniere
    Code:
    .header {
    	background-image: url(images/bg2.jpg);
    	background-position:center;
    	background-repeat: no-repeat;
    	height: 225px;
    	width: 100%;
    
    seulement j'ai un problem avec la resolution 800x600, le header se deforme et le background ne reste pas dans sa place

    quelqu'un a une idée?


    Edit: problem resolu , un min-width a fais l'afaire
     
  2. acamar
    acamar WRInaute passionné
    Inscrit:
    27 Novembre 2005
    Messages:
    1 334
    J'aime reçus:
    0
    S'il se déforme à 800 px il se déformera avant en 1024 ou 1280 px, non ? :roll:
     
  3. h4ni
    h4ni WRInaute occasionnel
    Inscrit:
    11 Juillet 2005
    Messages:
    427
    J'aime reçus:
    0
    le site est avec une resolution 1024 , il s'affiche bien avec les resolutioon 1024 --> 1440
    mais avec une resolution moin de 1024 , tout se deforme
     
  4. acamar
    acamar WRInaute passionné
    Inscrit:
    27 Novembre 2005
    Messages:
    1 334
    J'aime reçus:
    0
    Il faut peut être chercher à imposer la largeur 1024 px, comme ça avec un 800 px apparaitra un scroll horizontal sans subir de déformation !
     
  5. h4ni
    h4ni WRInaute occasionnel
    Inscrit:
    11 Juillet 2005
    Messages:
    427
    J'aime reçus:
    0
    Re
    si j'enleve le width: 100%; et je met un 995, ca marchera tres bien avec la resolution 800x600 et 1024 , mais pas avec les resolutions supers a 1024 :(
     
  6. acamar
    acamar WRInaute passionné
    Inscrit:
    27 Novembre 2005
    Messages:
    1 334
    J'aime reçus:
    0
    En gros, t'as pas à trop te soucier du 800x600 ça diminue de plus en plus.. si c'est pas très agréable c'est pas grave mais il faut tout de même que ça soit un peu décent :)
     
  7. jf_evreux
    jf_evreux WRInaute discret
    Inscrit:
    17 Décembre 2005
    Messages:
    169
    J'aime reçus:
    0
    +1 moi je developpe mini pour du 1024 maintenant, avec du contenu en 990px...Tant pis pour les retardataires
     
  8. h4ni
    h4ni WRInaute occasionnel
    Inscrit:
    11 Juillet 2005
    Messages:
    427
    J'aime reçus:
    0
    le problem c que ca deforme tout le site :(
     
  9. bproductiv
    bproductiv WRInaute accro
    Inscrit:
    27 Décembre 2004
    Messages:
    3 672
    J'aime reçus:
    0
  10. nickargall
    nickargall WRInaute accro
    Inscrit:
    13 Juin 2005
    Messages:
    6 601
    J'aime reçus:
    4
    min width est la solution pour Firefox, mais seul il ne fonctionnera pas avec IE6 (Le 7 je sais plus) qui ne le reconnaît pas.

    Il y a un morceau de javascript qui ira très bien pour ce problème :

    Dans le head de chaque page
    Code:
    <script type="text/javascript" src="/jscripts/minmax.js"></script>
    Et le fichier minmax.js rattaché :
    euh je place pas le code, mais vous pouvez entre autres le récupérer ici:
    -http://www.yapeno.com/jscripts/minmax.js
     
  11. h4ni
    h4ni WRInaute occasionnel
    Inscrit:
    11 Juillet 2005
    Messages:
    427
    J'aime reçus:
    0
    je vien d'essayer! ca marche tres bien :)
    Merci
     
Chargement...
Similar Threads - [résolu] Problem background Forum Date
Problème images en https (forum phpbb) [résolu] Développement d'un site Web ou d'une appli mobile 18 Novembre 2017
[RESOLU] probleme d'indexation des pages en httpS Crawl et indexation Google, sitemaps 20 Mars 2012
[Résolu] Problème d'importation de base MySQL en UTF8 chez 1&1 Administration d'un site Web 3 Juillet 2011
[Résolu] Problème pour gérer 2 campagnes AdWords 17 Novembre 2010
[RESOLU] Probleme d'erreur 302 non voulue Développement d'un site Web ou d'une appli mobile 30 Mai 2010
[Résolu] Problème de remonté de stats de campagne mails via GA Google Analytics 13 Mai 2010
[RESOLU]probleme lors de l'update des informations Développement d'un site Web ou d'une appli mobile 7 Avril 2010
[RESOLU] probleme de tri descendant de tableau ... Développement d'un site Web ou d'une appli mobile 4 Avril 2010
[résolu] Problème sur certains navigateurs ? Développement d'un site Web ou d'une appli mobile 16 Octobre 2009
probleme area="poly" et placement de div [RESOLU] Développement d'un site Web ou d'une appli mobile 8 Octobre 2009
[RESOLU] Problème avec PHPMAILER (apparition des headers dans le message) Développement d'un site Web ou d'une appli mobile 31 Juillet 2009
Problème URL Rewriting complexe avec les dossiers rééls et les autres chemins [Résolu] URL Rewriting et .htaccess 16 Juin 2009
[Résolu] Problème de onbeforeunload / frame Développement d'un site Web ou d'une appli mobile 12 Juin 2009
[Resolu]Probleme soumission boutique 1and1 Problèmes de référencement spécifiques à vos sites 25 Mai 2009
[résolu] problème de variables chez OVH Développement d'un site Web ou d'une appli mobile 21 Février 2009
[résolu] problème php chez OVH Développement d'un site Web ou d'une appli mobile 9 Février 2009
[RESOLU] Problème de redirection permanente URL Rewriting et .htaccess 18 Janvier 2009
Probleme de formulaire [Résolu] Développement d'un site Web ou d'une appli mobile 18 Janvier 2009
[résolu] Problème avec preg_replace (le point) Développement d'un site Web ou d'une appli mobile 6 Janvier 2009
[résolu] Problème de téléchargent de fichiers .ttf, .rar ... Administration d'un site Web 26 Novembre 2008