[RéSOLU] problème de <div> sous wordpress

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par kiev, 5 Mars 2007.

  1. kiev
    kiev Nouveau WRInaute
    Inscrit:
    3 Janvier 2007
    Messages:
    3
    J'aime reçus:
    0
    RéSOLU !

    Je suis entrain de préparer un site sous wordpress et
    j'ai un problème avec la répétition du fond d'une <div> avec internet explorer (impeccable sous Firefox)
    Le fond bleu qui devrait apparaitre juste dans la colonne de droite se répète sur la largeur de la page :?
    Est ce que quelqu'un peut m'aider svp ?

    vous pouvez tester le problème ici (utilisez IE)

    voici un morceau du code du "sidebar" :
    Code:
    <div id="rightcol">
    <div class="sidebox">
    				<h3 id="categories">Categories</h3>
    				<ul><?php wp_list_cats('sort_column=name&optioncount=1&hierarchical=0'); ?>
    				</ul>
    				<div class="bottom"></div>
    			</div>
    	                <hr />
    ....
    Et du css :
    Code:
    #rightcol {
    float: right;
    float: top;
    display: inline;
    width: 233px;
    margin: 0 0 0 13px;
    }
    
    #rightcol ul {
    list-style: none;
    }
    
    .sidebox {
    background: #cccccc url("images/bg-sidebox-middle.gif") top left;
    border-bottom: 20px solid #FFF;
    }
    
    .sidebox h3#categories {
    background: #FFF url("images/bg-sidebox-categories.gif") top left;
    height: 59px;
    text-indent: -9999px;
    }
     
  2. kiev
    kiev Nouveau WRInaute
    Inscrit:
    3 Janvier 2007
    Messages:
    3
    J'aime reçus:
    0
    J'ai résolu ça en ajoutant
    Code:
    width: 233px;
    à
    Code:
    .sidebox {
    background: #cccccc url("images/bg-sidebox-middle.gif") top left;
    border-bottom: 20px solid #FFF;
    }
     
Chargement...
Similar Threads - [RéSOLU] problème <div> Forum Date
Problème images en https (forum phpbb) [résolu] Développement d'un site Web ou d'une appli mobile 18 Novembre 2017
[RESOLU] probleme d'indexation des pages en httpS Crawl et indexation Google, sitemaps 20 Mars 2012
[Résolu] Problème d'importation de base MySQL en UTF8 chez 1&1 Administration d'un site Web 3 Juillet 2011
[Résolu] Problème pour gérer 2 campagnes AdWords 17 Novembre 2010
[RESOLU] Probleme d'erreur 302 non voulue Développement d'un site Web ou d'une appli mobile 30 Mai 2010
[Résolu] Problème de remonté de stats de campagne mails via GA Google Analytics 13 Mai 2010
[RESOLU]probleme lors de l'update des informations Développement d'un site Web ou d'une appli mobile 7 Avril 2010
[RESOLU] probleme de tri descendant de tableau ... Développement d'un site Web ou d'une appli mobile 4 Avril 2010
[résolu] Problème sur certains navigateurs ? Développement d'un site Web ou d'une appli mobile 16 Octobre 2009
probleme area="poly" et placement de div [RESOLU] Développement d'un site Web ou d'une appli mobile 8 Octobre 2009
[RESOLU] Problème avec PHPMAILER (apparition des headers dans le message) Développement d'un site Web ou d'une appli mobile 31 Juillet 2009
Problème URL Rewriting complexe avec les dossiers rééls et les autres chemins [Résolu] URL Rewriting et .htaccess 16 Juin 2009
[Résolu] Problème de onbeforeunload / frame Développement d'un site Web ou d'une appli mobile 12 Juin 2009
[Resolu]Probleme soumission boutique 1and1 Problèmes de référencement spécifiques à vos sites 25 Mai 2009
[résolu] problème de variables chez OVH Développement d'un site Web ou d'une appli mobile 21 Février 2009
[résolu] problème php chez OVH Développement d'un site Web ou d'une appli mobile 9 Février 2009
[RESOLU] Problème de redirection permanente URL Rewriting et .htaccess 18 Janvier 2009
Probleme de formulaire [Résolu] Développement d'un site Web ou d'une appli mobile 18 Janvier 2009
[résolu] Problème avec preg_replace (le point) Développement d'un site Web ou d'une appli mobile 6 Janvier 2009
[résolu] Problème de téléchargent de fichiers .ttf, .rar ... Administration d'un site Web 26 Novembre 2008