[Résolu] Problème de onbeforeunload / frame

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par bidulemachin, 12 Juin 2009.

  1. bidulemachin
    bidulemachin WRInaute discret
    Inscrit:
    5 Octobre 2007
    Messages:
    100
    J'aime reçus:
    0
    Bonjour à tous,

    J'ai un petit soucis : J'ai un formulaire contenant une iframe. Dans le body de ce formulaire j'ai placé un onbeforeunload pour éviter que l'utilisateur quitte la page maloncontreusement. Tout marche parfaitement sauf quand j'essaie de mettre à jour l'iframe. En effet, je change par un bouton javascript l'URL de mon iframe et l'alerte se déclenche aussitôt! Aucun problème sous firefox mais évidemment sous IE, l'alerte s'affiche automatiquement dès que je veux mettre mon iframe à jour !

    Merci d'avance pour votre aide !
     
  2. bidulemachin
    bidulemachin WRInaute discret
    Inscrit:
    5 Octobre 2007
    Messages:
    100
    J'aime reçus:
    0
    Re: Problème de onbeforeunload / frame

    Sujet résolu !

    J'avais mis un href="javascript:" sur le bouton qui appelait la frame, donc il pensait que ça quitter la page !
     
Chargement...
Similar Threads - [Résolu] Problème onbeforeunload Forum Date
Problème images en https (forum phpbb) [résolu] Développement d'un site Web ou d'une appli mobile 18 Novembre 2017
[RESOLU] probleme d'indexation des pages en httpS Crawl et indexation Google, sitemaps 20 Mars 2012
[Résolu] Problème d'importation de base MySQL en UTF8 chez 1&1 Administration d'un site Web 3 Juillet 2011
[Résolu] Problème pour gérer 2 campagnes AdWords 17 Novembre 2010
[RESOLU] Probleme d'erreur 302 non voulue Développement d'un site Web ou d'une appli mobile 30 Mai 2010
[Résolu] Problème de remonté de stats de campagne mails via GA Google Analytics 13 Mai 2010
[RESOLU]probleme lors de l'update des informations Développement d'un site Web ou d'une appli mobile 7 Avril 2010
[RESOLU] probleme de tri descendant de tableau ... Développement d'un site Web ou d'une appli mobile 4 Avril 2010
[résolu] Problème sur certains navigateurs ? Développement d'un site Web ou d'une appli mobile 16 Octobre 2009
probleme area="poly" et placement de div [RESOLU] Développement d'un site Web ou d'une appli mobile 8 Octobre 2009
[RESOLU] Problème avec PHPMAILER (apparition des headers dans le message) Développement d'un site Web ou d'une appli mobile 31 Juillet 2009
Problème URL Rewriting complexe avec les dossiers rééls et les autres chemins [Résolu] URL Rewriting et .htaccess 16 Juin 2009
[Resolu]Probleme soumission boutique 1and1 Problèmes de référencement spécifiques à vos sites 25 Mai 2009
[résolu] problème de variables chez OVH Développement d'un site Web ou d'une appli mobile 21 Février 2009
[résolu] problème php chez OVH Développement d'un site Web ou d'une appli mobile 9 Février 2009
[RESOLU] Problème de redirection permanente URL Rewriting et .htaccess 18 Janvier 2009
Probleme de formulaire [Résolu] Développement d'un site Web ou d'une appli mobile 18 Janvier 2009
[résolu] Problème avec preg_replace (le point) Développement d'un site Web ou d'une appli mobile 6 Janvier 2009
[résolu] Problème de téléchargent de fichiers .ttf, .rar ... Administration d'un site Web 26 Novembre 2008
[Résolu] Problème de cache ou d'historique Administration d'un site Web 8 Octobre 2008