[Résolu]Problème de soulignement dans un menu

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par phandil, 9 Juillet 2007.

  1. phandil
    phandil Nouveau WRInaute
    Inscrit:
    21 Juillet 2006
    Messages:
    19
    J'aime reçus:
    0
    Voilà j'ai un petit problème de soulignement dans mon menu du haut

    --> http://www.gagnerdesthunes.info

    certaines rubriques sont souligné, d'autres non et ca varie en fonction du naviguateur.

    Le code de la page:



    Code:
    <div id="site">
    <div id="top">
        <div id="nav">
    	    <ul>
    		    <li class="nav1"><a href="http://www.gagnerdesthunes.info" title="">Accueil</a></li>
    		    <li class="nav2"><a href="http://www.druly.fr/164" title="">Recherches</a></li>
    		    <li class="nav3"><a href="http://www.goodemails.com/index.php?ref=phandil" title="">PTC</a></li>
    		    <li class="nav4"><a href="mailto:[email protected]" title="">Contact</a></li>
    	    </ul>
        </div>
    </div>
    
    dans le fichier CSS, exemple pour une rubrique:

    Code:
    #nav {
    	font-size: 11px;
    	width: 800px;
    	position: absolute;
    	top: 0px;
    	left: 0px;
    }
    
    #nav ul {
    	list-style: none;
    	padding: 0;
    	margin: 0;
    }
    
    #nav li {
    	background: none;
    }
    
    .nav1 a:link, .nav1 a:visited {
    	color: #fc2b02;
    	font-size: 11px;
    	font-weight: bold;
    	position: absolute;
    	top: 47px;
    	left: 65px;
    }
    
    .nav1 a:hover, .nav1 a:active {
    	color: #0F1D4B;
    	text-decoration: underline;
    	font-weight: bold;    
    }
    
    
    merci de votre aide
     
  2. bgdc
    bgdc WRInaute impliqué
    Inscrit:
    23 Mai 2005
    Messages:
    536
    J'aime reçus:
    0
    c'est normal nav1, nav2, nav3, nav4 ???
     
  3. phandil
    phandil Nouveau WRInaute
    Inscrit:
    21 Juillet 2006
    Messages:
    19
    J'aime reçus:
    0
    pour que ce soit compataible w3c je dois mettre un id différent à chque fois donc oui c normal nav1,nav2,nav3 et nav4

    mais la structure dans la feuille css et la même pour tous
     
  4. jarreweb
    jarreweb WRInaute discret
    Inscrit:
    12 Septembre 2003
    Messages:
    185
    J'aime reçus:
    0
    là tu as mis des noms de "class" différents, ce n'est pas la meme chose
     
  5. titifrim
    titifrim WRInaute occasionnel
    Inscrit:
    21 Mars 2006
    Messages:
    267
    J'aime reçus:
    0
    text-decoration: none; est ton amie (à placer dans la partie a:link) par contre quel intérêt de créer une classe différente pour chaque lien. Il n'y a que les ID qui nécessitent une utilisation unique...
     
  6. phandil
    phandil Nouveau WRInaute
    Inscrit:
    21 Juillet 2006
    Messages:
    19
    J'aime reçus:
    0
    génial ca fontionne merci titifrim !!!!

    pour répondre à vos questions, c'est un kit graphique avec une base xhtml que je suis en train d'adapter

    la feuille css était déjà placé et je n'ai modifié que les parties importantes au fur et à mesures.

    c'est mon premier site xhtml donc j'apprend, soyez indulgent lol!

    merci encore pour la solution
     
  7. titifrim
    titifrim WRInaute occasionnel
    Inscrit:
    21 Mars 2006
    Messages:
    267
    J'aime reçus:
    0
    à ton service :wink:
     
Chargement...
Similar Threads - [Résolu]Problème soulignement menu Forum Date
[RESOLU]probleme lors de l'update des informations Développement d'un site Web ou d'une appli mobile 7 Avril 2010
[Resolu]Probleme soumission boutique 1and1 Problèmes de référencement spécifiques à vos sites 25 Mai 2009
[Résolu]Problème avec Ajax Développement d'un site Web ou d'une appli mobile 23 Août 2008
[résolu]Problème insoluble avec un ORBER BY Développement d'un site Web ou d'une appli mobile 15 Juillet 2008
[Resolu]Probleme installation forum PHPBB Développement d'un site Web ou d'une appli mobile 11 Juillet 2008
[résolu]problème d'indexation url finissant par /1 Crawl et indexation Google, sitemaps 20 Juin 2008
[Résolu]Problèmes d'accent dans le Flux RSS Développement d'un site Web ou d'une appli mobile 29 Mai 2008
[Résolu]Problème de syntaxe pour une RewriteRule URL Rewriting et .htaccess 5 Mai 2008
[résolu]Probleme serveur chez ovh Administration d'un site Web 5 Janvier 2008
[résolu]probleme de recuperation des checkbox Développement d'un site Web ou d'une appli mobile 31 Décembre 2007
[Résolu]Problème avec imagerotate() Développement d'un site Web ou d'une appli mobile 30 Décembre 2007
[résolu]problème d'une simple redirection .php en .html URL Rewriting et .htaccess 27 Août 2007
[Résolu]Problème menu en fonction du naviguateur Développement d'un site Web ou d'une appli mobile 30 Juin 2007
[RESOLU]Probleme tres simple CSS menu Développement d'un site Web ou d'une appli mobile 28 Juin 2007
[resolu]problème css IE6 Développement d'un site Web ou d'une appli mobile 6 Juin 2007
[résolu]Problème affichage DIV sous Firefox Développement d'un site Web ou d'une appli mobile 15 Avril 2007
[resolu]Problème FCKeditor Développement d'un site Web ou d'une appli mobile 7 Août 2006
[Resolu]Problème activex flash Développement d'un site Web ou d'une appli mobile 1 Juin 2006
[Résolu]Problème affichage numéro Développement d'un site Web ou d'une appli mobile 19 Avril 2006
[Résolu]Problème JS - replace Développement d'un site Web ou d'une appli mobile 21 Mars 2006