[resolu]Problème FCKeditor

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par lsteamgeo, 7 Août 2006.

  1. lsteamgeo
    lsteamgeo Nouveau WRInaute
    Inscrit:
    23 Novembre 2005
    Messages:
    14
    J'aime reçus:
    0
    Bonjour à tous, j'aurai besoin de votre aide parceque là je ne comprend pas du tout ce qu'il se passe!
    J'ai intégré FCKEditor dans une page PHP sauf qu'au lieu de m'afficher la "TEXTAREA" de FCKEditor ça m'affiche ma page index. Pourtant lorsque je fais un view source de la page en question, il apparait bien le code de la TEXTAREA. Si quelqu'un à une idée. Merci d'avance.

    la page qui contient FCKeditor :
    Code:
    require("FCKeditor/fckeditor.php") ;
    $oFCKeditor = new FCKeditor('mod_texte_edito') ;
    $oFCKeditor->BasePath = 'FCKeditor/';
    //$oFCKeditor->ToolbarSet = 'defaut';
    $oFCKeditor->Width = '80%';
    $oFCKeditor->Value = "valeur par defaut";
    $oFCKeditor->Create() ;
    le view source de la page m'affiche bien ce qui devrait s'afficher normalement à l'écran
    Code:
    <div>
    <input type="hidden" id="mod_texte_edito" name="mod_texte_edito" value="valeur par defaut" style="display:none" />
    <input type="hidden" id="mod_texte_edito___Config" value="" style="display:none" />
    <iframe id="mod_texte_edito___Frame" src="FCKeditor/editor/fckeditor.html?InstanceName=mod_texte_edito&amp;Toolbar=Default" width="80%" height="200" frameborder="0" scrolling="no"></iframe>
    </div>
    Malgré tout, c'est ma page index.php qui s'affiche à la place du textearea.... Je ne comprend pas pourquoi. HELP........... 8O
     
  2. lsteamgeo
    lsteamgeo Nouveau WRInaute
    Inscrit:
    23 Novembre 2005
    Messages:
    14
    J'aime reçus:
    0
    Personne n'aurait une idée?
     
  3. lsteamgeo
    lsteamgeo Nouveau WRInaute
    Inscrit:
    23 Novembre 2005
    Messages:
    14
    J'aime reçus:
    0
    Visiblement ça vient de mon htaccess, j'ai une règle qui fait "planter" FCKeditor. :

    Code:
    RewriteRule ([a-zA-Z]+)\.html$ index.php?rub=$1 [L]
    Mon htaccess se trouve à la racine de mon site alors que FCKeditor se trouve dans un sous dossier(admin) et n'a rien a voir avec les liens que je crée à l'aide de ce htacess. Comment dois-je faire pour que le htaccess ne s'applique pas à FCKeditor? Merci de votre aide.
     
  4. lsteamgeo
    lsteamgeo Nouveau WRInaute
    Inscrit:
    23 Novembre 2005
    Messages:
    14
    J'aime reçus:
    0
    C'est bon, j'ai tout simplement crée un htaccess vierge dans le sous dossier dans lequel se trouve FCKeditor. @+
     
Chargement...
Similar Threads - [resolu]Problème FCKeditor Forum Date
[RESOLU]probleme lors de l'update des informations Développement d'un site Web ou d'une appli mobile 7 Avril 2010
[Resolu]Probleme soumission boutique 1and1 Problèmes de référencement spécifiques à vos sites 25 Mai 2009
[Résolu]Problème avec Ajax Développement d'un site Web ou d'une appli mobile 23 Août 2008
[résolu]Problème insoluble avec un ORBER BY Développement d'un site Web ou d'une appli mobile 15 Juillet 2008
[Resolu]Probleme installation forum PHPBB Développement d'un site Web ou d'une appli mobile 11 Juillet 2008
[résolu]problème d'indexation url finissant par /1 Crawl et indexation Google, sitemaps 20 Juin 2008
[Résolu]Problèmes d'accent dans le Flux RSS Développement d'un site Web ou d'une appli mobile 29 Mai 2008
[Résolu]Problème de syntaxe pour une RewriteRule URL Rewriting et .htaccess 5 Mai 2008
[résolu]Probleme serveur chez ovh Administration d'un site Web 5 Janvier 2008
[résolu]probleme de recuperation des checkbox Développement d'un site Web ou d'une appli mobile 31 Décembre 2007
[Résolu]Problème avec imagerotate() Développement d'un site Web ou d'une appli mobile 30 Décembre 2007
[résolu]problème d'une simple redirection .php en .html URL Rewriting et .htaccess 27 Août 2007
[Résolu]Problème de soulignement dans un menu Développement d'un site Web ou d'une appli mobile 9 Juillet 2007
[Résolu]Problème menu en fonction du naviguateur Développement d'un site Web ou d'une appli mobile 30 Juin 2007
[RESOLU]Probleme tres simple CSS menu Développement d'un site Web ou d'une appli mobile 28 Juin 2007
[resolu]problème css IE6 Développement d'un site Web ou d'une appli mobile 6 Juin 2007
[résolu]Problème affichage DIV sous Firefox Développement d'un site Web ou d'une appli mobile 15 Avril 2007
[Resolu]Problème activex flash Développement d'un site Web ou d'une appli mobile 1 Juin 2006
[Résolu]Problème affichage numéro Développement d'un site Web ou d'une appli mobile 19 Avril 2006
[Résolu]Problème JS - replace Développement d'un site Web ou d'une appli mobile 21 Mars 2006