[Résolu] Problème includes php-répertoire des images en HTML

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par athoms, 10 Octobre 2005.

  1. athoms
    athoms WRInaute discret
    Inscrit:
    22 Avril 2004
    Messages:
    212
    J'aime reçus:
    0
    Bonjour à tous!

    Apparemment je me fais vieux en html ;)
    Je suis bloqué sur un problème (qui à mon avis vous paraitra surement très simple), merci à ceux qui auront une solution.

    Voici donc mon problème :
    J'ai un fichier php et un repertoire images stockés dans un répertoire. dans ce repertoire j'ai un sous repertoire, qu'on va appeler folder, contenant des scripts php.
    chacun fait un appel en php du genre
    include ("../toto.php"). Jusque là pas de problème.
    Cependant ce fichier toto.php affiche des image. Je fais donc en HTML des IMG SRC="images/machin.gif" dans ce fichier. Or le dossier image est situé dans le répertoire parent du dossier folder et le script original est dans le repertoitre folder, ce qui fait que le navigateur va chercher le repertoire images dans folder plutôt que ../folder...

    Il me semble qu'il y ait un tag html, genre base img, qui me permet d'indiquer le repertoire des images et dossiers, mais je ne suis pas sûr et je n'ai pas réussi à le trouver sur le net.

    A noter qu'une des solutions pourrait être d'indiquer l'url exacte des images, mais cette solution dans mon cas, ne convient pas.

    Je vous remercie de votre aide.
    bonne matinée à tous
     
  2. ZoRRo75
    ZoRRo75 WRInaute discret
    Inscrit:
    11 Mars 2004
    Messages:
    189
    J'aime reçus:
    0
    hello

    tu peux mettre un chemin relatif a la racine de ton site dans la source de l'image

    par exemple src="/images/machin.gif"

    quel que soit la page ou le repertoire d'ou ce sera affiché ca cherchera par rapport à la racine du site

    cdlt

    juju
     
  3. e-kiwi
    e-kiwi WRInaute accro
    Inscrit:
    23 Décembre 2003
    Messages:
    13 198
    J'aime reçus:
    1
    Bonjour,

    pas de solution miracle, il faut indiquer le chemin exact des photos depuis la racine par exemple, et il n y aura plus de problemes, vu que la page qui "va chercher" l'image est bien la page qui inclue
     
  4. ZoRRo75
    ZoRRo75 WRInaute discret
    Inscrit:
    11 Mars 2004
    Messages:
    189
    J'aime reçus:
    0
    si, on peut mettre un slash '/' au debut du chemin pour que le chemin soit relatif à la racine du site et pas a la page en cours

    cdlt

    juju
     
  5. e-kiwi
    e-kiwi WRInaute accro
    Inscrit:
    23 Décembre 2003
    Messages:
    13 198
    J'aime reçus:
    1
    oui, sauf qd le chemin racine du site n est pas / ...
     
  6. ZoRRo75
    ZoRRo75 WRInaute discret
    Inscrit:
    11 Mars 2004
    Messages:
    189
    J'aime reçus:
    0
    genre ? je vois pas la ?

    quand on est pas dans le domaine ? mais dans un sous repertoire ?

    genre wri.com/monsite ?
     
  7. itsme
    itsme WRInaute impliqué
    Inscrit:
    13 Octobre 2004
    Messages:
    609
    J'aime reçus:
    0
    Code:
    <BASE HREF="http://www.monsite.com/">
    permet de definir le repertoire de base pour les chemins relatifs :)
     
  8. athoms
    athoms WRInaute discret
    Inscrit:
    22 Avril 2004
    Messages:
    212
    J'aime reçus:
    0
    Merci pour vos réponses :)

    En fait le / devant les images marche chez mon hebergeur mais pas en local, car mon site est stocké dans mon repertoire web sous la forme www/dossier1/dossier2/site.

    Pourquoi faire simple quand on peut faire compliqué? ;-)

    Sinon pour le base href, ça fonctionne mais apparemment ça me change tous les chemins, y compris celle des images de la page php courante.

    Donc je me suis resigné à mettre l'url en dur dans l'img src.

    bonne soirée à tous!
     
  9. Patrice A.
    Patrice A. WRInaute passionné
    Inscrit:
    11 Février 2005
    Messages:
    2 071
    J'aime reçus:
    0
    Pensez à éditer vos titres de sujet pour préciser [résolu] une fois que le problème a trouvé solution :wink:
     
Chargement...
Similar Threads - [Résolu] Problème includes Forum Date
Problème images en https (forum phpbb) [résolu] Développement d'un site Web ou d'une appli mobile 18 Novembre 2017
[RESOLU] probleme d'indexation des pages en httpS Crawl et indexation Google, sitemaps 20 Mars 2012
[Résolu] Problème d'importation de base MySQL en UTF8 chez 1&1 Administration d'un site Web 3 Juillet 2011
[Résolu] Problème pour gérer 2 campagnes AdWords 17 Novembre 2010
[RESOLU] Probleme d'erreur 302 non voulue Développement d'un site Web ou d'une appli mobile 30 Mai 2010
[Résolu] Problème de remonté de stats de campagne mails via GA Google Analytics 13 Mai 2010
[RESOLU]probleme lors de l'update des informations Développement d'un site Web ou d'une appli mobile 7 Avril 2010
[RESOLU] probleme de tri descendant de tableau ... Développement d'un site Web ou d'une appli mobile 4 Avril 2010
[résolu] Problème sur certains navigateurs ? Développement d'un site Web ou d'une appli mobile 16 Octobre 2009
probleme area="poly" et placement de div [RESOLU] Développement d'un site Web ou d'une appli mobile 8 Octobre 2009
[RESOLU] Problème avec PHPMAILER (apparition des headers dans le message) Développement d'un site Web ou d'une appli mobile 31 Juillet 2009
Problème URL Rewriting complexe avec les dossiers rééls et les autres chemins [Résolu] URL Rewriting et .htaccess 16 Juin 2009
[Résolu] Problème de onbeforeunload / frame Développement d'un site Web ou d'une appli mobile 12 Juin 2009
[Resolu]Probleme soumission boutique 1and1 Problèmes de référencement spécifiques à vos sites 25 Mai 2009
[résolu] problème de variables chez OVH Développement d'un site Web ou d'une appli mobile 21 Février 2009
[résolu] problème php chez OVH Développement d'un site Web ou d'une appli mobile 9 Février 2009
[RESOLU] Problème de redirection permanente URL Rewriting et .htaccess 18 Janvier 2009
Probleme de formulaire [Résolu] Développement d'un site Web ou d'une appli mobile 18 Janvier 2009
[résolu] Problème avec preg_replace (le point) Développement d'un site Web ou d'une appli mobile 6 Janvier 2009
[résolu] Problème de téléchargent de fichiers .ttf, .rar ... Administration d'un site Web 26 Novembre 2008