Soucis d'indexation et div

mels

Nouveau WRInaute
Bonsoir à tous,

Je suis en ce moment face à un souci assez étrange pour l'indexation d'un site. Ce site n'a pas été créé par nos soins (l'agence web dans laquelle je travaille), il nous a été fourni en l'état pour être référencé.

Nous avons proprement taggé les pages, mis un peu de contenu dans les noembed là où il y a du flash, différencié toutes les meta title et description sur chaque page... Et pourtant le site est mal indexé par Google.

Toutes les pages ont été visitées et sont présentes dans la requête site:www... mais seule la homepage bénéficie de l'affichage du vrai title, d'une description etc...
Les autres pages sont listées sous la forme de l'URL de la page et rien d'autre (https://www.google.fr/search?sourceid=na ... -voute.com.)

Inutile de dire que le site ne ressort pas DU TOUT dans les résultats, même en 753e position.

J'ai de très bons résultats dans Yahoo, MSN et autres, et RIEN de rien de rien dans Google. Je précise que dans les premières semaines après son optimisation et sa soumission, le site ressortait sur Google, notamment 3e en première page pour une requête sur le nom de la société, là il n'y a plus rien.

J'ai vérifié que le robots.txt était bien là, j'ai également dans le doute ajouté une redir 301 sur toutes les versions du nom de domaine etc... mais rien n'y fait.

En repassant le code source du site en revue pour la 753e fois, je découvre que l'intégralité du contenu de la page est dans un div, déclaré comme suit :
Code:
<div style="position:absolute; top:0px; left:0px; width: 803px;">

A noter également, la présence d'un "filtre de transition" sur chaque page, de la forme :

Code:
<meta http-equiv="Page-Exit" content="blendTrans(Duration=1)">

J'ai beau regarder le site dans tous les sens, ce sont les deux seules différences notoires que j'observe et qui pourraient causer ce problème.

Mes questions donc :

- quelqu'un en sait-il plus sur d'éventuels problèmes d'indexation de pages dont l'intégralité est dans un div déclaré comme plus haut ?
- pensez-vous que ce div ou le filtre de transition puissent être responsables?
- est-ce possible que le souci vienne de la Sandbox (à ma connaissance le site est relativement récent, il date du début de l'année) ? Il est tellement facile de l'accuser de tout que je doute toujours un peu...
- la personne qui a taggé le site a-t-elle fait des erreurs que je ne vois pas ? (autrement dit, ai-je la berlue?!!)
- avez vous d'autres idées, car je commence à désespérer !

Je vous remercie par avance !

Mels.
 

medium69

WRInaute passionné
Pour parler de ce dont je suis certain, cela ne vient pas de la balise "DIV".

Mon site à toujours été codé avec cette balise et mis à part ces 2 derniers mois, je me plaçais toujours dans les 5 premiers sur Google.

Par contre toujours aussi bien placé sur les autres moteurs.
 

CaYuS

WRInaute occasionnel
Bonsoir,

Personnellement je ne vois pas de détail relativement gênant pouvant entraîner cela.
A mon sens, ni les div, ni le meta ne devrait être gênant pour ce qui est de l'indexation.
Je pencherai plus pour une hypothèse de jeunesse de référencement du site. Google connait déjà l'ensemble des pages, je pense qu'il ne manque plus qu'un peu de temps pour qu'elles apparaissent petit à petit toutes en "claires".

Néanmoins :
. Il pourrait être intéressant de renseigner les attributs alt des images.
. Le code suivant est inutil car il s'agit du comportement par défaut :
Code:
<meta name="robots" content="index,follow">
. Il faudrait faire quelques blacklinks de qualité supplémentaires pour que Google porte le site un peu plus dans son coeur, et le reste devrait venir tout seul.

Du moins c'est mon avis ;)
 

medium69

WRInaute passionné
mels a dit:
- la personne qui a taggé le site a-t-elle fait des erreurs que je ne vois pas ? (autrement dit, ai-je la berlue?!!)

Es-tu sur qu'il n'a pas mis de texte caché, ou autre chose déplaisante pour Google avant de vous l'avoir soumis ?

La vrai question est "qu'avez-vous fait sur votre site avant de nous le soumettre ?"
 

mels

Nouveau WRInaute
Bonjour, merci pour vos réponses !

Haaa... J'aurais bien aimé qu'on me dise "rhaaa oui oui ton problème vient des divs", ça m'aurait drôlement simplifié la tâche ;)

J'ai bien peur aussi que ce soit un souci de jeunesse du site et du référencement... ce qui m'étonnera toujours c'est que tous les sites ne semblent pas frappés de la même façon par ces "pénalités"... Quant à expliquer aux clients les "problèmes de jeunesse", j'ai beau tourner ça dans tous les sens, ils pensent toujours que je leur raconte des bobards... Comme on dit "wait and see"... :)

medium69, à priori rien de "déplaisant" (cloaking, divs cachés, texte blanc sur fond blanc ou autres techniques mal vues) n'a été fait sur le site... Je pense que je vais quand même me planifier une opération commando un de ces quatre et vérifier une à une les sources de chacune des pages, sait-on jamais !

Dernière question :

. Le code suivant est inutil car il s'agit du comportement par défaut :
Code:
<meta name="robots" content="index,follow">

Cela peut-il pour autant nuire à l'indexation et au positionnement ? Autrement dit, me recommandes-tu de le sortir ?

Merci encore :)

mels
 

CaYuS

WRInaute occasionnel
mels a dit:
Cela peut-il pour autant nuire à l'indexation et au positionnement ? Autrement dit, me recommandes-tu de le sortir ?
Nuire à l'indexation et au positionnement ?
En théorie, non.
Néanmoins oui je te recommande de le sortir pour la simple et bonne raison que c'est inutil, et donc cela alourdit le code de la page sans motif valable.
La politique des moteurs de recherche est : On indexe tout SAUF ce qu'on nous demande de ne pax indexer.
Et ce n'est pas : On n'indexe rien SAUF ce qu'on nous autorise à indexer.

Donc dans ton cas, elle n'a pas de raison d'être ;)

Bonne continuation.
 

Discussions similaires

Haut