avec ou sans www

Discussion dans 'Problèmes de référencement spécifiques à vos sites' créé par tomsc, 11 Novembre 2010.

  1. tomsc
    tomsc Nouveau WRInaute
    Inscrit:
    8 Novembre 2010
    Messages:
    28
    J'aime reçus:
    0
    Bonsoir à tous,

    Voilà, j'ai une galerie en ligne à l'adresse http://constantimages.fr mais aussi http://www.constantimages.fr qui est redirigé vers http://constantimages.fr.

    Moi ca me pose pas de problèmes, en revanche google a du mal, un jour il indexe avec www un jours sans, du coup c'est le bazard!

    dans google webmaster c'est configuré comme ca :

    Ne pas définir de domaine favori
    • Afficher les URL de la manière suivante : http://www.constantimages.fr
    Afficher les URL de la manière suivante : constantimages.fr

    Je voudrais de pas définir de domaine favoris mais ca marche pas...

    Que faire pour que toutes mes adresses soient référencés de la même manières (avec ou sans www je m'en fiche!), enfin bon ça fait un mois que j'ai ce nouveau site (l'adresse existe depuis longtemps mais j'avais un autre site avant dessus) et je n'ai aucunes visites provenant des moteurs de recherches, donc si au passage vous pouvez me dire ce qui va pas adns mes pages pour le référencement... Merci a tous :wink:

    merci a tous

    ps: en plus c'est embêtant pour les stats de addthis, le nombre de shares est différent si le visiteur a cliquer sur share avec www ou sans...
     
  2. leo11173
    leo11173 WRInaute occasionnel
    Inscrit:
    18 Avril 2009
    Messages:
    286
    J'aime reçus:
    0
    Il te fait définir un domaine favori. Si tu as déjà pas mal de backlinks et te tâte entre www ou sans, bien essayer d'opter pour la forme dans laquelle tu as déjà le plus de backlink.

    Tu dis plus haut avoir redirigé www constantimages fr vers constantimages fr, hors ici, lorsque je navigue sur les pages de ton site, je ne vois pas l'ombre d'une redirection. C'est donc un problème à régler au plus vite.

    Etant donné que tu est sous apache, une règle de réécriture dans le htacess fera l'affaire. Je ne la connais pas de tête mais une recherche rapide sur le forum te donnera la solution, ce genre de soucis est un classique.
     
  3. tomsc
    tomsc Nouveau WRInaute
    Inscrit:
    8 Novembre 2010
    Messages:
    28
    J'aime reçus:
    0
    Ok, j'ai le plus de backlink sans le www mais quand je veux choisir la bonne adresse dans google webmaster j'ai un message de ce style:

    Une étape du processus de définition du domaine favori consiste à confirmer que vous êtes le propriétaire du domaine http://www.constantimages.fr/. Veuillez confirmer http://www.constantimages.fr/.

    et rien a faire...

    Sinon pour la redirection c'est une redirection DNS de type CNAME dans OVH de www.constantimages.fr vers constantimages.fr ca va pas?
     
  4. tomsc
    tomsc Nouveau WRInaute
    Inscrit:
    8 Novembre 2010
    Messages:
    28
    J'aime reçus:
    0
    C'est bon pour le choix dans google webmester j'ai réussi à valider. Reste la redirection, en fait il faudrait faire une redirection de type A et non un CNAME non?
     
  5. leo11173
    leo11173 WRInaute occasionnel
    Inscrit:
    18 Avril 2009
    Messages:
    286
    J'aime reçus:
    0
  6. tomsc
    tomsc Nouveau WRInaute
    Inscrit:
    8 Novembre 2010
    Messages:
    28
    J'aime reçus:
    0
    J’avoue ne pas trop savoir quoi faire... Certains disent que le rewrite n'est pas fait pour ça et que c'est pas gênant d'avoir une redirection. En fait mon www.constantimages.fr est redirigé comme un sous domaine classique vers constantimages.fr . J'ai choisis mon adresse préféré dans google webmester, normalement je ne devrais plus voir de résultats en www donc est ce toujours utiles de modifier cela?
     
  7. tomsc
    tomsc Nouveau WRInaute
    Inscrit:
    8 Novembre 2010
    Messages:
    28
    J'aime reçus:
    0
    Que penses tu de la redirection leo si tu essayes là?
     
  8. leo11173
    leo11173 WRInaute occasionnel
    Inscrit:
    18 Avril 2009
    Messages:
    286
    J'aime reçus:
    0
    Je pense qu'on peux toujours accéder au pages avec les www et sans les www et donc qu'il y à toujours du duplicate content et pas de redirection.
     
  9. tomsc
    tomsc Nouveau WRInaute
    Inscrit:
    8 Novembre 2010
    Messages:
    28
    J'aime reçus:
    0
    Bha non plus chez moi... il doit falloir remettre à jours ta table de DNS, essaye par exemple de "réparer" ta connection internet pour mettre tout ca à jour.

    Ps: bon je fais plein de tests... je reviens demain pour faire un point, merci pour ton aide leo
     
  10. tomsc
    tomsc Nouveau WRInaute
    Inscrit:
    8 Novembre 2010
    Messages:
    28
    J'aime reçus:
    0
  11. fredfan
    fredfan WRInaute accro
    Inscrit:
    2 Juillet 2008
    Messages:
    2 850
    J'aime reçus:
    2
    Le site n'est plus accessible avec les www
    Tes redirections serveurs ne sont pas adaptées. Il faut une réécriture htaccess.
     
  12. tomsc
    tomsc Nouveau WRInaute
    Inscrit:
    8 Novembre 2010
    Messages:
    28
    J'aime reçus:
    0
    Oui je sais, j'ai supprimer la redirection dans OVH manager et j'essaye avec des rewrite rules mais ca ne marche pas...

    Aidezzzz moiii :cry:

    Je suis chez OVH avec un 60gp...
     
  13. tomsc
    tomsc Nouveau WRInaute
    Inscrit:
    8 Novembre 2010
    Messages:
    28
    J'aime reçus:
    0
    J'ai même essayé une redirection du type :

    Code:
    Options +FollowSymlinks
    RewriteEngine on
    RewriteRule ^galerie-([a-zA-Z0-9_-]+)\.html$ index.php?Mnu=$1
    Ça ne marche pas... Pourtant quand je suis le tuto wri avec le dossier test ça marche parfaitement...
     
  14. tomsc
    tomsc Nouveau WRInaute
    Inscrit:
    8 Novembre 2010
    Messages:
    28
    J'aime reçus:
    0
    ps: je ne sais pas si ça aide mais mon index.php et tout mon site est sous le dossier /www/ sur mon ftp... Toute façon j'ai pas le choix je pense
     
  15. leo11173
    leo11173 WRInaute occasionnel
    Inscrit:
    18 Avril 2009
    Messages:
    286
    J'aime reçus:
    0
    Code:
    RewriteCond %{HTTP_HOST} www.example.com
    RewriteRule (.*) http://example.com$1 [L,R=301]
    c'est plustôt un truc du genre ou son inverse qu'il faut faire.
     
  16. tomsc
    tomsc Nouveau WRInaute
    Inscrit:
    8 Novembre 2010
    Messages:
    28
    J'aime reçus:
    0
    Voilà le contenu de mon htaccess exacte :

    Code:
    RewriteEngine on
    RewriteCond %{HTTP_HOST} www.constantimages.fr
    RewriteRule (.*) http://constantimages.fr$1 [L,R=301]
    voyez bien que ca ne marche pas... :cry:
     
  17. tomsc
    tomsc Nouveau WRInaute
    Inscrit:
    8 Novembre 2010
    Messages:
    28
    J'aime reçus:
    0
    il semblerait qu'il y ai des effets si je rajoute

    Code:
    RewriteBase /
    mais

    Code:
    RewriteEngine on
    RewriteBase /
    RewriteCond %{HTTP_HOST} http://www.constantimages.fr
    RewriteRule (.*) http://constantimages.fr$1 [L,R=301]
    ne fonctionne quand même pas
     
  18. tomsc
    tomsc Nouveau WRInaute
    Inscrit:
    8 Novembre 2010
    Messages:
    28
    J'aime reçus:
    0
    J'en ai marre..... Comment expliquez vous que ce code :

    Code:
    RewriteEngine on
    Options +FollowSymlinks
    RewriteCond %{HTTP_HOST} www.constantimages.fr$
    RewriteRule (.*)$ http://constantimages.fr/$1 [QSA,L,R=301]
    fonctionne sur un PC et pas sur un autre???

    Même navigateur...
     
  19. tomsc
    tomsc Nouveau WRInaute
    Inscrit:
    8 Novembre 2010
    Messages:
    28
    J'aime reçus:
    0
    Il semblerait que ca fonctionne,

    il fallait que je créer la redirection DNS au niveau de l’hébergeur de www.constantimages.fr vers constantimages.fr
     
  20. leo11173
    leo11173 WRInaute occasionnel
    Inscrit:
    18 Avril 2009
    Messages:
    286
    J'aime reçus:
    0
    Hum, sur ton apache le module mod_rewrite est activé ?

    Edit, je viens de voir ta réponse au dessus. Donc maintenant tu as bien une direction 301 sur les pages www qui renvois sur les pages sans www. Impeccable.
     
  21. tomsc
    tomsc Nouveau WRInaute
    Inscrit:
    8 Novembre 2010
    Messages:
    28
    J'aime reçus:
    0
    Oui, merci pour ton aide leo,

    j'ai une dernière question, j'ouvre un nouveau mais dernier topic