CM ASUS M5A99X EVO R2.0 : comment désactiver le "Secure Boot" ?

Discussion dans 'Le café de WebRankInfo' créé par ortolojf, 18 Décembre 2012.

  1. ortolojf
    ortolojf WRInaute accro
    Inscrit:
    14 Août 2002
    Messages:
    2 866
    J'aime reçus:
    10
    Bonsoir

    J'ai acheté il y a environ 1 mois, une carte mère ASUS M5A99X EVO R2.0.

    Je n'ai pas updaté le Bios, La dernière version updatable est la : 1302, je crois que ma version de Bios installée sur la CM est : 1301, mais pas sûr.

    Cette Carte Mère, semble-t-il, d'après les spécifications récentes de Microsoft relatives à Windows 8, a le "Secure Boot" de son Bios UEFI, activé par défaut.

    Ma question est : Théoriquement , les spécifications de Microsoft, indiquent qu'il est nécessairement possible physiquement, de désactiver ce mode "Secure Boot", au niveau du Bios.

    Mais... Nulle par dans le mode d'emploi de la CM, il n'est question de Secure Boot, sauf pour dire, à la fin des commandes avancées de setup du Bios :

    Dans la section : "Boot Option s Priorities" ( cette option n'apparaît pas sur la photo noir et blanc du menu "Bios" :

    En Français: "Ces options spécifient l'ordre de priorité des périphériques au boot. Le nombre des périphériques affichés sur l'écran, dépend du nombre de périphériques installés sur la machine".

    Et en dessous :

    "Pour accéder au système d'exploitation Windows en "Safe" Mode ( je suppose qu'il s'agit du "Secure Boot" ), faire l'une de ce deux choses :

    - Presser <F8> après la phase POST du Boot,

    - Pour sélectionner le périphérique pendant le démarrage, presser <F8> quand le Logo ASUS apparaît.

    Mais... Rien au sujet du "Secure Boot".

    Le "Secure Boot", est une fonctionnalité des nouveaux Bios UEFI ( à partir de la version UEFI 2.3.0 ou 2.3.1 je ne sais pas ), qui nécessite une clé d'activation lors de l'installation du système d'exploitation, pour que celui-ci puisse booter.

    Cette clé, dépend de tout le hardware installé sur l'ordinateur, et est payante.

    1- J'ai demandé au support ASUS, d e me dire quelle était la version de UEFI supportée par mon Bios. Je crois avoir reçu la réponse : 2.3.0.

    2- Je ne veux pas installer Windows sur cet ordinateur neuf, ( dont le hardware fonctionne normalement ), mais Linux Fedora 17 64 bits, et puis ensuite la version 18 quand elle apparaîtra ( après le 8 Janvier prochain ).

    3- Ma première question est : Est-ce que la version 2.3.0 de la norme UEFI, supporte le protocole de "Secure Boot", qui est quand même récent ?

    4- Ma deuxième question : Comment, dans le Bios UEFI de cette Carte Mère ASUS M5A99X EVO R2.0, désactiver le mode "Secure Boot" ?

    Merci beaucoup à ceux d'entre-vous qui ont acheté cette CM, comment vous avez fait pour désactiver le "Secure Boot";

    Merci beaucoup de vos réponses.

    Jean François Ortolo
     
  2. ortolojf
    ortolojf WRInaute accro
    Inscrit:
    14 Août 2002
    Messages:
    2 866
    J'aime reçus:
    10
    Bonsoir

    Bon, ben j'ai trouvé sur le net, un Document Acrobat Reader, qui décrit ce menu du Bios ( titre : "Fast Bios" ), d'une manière plus développée que le manuel de ma CM.

    Il est éventuellement possible, que ces options ne soient disponibles qu'avec la dernière version du Bios.

    Il est indiqué, qu'il est possible de choisir le type de système d'exploitation, entre : [UEFI Windows] et [Other OS].

    Cependant, ce document n'est pas très clair, pour savoir s'il est possible d'avoir une fonctionnalité UEFI, ( au lieu de Legacy ), même avec des OS différents, et ceci sans "Secure Boot".

    Il est indiqué théoriquement, que le "Microsoft Secure Boot " n'est compatible qu'avec l'option [UEFI Windows] , et aussi que si l'OS que l'on veut installer est autre chose que Windows, il faut nécessairement choisir : [Other OS], qui n'est pas activé par défaut.

    Pour le reste, pour la gestion spécifique du "Secure Boot", qui fait l'objet d'un titre suivant, ( sur ce Bios récent théoriquement ), il y a le choix entre [Standard] ( par défaut ) ou [Custom].

    Il y aussi avant tout çà, le mode de "Compatibilité" CSM, qui indique si l'on préfère booter partir d'un périphérique UEFI ou Legacy, ou [Auto] avec d'abord Legacy puis UEFI, etc...

    Bref, la seule solution, semble que je doive regarder par moi-même, dans les méandres du Bios actuel, qui n'a probablement même pas ces fonctionnalités complètes, et éventuellement que je prenne le risque de mettre à jour le Bios avec une clé USB ( j'ai mis le dernier Bios dedans à la racine ), qui est formatée correctement en FAT 32.

    Ceci, au risque de me trouver avec un système incompatible avec Fedora 17 64 bits. ;(

    Sans parler du risque de mettre à jour le Bios... ;(

    Merci beaucoup de vos conseils.

    Bien amicalement.

    Jean François Ortolo
     
  3. ortolojf
    ortolojf WRInaute accro
    Inscrit:
    14 Août 2002
    Messages:
    2 866
    J'aime reçus:
    10
    Rebonjour

    Finalement, le site Wikipedia, à propos de la norme UEFI, dit que "depuis la version 2.3.1 , la norme UEFI supporte le mode "Secure Boot", qui permet de sécuriser au boot, contre les rootkits et autres malwares disposés avant le Boot".

    Moi, ma version de UEFI ( dixit le support de ASUS, pour la version actuelle de mon Bios ), est : 2.3.0.

    Il semblerait donc, d'après le site Wikipedia,que cette version 2.3.0 de UEFI, ne supporte pas le "Secure Boot".

    Donc... Les problèmes que j'ai constatés à l'install de Linux Fedora 17 64 bits, devraient être entièrement résolus, par ce "nettoyage" du MBR de mon disque dur ( neuf, un Western Digital Caviar Black de 1 Téra-octets ), avec la commande :

    dd if=/dev/zero of=/dev/sda bs=512 count=1

    que j'ai faite,a près avoir remis ( avec parted ) le disque en mode msdos.

    Après cette commande, j'ai fait :

    gdisk /dev/sda

    qui me l'a remis correctement en mode GPT,

    puis :

    w pour écrire sur le disque,

    puis :

    q

    pour sortir.


    Je n'ai pas utilisé parted pour remettre en mode GPT, car parted, en faisant celà ( pour certaines versions ), "abime" le MBR, ce qui fait que le disque aurait été reconnu comme un disque MBR, et non pas GPT (problèmes constatés lors des installations précédentes ).

    Donc... J'ai quand même essayé il y a quelque semaines, d'installer Linux Fedora 17 64 bits sur ce nouvel ordinateur ( après avoir fait la manip ci-dessus ), et là, le processus d'installation, ne me laisse pas la possibilité de créer une partition de type EFI System, à monter sur /boot/efi , comme celà devrait être le cas si le disque était reconnu comme GPT.

    C'est à n'y rien comprendre, puisque gdisk reconnait bien le disque comme GPT, et il n'y a aucun problème de décelé sur le disque avec la commande : v

    Merci beaucoup de votre aide.

    Bien amicalement.

    Jean François Ortolo
     
  1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies.
    Rejeter la notice