liens inactifs sous FF

Astropolis

WRInaute discret
bonjour à tous

voilà j'essaie de lancer un tout petit site web sans prétention sur les télescopes :

http://www.achat-telescope.net

Je rencontre un problème depuis ma page d'accueil sous Firefox, car les liens qui sont dans le contenu (avec les petits logos comme le favicon) sont absolument inactifs sous Firefox ! et évidemment sous IE ça marche.

Mais je ne vois pas où est le problème dans mon code, en même temps je ne maîtrise pas vraiment mon affaire de ce côté là :p

Les liens sont balisés h2 et j'ai aussi un code CSS correspondant, peut-être que le soucis vient de là ?

Code:
div#contenu h2
{
	padding-left: 50px ;
	line-height: 40px ;
	font-size: 1.4em ;
	background: url(mini.jpg) no-repeat left bottom ;
	color: #5e1600 ;
	border-bottom: 1px solid #5e1600 ;
}

J'ai besoin d'aide, alors merci pour vos réponses !
 

Astropolis

WRInaute discret
purée je viens de comprendre le pourquoi ! non mais je rêve d'être aussi ab**ti

J'ai un calque qui me sert de menu sur la gauche, et pour le maintenir en place en fonction de la résolution des écrans, j'ai appliqué le {width: 100%;}, sauf que si sous IE on peut accéder au contenu de la page (en le surlignant avec le curseur je veux dire), hé bien sous FF c'est impossible, c'est comme si on glissait sur le calque (qui évidemment occupe toute la largeur de la page) donc forcément je perds l'accès aux liens.

C'est donc là que vient mon problème ! donc je change l'intitulé de ma question : comment maintenir mon menu de gauche sans appliquer ce critère CSS du width ... ?
 

Astropolis

WRInaute discret
Astropolis a dit:
purée je viens de comprendre le pourquoi ! non mais je rêve d'être aussi ab**ti

J'ai un calque qui me sert de menu sur la gauche, et pour le maintenir en place en fonction de la résolution des écrans, j'ai appliqué le {width: 100%;}, sauf que si sous IE on peut accéder au contenu de la page (en le surlignant avec le curseur je veux dire), hé bien sous FF c'est impossible, c'est comme si on glissait sur le calque (qui évidemment occupe toute la largeur de la page) donc forcément je perds l'accès aux liens.

C'est donc là que vient mon problème ! donc je change l'intitulé de ma question : comment maintenir mon menu de gauche sans appliquer ce critère CSS du width ... ?

EDIT : La chaise sauvage m'a devancée, merci ! mais c'est donc un nouveau problème qui se pose à moi, car je galère pour maintenir ce calque en place ... :(
 

Astropolis

WRInaute discret
Re: liens inactifs sous FF (résolu)

Hé bien je crois que je viens de résoudre mon problème, en remplaçant width:100% par width:auto ...

désolé pour ce topic dont l'espérance de vie aura été aussi courte que son intérêt ! ;)
 

La Chaise sauvage

WRInaute impliqué
Ben je vois plus bien ou est le problème du coup, maintenant...
Ton menu semble rester en place, et on peut cliquer sur les liens du contenu, sous Fx comme sous iE, là, non ?

[edit: ok, tant mieux alors :wink:]
 

Astropolis

WRInaute discret
oui merci La Chaise sauvage :)

maintenant va falloir que je trouve un CSS compatible IE / FF pour colorer mes liens ... c'est pas gagné.
jusqu'à présent ça ne marche que pour IE (pour changer), c'est ch**nt.
 

La Chaise sauvage

WRInaute impliqué
quel est le problème avec la coloration des liens ?

ta css indique div#contenu a et div#contenu a:hover, donc c'est normal que les liens de div#sidebar ne soient pas colorés.
Ce qui l'est moins, c'est qu'internet explorer colore ces liens, et là je soupçonne un problème dans la structure de ton code, qui est probablement "ambigüe"

commence déjà par essayer de valider ton site, ça règle souvent bien des problèmes inter-navigateurs.

et puis bon, tu peux aussi remplacer div#contenu a par div#conteneur a, pour colorer tous les liens - mais règle quand même tes soucis de validité :wink:
 

Discussions similaires

Haut