Probleme balise meta title, description page d'accueil

vontsy

Nouveau WRInaute
Bonjour, je posséde une boutique internet devellopé avec prestashop et voici le probleme:

- Les meta-tags <title> , <description> … n’apparaissent pas dans la source de la page d’accueil
- Elles sont bien rempli dans preferences – meta tags – index.php
- Les meta tags des autres CMS s’affiche bien dans la source de leur page associé
- Si je modifie les meta-tags des CMS, elles se modifie bien dans la source sauf index.php qui reste vide
- Si je modifie le index.php, elle se modifie bien dans la base de donné phpmyadmin
- L’ID de index.php à été remis à 4 comme sur la base de donnée de depart
- Si je crée les meta-tags en dur dans le header.tpl, elles s’affiche bien dans la source index.php mais egalement sur toute les autres pages (donc sa ne me convient pas)
- J’ai tenté un code comme celui si dans le header

{if $page_name == “index”} <title>{l s=“exemple”}</title> <meta name=“description” content=“Notre selection de coques pour iphone {$titre} : des coques pour iphone transparentes, rigides ou en silicone ainsi que des accessoires pour relooker votre iPhone.”>

Sa fonctionne mais je n’arrive pas à retirer les autres meta-tags vide et je ne s’est pas si s’est une bonne solution

Je ne sait plus ou chercher pour regler ce problème

Merci pour votre aide

http://www.cosmetique-discount.fr
 

Rod la Kox

WRInaute accro
vontsy a dit:
- Les meta-tags <title> , <description> … n’apparaissent pas dans la source de la page d’accueil
La balise title apparait bien (c'est une balise, pas un meta)
Le Meta Description apparait aussi, mais il n'est pas renseigné.
 

koulyik

WRInaute discret
et un code dans ce style ?
Code:
		<title>{$meta_title|escape:'htmlall':'UTF-8'}</title>
        
{if isset($meta_description) AND $meta_description}
		<meta name="description" content="{$meta_description|escape:htmlall:'UTF-8'}" />
{/if}
{if isset($meta_keywords) AND $meta_keywords}
		<meta name="keywords" content="{$meta_keywords|escape:htmlall:'UTF-8'}" />
{/if}

ensuite je pense que tu n'es pas sur le bon forum..
et si je peux me permettre tu as pas mal de bug sous firefox 3.6 avec tes css.
 

vontsy

Nouveau WRInaute
Ce code est dejà celui qui est integré dans le header.tpl

Il marche pour toute les pages sauf pour la page index.php ou les balises reste vides.

Désolé mais je n'utilise peut etre pas les bon termes mais je suis vraiment debutant s'est pour cela que j'ai preferé demander dans cette parti du forum.

Merci
 

Discussions similaires

Haut