Aide pour problème de validation W3C

Discussion dans 'Problèmes de référencement spécifiques à vos sites' créé par CedricADW, 10 Juin 2009.

Tags:
  1. CedricADW
    CedricADW Nouveau WRInaute
    Inscrit:
    8 Avril 2009
    Messages:
    12
    J'aime reçus:
    0
    Bonjour,

    J'ai voulu tester et faire la validation W3C de mon site. Le problème, c'est que j'ai énormément d'erreurs qui s'affichent. Je cherche quelqu'un qui pourrait me filer un p'tit coup de pouce car là, je rame un peu !

    Validation utilisée :

    http://validator.w3.org/

    Mon site :

    http://www.autourduweb.fr/

    Merci ^_*

    P.S : Je ne sais pas si je suis au bon endroit pour poster mon problème sinon les modérateurs déplaceront ce sujet.
     
  2. oli004
    oli004 WRInaute passionné
    Inscrit:
    5 Janvier 2005
    Messages:
    1 645
    J'aime reçus:
    0
    Il y a de nombreuses compétentes dans ce domaine ici, néanmoins tu auras je pense de plus grande chance d'obtenir des réponses précises sur le forum d'alsacréation.
     
  3. screuscreu
    screuscreu WRInaute impliqué
    Inscrit:
    14 Janvier 2008
    Messages:
    701
    J'aime reçus:
    0
    Règle numéro 1 : corriger les problème dans l'ordre

    -71 erreurs ... il y a pire ;)

    Ajoute : "type="text/javascript"" pour les erreurs 1 à 4
    Après 90% des autres sont juste que tu as oublié de fermer tes balises (principalement tes <p>) ... Clique sur "Show Source", il te montrera exactement la ligne de l'erreur.

    Courage
     
  4. CedricADW
    CedricADW Nouveau WRInaute
    Inscrit:
    8 Avril 2009
    Messages:
    12
    J'aime reçus:
    0
    @ Oli004 : Ok, j'irais faire un tour sur ce forum alors, merci ^^

    @ screuscreu : j'ai déjà type="text/css"
    Je peux en rajouter un troisième ??

    Merci...
     
  5. screuscreu
    screuscreu WRInaute impliqué
    Inscrit:
    14 Janvier 2008
    Messages:
    701
    J'aime reçus:
    0
    "text/css" pour les .css
    text/javascript pour les .js
     
  6. CedricADW
    CedricADW Nouveau WRInaute
    Inscrit:
    8 Avril 2009
    Messages:
    12
    J'aime reçus:
    0
    Bon faut dire que là dedans, j'y connais pas grand chose (c'est pourquoi je suis venu sur un forum ^^), alors, je t'ai copié le morceau de code :

    Code:
    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
    	<link rel="alternate" type="application/rss+xml" title="<?php bloginfo('name'); ?> RSS Feed" href="<?php bloginfo('rss2_url'); ?>" />
    	<link rel="alternate" type="application/atom+xml" title="<?php bloginfo('name'); ?> Atom Feed" href="<?php bloginfo('atom_url'); ?>" />
    C'est où j'ai trouvé type="text/css" mais maintenant, je la met où ta ligne ?

    Merci...
     
  7. spout
    spout WRInaute accro
    Inscrit:
    14 Mai 2003
    Messages:
    9 078
    J'aime reçus:
    295
    Pour t'aider dans la validation HTML, je conseille d'installer cette extension Firefox:
    Html Validator: http://users.skynet.be/mgueury/mozilla/

    Comme ça on voit en permanence si la page valide ou pas, et ça saute aux yeux quand il y a des erreurs de validation (croix rouge)
     
  8. CedricADW
    CedricADW Nouveau WRInaute
    Inscrit:
    8 Avril 2009
    Messages:
    12
    J'aime reçus:
    0
    Merci Spout, j'avais effectivement déjà installé ce plugin mais pour quelqu'un qui touche pas sa bille là dedans, c'est un peu lourd !
    Je fouille... Je fouille !

    En tout cas, merci ^_*
     
  9. screuscreu
    screuscreu WRInaute impliqué
    Inscrit:
    14 Janvier 2008
    Messages:
    701
    J'aime reçus:
    0
    J'y pense, pourquoi tu veux valider W3C ? Pour faire joli ?

    Bon courage ...
     
  10. CedricADW
    CedricADW Nouveau WRInaute
    Inscrit:
    8 Avril 2009
    Messages:
    12
    J'aime reçus:
    0
    Petit à petit j'avance ! Il m'en reste tout de même 50 ! J'ai toujours pas trouvé où mettre ta ligne de code pour mes 4 premières erreurs...

    Un p'tit peu plus de renseignements ?

    Merci...
     
  11. screuscreu
    screuscreu WRInaute impliqué
    Inscrit:
    14 Janvier 2008
    Messages:
    701
    J'aime reçus:
    0

    ICI :
    Code:
    	
    <script src="http://www.autourduweb.fr/wp-content/themes/magazeen/js/pngfix.js"></script>
    	<script src="http://www.autourduweb.fr/wp-content/themes/magazeen/js/jquery-latest.js"></script>
    	<script src="http://www.autourduweb.fr/wp-content/themes/magazeen/js/effects.core.js"></script>
    	<script src="http://www.autourduweb.fr/wp-content/themes/magazeen/js/functions.js"></script>
    Rajoute
    Code:
    type="text/javascript"
    Dans chaque ligne

    Exemple
    Code:
    <script type="text/javascript" src="http://www.autourduweb.fr/wp-content/themes/magazeen/js/jquery-latest.js"></script>
     
  12. screuscreu
    screuscreu WRInaute impliqué
    Inscrit:
    14 Janvier 2008
    Messages:
    701
    J'aime reçus:
    0
    Ligne 585
    Code:
    <center><strong><a href="http://www.autourduweb.fr/2009/">Voir d'autres articles dans l'archive</a></center></strong>
    tu as center puis strong puis /center puis /string
    Pense à refermer les balises dans le bon sens :

    Code:
    <center><strong><a href="http://www.autourduweb.fr/2009/">Voir d'autres articles dans l'archive</a></strong></center>
    Cette erreur est répétée de très nombreuses fois (pour les <p><strong> ou autres)
     
  13. CedricADW
    CedricADW Nouveau WRInaute
    Inscrit:
    8 Avril 2009
    Messages:
    12
    J'aime reçus:
    0
    Merci pour ton aide screuscreu !

    Mais là, j'y arrive plus ! J'ai changé ce que tu m'as dit, il m'en reste 42 !

    Par exemple, pour les deux premières erreurs (ligne 178 et 180) qu'est-ce que je dois faire ??

    Je te donne ce que j'ai dans mon article en HTML :

    T'as une idée ?

    Merci...
     
  14. screuscreu
    screuscreu WRInaute impliqué
    Inscrit:
    14 Janvier 2008
    Messages:
    701
    J'aime reçus:
    0
    JE te l'ai déjà marqué à 2 reprises : tes blises sont mal fermées ou pas fermées.
    Regardes, tu ne fais que ouvrir des <p> et les ferme que 1 fois par an
     
  15. CedricADW
    CedricADW Nouveau WRInaute
    Inscrit:
    8 Avril 2009
    Messages:
    12
    J'aime reçus:
    0
    Bah désolé, mais je vois pas là ! Dans ce que je t'ai collé, les balises sont bien fermées ou je met rompe ??

    Comment tu l'écrirais toi ??

    J'ai bien
    Code:
    </p>
    à chaque fin de balise où j'hallucine ??
     
  16. CedricADW
    CedricADW Nouveau WRInaute
    Inscrit:
    8 Avril 2009
    Messages:
    12
    J'aime reçus:
    0
    En fait, je les ai effacé et apparemment, c'est mieux ! Mais d'où elles viennent ces balises ?

    Est-ce que ça pourrait venir du fait que j'écris d'abord tout sous Open Office.org et que c'est lui qui me les génère ???
     
  17. screuscreu
    screuscreu WRInaute impliqué
    Inscrit:
    14 Janvier 2008
    Messages:
    701
    J'aime reçus:
    0
    je parlais en général, pas du code que tu as cité.
     
Chargement...
Similar Threads - Aide problème validation Forum Date
Aide pour un problème http–https sur My Ranking Metrics Problèmes de référencement spécifiques à vos sites 19 Juin 2018
Aide réciproque appréciée, dubitatif sur certains problèmes SEO Problèmes de référencement spécifiques à vos sites 6 Juin 2018
Petit Problème GOOGLE un peu d'aide MERCI ! Débuter en référencement 16 Janvier 2015
Problème indexation avec snapshot html. Fonctionne à moitié. Besoin d'aide !! Problèmes de référencement spécifiques à vos sites 6 Janvier 2015
Problème référencement après 4 ans d'activité [Besoin d'aide] Problèmes de référencement spécifiques à vos sites 19 Mars 2014
Problème d'affichage : besoin de votre aide ! Développement d'un site Web ou d'une appli mobile 30 Mars 2013
Débutante demande aide pour problème avec slider Développement d'un site Web ou d'une appli mobile 27 Octobre 2012
besoin d'aide sur probleme de div déployables ... Développement d'un site Web ou d'une appli mobile 9 Septembre 2012
ENORME problème de code malveillant - Besoin d'aide SVP ! Référencement Google 8 Mai 2012
[Aide] Léger problème d'intégration... Développement d'un site Web ou d'une appli mobile 4 Mai 2012