Erreur liée à des redirections

ungars

WRInaute discret
Bonsoir,
Ma console Google Search, depuis 10 jours, me signale une erreur liée à des redirections sur cette page

Elle a bien été indexée 10 jours auparavant quand j' ai mis le site en ligne, je ne vois pas du tout d' ou peut venir cette erreur de redirection

Il y avait quelques problèmes sur la page, avec des liens internes (erreur de syntaxe), un lien vers une page Facebook vide que j' ai enlevé depuis et j' ai corrigé le reste.

J' avais commencé le site sur une autre Url en attendant que l'ami à qui je l' ai fait achète un hébergement. Pour changer les Url, j' ai utilisé le plugin "Better Search replace" . J' ai modifié aussi les tables "options" dans ma base de données en y mettant la nouvelle Url.

Peut être que mon problème vient de là, mais l' image qui est sur le site semble bien hébergée sur la nouvelle Url.

Je n'ai pas fait de redirection 301, je n' ai pas touché à mon fichier .htaccess :

Code:
# o2s WpTiger Begin - Dont edit - Ne pas modifier - forceHttps
# Force le HTTPS
RewriteEngine On 
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteCond %{HTTPS} !on
RewriteRule ^(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
# o2s WpTiger End - Dont edit - Ne pas modifier - forceHttps

# BEGIN WordPress
# Les directives (lignes) entre « BEGIN WordPress » et « END WordPress » sont générées
# dynamiquement, et doivent être modifiées uniquement via les filtres WordPress.
# Toute modification des directives situées entre ces marqueurs sera surchargée.
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

Si je fais une inspection de l' Url, on me dit :

Cette URL n'est pas sur Google : erreurs d'indexation
Elle ne peut pas figurer dans les résultats de la recherche Google tant qu'elle n'a pas été indexée. En savoir plus

Si je veux la tester en direct, tous les voyants sont au vert et l'indexation ne semble pas poser de problème :
Google a accès à cette URL
Si elle est indexée et sélectionnée comme URL canonique, elle pourra figurer dans les résultats de la recherche Google avec toutes les optimisations pertinentes. En savoir plus

J' ai fait plusieurs demandes d' indexation en 10 jours, le problème persite.

Merci pour votre aide, bonne soirée.
 

ungars

WRInaute discret
Bonsoir, je me permets de revenir vers vous, car je n' ai pas trop avancé depuis mon dernier post.

J' ai ouvert un topic sur le forum de Google, la personne qui m' a répondu m' a dit qu' il n' y avait aucun problème avec mon url , qu' elle était indexée, et que tout allait bien.

Je veux bien, mais pourtant dans ma console on voit ça : https://www.cjoint.com/c/LFuuyCIqSNd

Il y a aussi cette fameuse erreur de redirection : https://www.cjoint.com/c/LFuuAh5lQzd

La page que l' on voir actuellement sur Google est une page mise en cache le 21 Mai, elle a changé depuis. Si on regarde le cache des autres pages, on voit qu' il est bien plus récent.

De plus, si je regarde les requètes les plus fréquentes, elles n' ont de rapport qu' avec les autres pages du site, qui représentent les activités annexes de mon ami (chauffagiste, climatisation). Rien à voir avec la plomberie, qui est son activité principale, ce qui est assez embêtant.

Je ne vois pas d' ou peuvent venir ces erreurs de redirection. Il serait plus simple dans ma console de me dire ou elle est, cela me simplifierai la tâche.

Il reste un truc à faire, j' attends encore un peu, l' erreur m' a été signalée dans ma console quand j' ai rajouté un numéro de téléphone cliquable. Je ne vois pas le rapport, mais c' est la seule chose que j' ai fait, et quelques jours après j' ai eu ce souci.

Merci d' avance pour votre aide, bonne soirée.
 

WebRankInfo

Olivier Duffez (admin)
Membre du personnel
l'URL que tu as testée contient un / à la fin, c'est pas pareil.

sinon, clique sur Tester l'URL en direct, et dis-nous ce que ça donne
 

ungars

WRInaute discret
Bonjour, je te remercie de ta réponse.

A quelle endroit j' ai mis un / , je ne le vois pas .

Quand je teste l' url cela semble fonctionner, la page est indexable : https://www.cjoint.com/c/LFvharzS3ud

J' ai déjà demandé plusieurs fois une indexation.

Merci beaucoup pour le coup de main ! Bonne journée.
 

WebRankInfo

Olivier Duffez (admin)
Membre du personnel
le site où tu uploades les images les compresse tellement qu'on ne voit pas grand chose. Tu peux les uploader directement dans le forum...

dans les captures d'écran, au-dessus de "Inspection de l'URL", on voit l'URL sans / à la fin
 

ungars

WRInaute discret
Bonsoir et merci de ta réponse. Il faut donc rajouter le / à la fin de l' url ? Je ne le savais pas désolé.
Je l' ai donc rajouté, tu peux le voir dans la barre d' adresse, par contre il disparait en dessous, quand on a les résultats...

J' ai uploadé l' image comme tu me l' as demandé

Là aussi, tout est au vert.

La bonne nouvelle du soir, c' est que ma page a été indexée hier (le dernier cache datait du 21 Mai). Par contre j' ai toujours cette erreur de redirection.

Merci beaucoup pour ton aide, bonne soirée.
 

Fichiers joints

  • testslash.PNG
    testslash.PNG
    74.4 KB · Affichages: 5

ungars

WRInaute discret
Merci beaucoup, mais quand est il de ce problème de redirection qui m' est signalé dans ma console ?
Bonne journée.
 

WebRankInfo

Olivier Duffez (admin)
Membre du personnel
l'URL sans le / ne peut pas être indexée car elle est redirigée
l'URL avec le / est indexée
 

ungars

WRInaute discret
Bonsoir, merci pour ta réponse.

L' url avec le / c' est celle de mon site si j' ai bien compris, elle est indexée.

L'url sans le / n' est pas indexée, mais je ne comprends pas en fait d' ou elle sort. Elle est redirigée par quel procédé, moi je n' ai pas souvenir d' avoir sciemment redirigé quelque url qu' elle soit.

Le fait que cette url sans le / soit désindexée pour ce problème de redirection, est ce préjudiciable pour le référencement du site ?

Je te souhaite une bonne journée.
 

WebRankInfo

Olivier Duffez (admin)
Membre du personnel
dans ton 1er message c'est toi qui parle de cette URL sans le /
c'est normal qu'elle ne soit pas indexée vu qu'elle fait une 301
bref, affaire classée !
 

ungars

WRInaute discret
Bonsoir, oui effectivement, après jusqu' à ce que tu me le dises, je ne faisais pas la différence entre les url avec un / ou sans.

Oui, affaire classée, mais j' aimerai comprendre :

- Pour quelle raison ma console m' a sorti cette url et pourquoi elle fait une redirection 301, car je ne l' ai jamais décidé.

- Est ce que cela va pénaliser mon référencement ?

Merci encore pour le temps que tu me consacres, et pour ta patience. Bonne soirée.
 

WebRankInfo

Olivier Duffez (admin)
Membre du personnel

ungars

WRInaute discret
Alors j' ai fait des erreurs sur le site ! C' est pour ça.

Sur la page en question, j' ai par exemple mis deux liens internes (chauffagiste et climatisation avignon) . Je n' ai pas mis de /

Et il y avait bien au moins un lien interne vers cette mauvais url

Je dois donc les rajouter ?

Et donc du fait qu' il n' y a plus de lien vers les mauvaises url, cette fois ci l' affaire sera classée pour de bon ?

Merci beaucoup !
 

ungars

WRInaute discret
Comme je te disais, jusqu' à ce post je ne savais pas qu' il y avait une différence entre une url avec ou sans / .
Vu que les url sans le / fonctionnait, je n' avais pas vu le problème. Je découvre un peu tout au fur et à mesure.

Et puis je n' ai ce problème que sur cette page dans ma console, alors que l' erreur je l' ai faite partout. Si cela me l' avait été signalé sur toute les pages, cela aurait sans doute fait tilt plus tôt !

Je corrige mes url dans la soirée.

Encore merci du coup de main.
 

ungars

WRInaute discret
Bonjour, j' avais fait une demande de validation la semaine dernière, mais elle m' est revenue en échec hier.
Peut être parce que je n' ai fait les modifications que Jeudi.

Merci beaucoup, bon Dimanche.
 

Fichiers joints

  • echec.PNG
    echec.PNG
    70.7 KB · Affichages: 4

Madrileño

Membre Honoré
Bonjour,

Dernière exploration mardi 21 juin.

Temps de réponse : 5 minutes.
Cordialement.
 
Dernière édition:

ungars

WRInaute discret
Bonjour, merci pour ta réponse. J'avais vu aussi l'échec au 25 et un mail reçu en ce sens le même jour.
Je vais donc attendre la prochaine indexation !

Passe une bonne après midi.
 

ungars

WRInaute discret
Bonjour,
J' ai patienté, mais j' ai toujours cette erreur, et cela fait plus d' un mois que je l' ai corrigé (oubli d' un slash dans l' ancre d' une url sur une page) .

La page a été mise à jour le 26 Juillet, mais n' a pas été explorée depuis le 21 Juin.

Si je supprime cette url dans ma Google Search (l' url sans le slash que j' avais oublié de mettre dans mon ancre) , est ce que ce serait une bonne chose ? Est ce que cela ne va pas pénaliser la vrai url ecrite comme il faut avec le slash (https://www.ahpc-energie.fr/plombier-avignon/) . Si j' ai bien compris non, puisque ce n' est pas la même url, mais vu que l' url sans le slash est redirigée vers la bonne url, j' ai un doute.

Merci pour votre aide, bonne journée.
 

Fichiers joints

  • redirection2.PNG
    redirection2.PNG
    73.5 KB · Affichages: 1
  • redirection1.PNG
    redirection1.PNG
    75.1 KB · Affichages: 1
Dernière édition:

ungars

WRInaute discret
Salut à tous, ça y est, enfin je n' ai plus ce message d' erreur, près de 2 mois après l' avoir corrigé... D' habitude quand je corrige et que Google le constate, j' ai un mail, mais pas là. Je ne sais donc pas depuis quand c' est d' actualité, mais cela date de moins d' une semaine.

Merci à tous et bonne soirée.
 

Discussions similaires

Haut