probleme area="poly" et placement de div [RESOLU]

webmasterdemonsite

WRInaute impliqué
bonjour

j'ai un probleme insoluble:

sur une map (en rouge) je veux placer:

wri.gif


- des div (en bleu et en jaune) qui affichent des fichiers images (gif avec transparence)
et
- des zones cliquables area sur les div en bleu et en jaune

je parviens à afficher soit les div, soit les zones cliquables

mais quand je tente d'afficher les deux, les div se superposent aux zones cliquables et la zone devient NON-cliquable...

sachant que la balise <area> ne semble pas supporter background-iamge en css...

un coup de pouce serait le bien venu, car j'ai passé la matinée sur ce probleme ...grr....

bonne journée à tous
 

aladdin

WRInaute passionné
Re: probleme area="poly" et placement de div

essai d'utiliser le css z-index pour mettre ton area en avant plan.
en mettant des div en z-index:0 et ton area en z-inde:1 par exemple ;)
 

jeroen

WRInaute passionné
Re: probleme area="poly" et placement de div

Pourquoi ne pas mettre les liens directement sur les fichier image ?
 

webmasterdemonsite

WRInaute impliqué
Re: probleme area="poly" et placement de div

salut

aladdin a dit:
essai d'utiliser le css z-index pour mettre ton area en avant plan.
en mettant des div en z-index:0 et ton area en z-inde:1 par exemple ;)

je ne connaisais pas z-index...donc j'ai essayé ceci:

Code:
<!-- la DIV de ma map -->

<div style="position: absolute;
            left: 0px;
            top: 0px;
            width: 100px;
            height: 100px;
            ">
     <img src="map.bmp" width="100" height="100" border="0" usemap="#map" />
     <map name="map">
     <area style="z-index: 111111111;"  shape="rect" coords="30,22,67,54" href="#" />
     </map>
</div>

<!-- la DIV de l'objet -->

<div style="z-index: 1;
            position: absolute;
            left: 30px;
            top: 22px;
            background-image: url(objet.bmp);
            width: 38px;
            height: 33px;
            ">
</div>

mais l'area ne semble pas au premiere plan et la zone n'est pas cliquable :(

jeroen a dit:
Pourquoi ne pas mettre les liens directement sur les fichier image ?

car l'image n'est pas carré...seule le polygone doit etre cliquable et le polygone doit etre une image...
 

webmasterdemonsite

WRInaute impliqué
oups

merci encore aladdin !

en fait ca marche avec le z-index (dans mon dernier post, j'avais oublier de gérer la transparence des images...)

encore merci, dire que j'ai passer 7heures sur ce probleme alors qu'un z-index etait la solution...
 

Discussions similaires

Haut