Probleme attribut alt non pris en compte par les outils SEO

Discussion dans 'Débuter en référencement' créé par auderef, 28 Juin 2016.

  1. auderef
    auderef Nouveau WRInaute
    Inscrit:
    17 Mars 2016
    Messages:
    15
    J'aime reçus:
    0
    Bonjour,

    En passant mon site "a la moulinette" d'outils SEO ils me disent tous que j'ai un problème sur les balises alt.

    J'ai fait plusieurs test mais je n'arrive pas à voir d'ou vient le problème !

    Outils utilisés :

    SEO Quake m'indique "6 images without ALT"
    SEO Grader m'indique un point rouge sur les images et le nom alternatif reste vide.

    Partie du code : (exemple pour une image)
    <img src=\"images/logo2.png\" width=\"265\" height=\"59\" alt=\"Piles CR2032\" border=\"0\" style=\"max-width: 100%; height: auto;\">

    Avec ou sans les \", placé en début ou en fin de la balise img, avec ou sans tout ce qui suit style, rien n'y fait.
    A savoir : le style CSS n'est pas placé sur une feuille externe mais dans la page elle même, j'ai fait cela pour passer à l'aise sur google insight et je n'ai pas envie d'en changer (sinon il me met un message d'erreur).

    J'ai utilisé les modes de compression et tout ce qu'il faut (gzip, keep alive, character set, cache validator etc etc...) pour passer sur google insight et gtmetrix. Je les aient mis dans htaccess, php.ini et je sais plus ou (cela date un peu pour moi). Je vous dit tout cela des fois que le problème vienne de là...

    Cela concerne mon site sur les piles : http://www.pile-cr2032.com

    Score obtenus :
    google insight mobile et ordinateur : 100
    gtmetrix : A et A (99% et 96%)
    W3c était valide jusqu'a ce que je mette favicon et microdata (mais je vais le régler sous peu)
    Grader 74/100

    J'avoue que je sèche un peu là du coup donc si quelqu'un à une piste, je suis prenneur.
    Merci
     
  2. UsagiYojimbo
    UsagiYojimbo WRInaute accro
    Inscrit:
    23 Novembre 2005
    Messages:
    11 875
    J'aime reçus:
    72
    Le alt de l'image dont tu parles est KO au niveau HTML. Le moteur ne voit pas le code source original, il voit uniquement le rendu HTML. Et dans le cas qui t'intéresse, il n'y a pas de double quote finale.

    Par ailleurs, je pense que tu as pas mal d'autres trucs à faire avant de te poser sur les alt du site, le code source est affreux :

    - CSS en vrac dans la page, et en inline via la balise style
    - meta keywords surchargée à l'extrême
    - utilisation d'espace insécable (&nbsp;) pour gérer des espacements
    - sitemap XML indexé
    etc.
     
  3. auderef
    auderef Nouveau WRInaute
    Inscrit:
    17 Mars 2016
    Messages:
    15
    J'aime reçus:
    0
    Ok merci pour la réponse.
    Faudra donc que je retravaille un peu tout cela.

    Par contre que veut dire sitemap.xml indexé?

    Les espaces insécables sont a proscrire?? (dans ce cas c’était pour obtenir un léger décalage)

    Les meta keyword je vais les enlever en grande partie.

    Quand vous dites style inline c'est par exemple dans les images avec la balise style? Il faudra donc que j'y remedie.

    Cependant j'ai fait des tests avec du html simple, sans style ni rien,une image et c'est tout, voici le code source :
    <html>
    <head>
    <title>Sans Titre</title>
    <meta http-equiv="content-type" content="text/html; charset=iso-8859-1">
    </head>
    <body bgcolor="#FFFFFF">
    <hr>
    <img width=217 height=217 src="images/cr2032.jpg" alt=pile-cr2032-varta.png >
    </body>
    </html>

    la page est ici vous pouvez vérifier :
    http://www.auderef.com/test2/index.html

    Et pourtant SEO Quake met toujours "1 images without ALT." donc je ne comprends pas j'ai du sauter un épisode..

    En tout cas merci pour vos remarques.

    Mais malgré mon code j'ai des bons scores sur les outils seo mais les visites ne suivent pas ni le classement ce qui est quand même le plus important j'en conviens
     
  4. UsagiYojimbo
    UsagiYojimbo WRInaute accro
    Inscrit:
    23 Novembre 2005
    Messages:
    11 875
    J'aime reçus:
    72
    Toujours pour les mêmes raisons : dans le code source HTML (que tu peux afficher depuis ton navigateur, le contenu de l'attribut alt de ton image n'est pas encapsulé dans des "".
     
  5. auderef
    auderef Nouveau WRInaute
    Inscrit:
    17 Mars 2016
    Messages:
    15
    J'aime reçus:
    0
    bien vu mais ça ne règle rien le message d'erreur est toujours là le vilain!

    Par contre SEO grader me le valide bien lui contrairement a Quake
     
  6. UsagiYojimbo
    UsagiYojimbo WRInaute accro
    Inscrit:
    23 Novembre 2005
    Messages:
    11 875
    J'aime reçus:
    72
    Tu as des absences de "" sur d'autres attributs de ta balise image (les width et height). J'imagine que ça peut perturber certains outils.
     
  7. auderef
    auderef Nouveau WRInaute
    Inscrit:
    17 Mars 2016
    Messages:
    15
    J'aime reçus:
    0
    merci pour la réponse rapide mais c'est toujours pareil. Je vais finir par penser que quake est bugé...

    mais je vois qu'au w3c ce petit bout de code ne passe pas je vais bosser dessus voir si ca regle ce probleme

    ok j'ai changé le doctype de strict vers transitional car <body bgcolor="#FFFFFF"> mettait 2 erreurs. Là c'est validé mais rien ne change pour quake.
     
  8. UsagiYojimbo
    UsagiYojimbo WRInaute accro
    Inscrit:
    23 Novembre 2005
    Messages:
    11 875
    J'aime reçus:
    72
    https://www.google.fr/search?client=firefox-b&biw=1440&bih=690&q=site% ... type%3Axml

    Pour du décalage de texte, on utilise la propriété css text-indent

    Ils ne servent plus à rien, et peuvent juste pénaliser le site en cas de suroptimisation (comme ici).

    Pour info, ce sont des outils TIERS. Ils se focalisent sur certains éléments connus de l'algorithme, mais avoir de bonnes notes sur ces outils n'est pas de facto associé à l'acquisition de trafic.
     
  9. auderef
    auderef Nouveau WRInaute
    Inscrit:
    17 Mars 2016
    Messages:
    15
    J'aime reçus:
    0
    Ok merci pour toutes ces infos et votre réactivité. Je viens d'enlever la balise keywords.

    Me reste a voir pour le fichier map comment faire.

    après oui je sais que les notes des outils SEO n'ont rien a voir avec le trafic mais je veux obtenir les meilleures notes possibles tout de meme. Ce qu'ilme manque clairement ce sont les backlinks de qualité.
     
  10. patrick_lejeune
    patrick_lejeune WRInaute occasionnel
    Inscrit:
    1 Avril 2016
    Messages:
    428
    J'aime reçus:
    0
    Oublie tous ces espèces d'outils et concentre toi sur ton site.
    Un site sur un seul sujet qui 16 sur pile cr2032 (avec le nom de domaine et seul réel contenu), c'est très faible, surtout que c'est pas forcément concurrentiel.
    Sur les quelques "pauvres pages" du site, vire déjà le lien "Retour en page d'accueil" pour le mettre soit en balise alt sur le logo (achat - vente pile cr2032) ou au moins les mots clés sur le texte du lien.

    Le référencement, c'est pas des outils: c'est de la réflexion. Tu gagnera plus de visiteur sur le contenu que essayer de comprendre des espèces d'outils quasiment inutiles (surtout avec un site de 5 pages avec 1 seule page intelligente - l'accueil).
     
  11. Leonick
    Leonick WRInaute accro
    Inscrit:
    8 Août 2004
    Messages:
    19 417
    J'aime reçus:
    0
    à partir de combien de répétition considères-tu que ça devient de la suroptimisation ? 40 fois ? car là, on trouve 39 fois le mot CR2032 8O
    tu crois que si tu avais un client devant toi tu pourrais lui débiter tout le contenu de ton texte sans qu'il te coupe la parole en te disant d'abréger ? :wink:
     
Chargement...
Similar Threads - Probleme attribut alt Forum Date
WordPress Probleme avec attribut ALT de certaines images Référencement Google 8 Octobre 2018
Problème d'attribution des conversions suite au passage du tunnel en HTTPS Google Analytics 25 Mars 2015
Problème sur les redirections de pages profondes URL Rewriting et .htaccess Mercredi à 13:53
Problème de référencement et ajout sitemaps Problèmes de référencement spécifiques à vos sites 26 Novembre 2019
Problème affichage des derniers articles wordpress page accueil Administration d'un site Web 20 Novembre 2019
Gestion de cookies problème directives CNIL. Administration d'un site Web 15 Novembre 2019
Search Console URL exclues : comment résoudre le problème ? Problèmes de référencement spécifiques à vos sites 15 Novembre 2019
Search Console Premier référencement et problèmes Débuter en référencement 11 Novembre 2019
Test d'optimisation mobile : Problèmes de chargement de la page Débuter en référencement 10 Novembre 2019
Problème sur une source Referral Googleads.g.doubleclick.net Google Analytics 7 Novembre 2019
  1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies.
    Rejeter la notice