Probleme ! envoi de formulaire en php sous OVH

Discussion dans 'Administration d'un site Web' créé par mage34, 21 Mars 2005.

Tags:
  1. mage34
    mage34 WRInaute discret
    Inscrit:
    5 Mai 2003
    Messages:
    79
    J'aime reçus:
    0
    Salut à tous !

    J'ai un soucis. J'ai crée un formulaire dont voici le code :

    fichier form1 :

    !DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <html>
    <head>
    <title>Document sans titre</title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    </head>

    <body>
    <form action=form2.php method=post target="_self">
    <strong>Objet de votre message :<br />
    <select name=SUJET size=1 id="SUJET">
    <option value="no" selected>Choisissez votre sujet ...</option>
    <option value="Autre">Autre</option>
    <option value="Service commercial">Service commercial</option>
    <option value="Partenariats">Partenariats</option>
    <option value="Presse">Presse</option>
    </select>
    <br />
    <br />
    Entrez votre adresse e-mail :<br />
    <input
    name=FROM value="@" size="30" onFocus="this.value=''" maxlength="100" sizeA??U??????????????Í=40 : >
    <br />
    <br />
    Votre message :<br />
    <textarea name=message cols=30 rows=4 wrap="VIRTUAL" :></textarea>
    <br />
    <br />
    <input style="BORDER-RIGHT: #000000 1px solid; BORDER-TOP: #000000 1px solid; BORDER-LEFT: #000000 1px solid; CURSOR: hand; BORDER-BOTTOM: #000000 1px solid; BACKGROUND-COLOR: #cccccc" type=submit value="Envoyer" name=Submit>
    </strong>
    </form>
    </body>
    </html>

    fichier form2 :

    <?php
    mail("",
    "$SUJET",
    "
    ".str_replace("\\","",$MESSAGE)."

    ","From: $FROM");
    ?>
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <html>
    <head>
    <title>Document sans titre</title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    </head>

    <body>
    <strong>Message envoy&eacute;</strong>
    </body>
    </html>

    le formulaire s'envoi correctement mais les champs n'apparaissent pas ! Je suis en dédié chez ovh, j'ai passé la nuit la dessus et je ne voit pas ce qu'il faut faire...
     
  2. ludoanimation
    ludoanimation WRInaute impliqué
    Inscrit:
    25 Juillet 2003
    Messages:
    677
    J'aime reçus:
    0
    et si tu remplacait $sujet par $HTTP_POST_VARS["sujet"] et pareil pour les autres champs, ca marcherait pas mieux ?
     
  3. olivieri
    olivieri WRInaute impliqué
    Inscrit:
    3 Février 2003
    Messages:
    689
    J'aime reçus:
    0
    oui, ou par $_POST["sujet"]
     
  4. Bobulum
    Bobulum WRInaute discret
    Inscrit:
    21 Mars 2005
    Messages:
    56
    J'aime reçus:
    0
    C'est pas sur que ca marche mieux, mais c'est beaucoup plus sécurisé...

    Il ne faut pas oublier si tu as une page après de rappeller les variables php via des champs cachés.
     
  5. mage34
    mage34 WRInaute discret
    Inscrit:
    5 Mai 2003
    Messages:
    79
    J'aime reçus:
    0
    ok merci à vous tous ça fonctionne parfaitement maintenant et grace a vous :)
     
  6. olivieri
    olivieri WRInaute impliqué
    Inscrit:
    3 Février 2003
    Messages:
    689
    J'aime reçus:
    0
    Et vire ton email de ton 1er post, ca évitera des mauvaises surprises ...
     
  7. mage34
    mage34 WRInaute discret
    Inscrit:
    5 Mai 2003
    Messages:
    79
    J'aime reçus:
    0
    je viens de l'enlever mais c un peu tard chui bon pour me recréer une boite ( en tt cas merci de me l'avoir signaler )
     
  8. mickae13
    mickae13 Nouveau WRInaute
    Inscrit:
    21 Juin 2011
    Messages:
    1
    J'aime reçus:
    0
    Bonsoir,

    Je me permets de déterrer ce post car il m'intéresse mais il manque un morceau ... Pouvez-vous me dire où faut-il entrer l'adresse mail pour recevoir le formulaire ?


    Merci !
    Niko
     
Chargement...
Similar Threads - Probleme envoi php Forum Date
PHP -Problème retraitement données Mysql avant envoit dans un tableau array Développement d'un site Web ou d'une appli mobile 28 Décembre 2016
Problème avec l'envoi d'un mail sans contenu php Développement d'un site Web ou d'une appli mobile 7 Septembre 2016
Problème configuration évènement envoi formulaire Google Analytics Google Analytics 14 Mars 2014
Problème d'envoi de mail Développement d'un site Web ou d'une appli mobile 8 Juillet 2013
Problème envoi mots clés $_SERVER['HTTP_REFERER'] Administration d'un site Web 24 Mai 2012
Probleme d'envoi de mail en html avec serveur smtp Développement d'un site Web ou d'une appli mobile 7 Décembre 2009
probleme envoi un fichier a l'email à partir d'un formulaire Développement d'un site Web ou d'une appli mobile 3 Octobre 2009
Problème avec REQUEST_URI qui ne me renvoie pas l'URL rewritée ! Développement d'un site Web ou d'une appli mobile 6 Décembre 2008
Contrer le problème d'envoi d'e-mails Administration d'un site Web 5 Décembre 2008
[RESOLU] probléme d'envoi de formulaire Développement d'un site Web ou d'une appli mobile 24 Juillet 2008
problème d'envoie de mail Administration d'un site Web 14 Avril 2008
probleme envoi de mail par mon crm Administration d'un site Web 26 Mars 2008
Probleme avec le bouton d'envoi d'un formulaire Développement d'un site Web ou d'une appli mobile 22 Mars 2008
Envoi d'une newsletter / problème headers / spam Développement d'un site Web ou d'une appli mobile 18 Février 2008
Problème dans l'envoie d'un newsletter Développement d'un site Web ou d'une appli mobile 1 Janvier 2007
Problèmes d'envoi d'e-mail ? Les serveurs mentent ! Administration d'un site Web 1 Septembre 2006
Probleme d'envoi avec gmail via Outlook Gmail, Google Talk, Blogger et Orkut 8 Décembre 2004
Probleme d'envois de formulaire par mail Administration d'un site Web 25 Octobre 2004
Problème envoi formulaire avec windows XP Administration d'un site Web 8 Février 2004
Problemes d'envoi Administration d'un site Web 31 Octobre 2003