Problème phpbb3 : Fatal error: Cannot redeclare deregister_globals

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par landry, 12 Novembre 2011.

  1. landry
    landry WRInaute discret
    Inscrit:
    3 Mai 2006
    Messages:
    208
    J'aime reçus:
    0
    Bonjour,

    J'ai voulu installé un p****n de MOD de m*****e (oui je suis très énervé là :) ) afin de partager des posts via des ancres sur Facebook, plutôt que le topic en entier.

    J'ai installé cette daube de mvinny-Share-On. Il demande de modifier quelques fichiers PHPBB3, il se connecte à la DB et inclue 3 tonnes et demi de fichier annexes tout ça pour un résultat minable. En fait il ajoute quelques pov' icône, pas belles en prime, sur le premier topic. Chose que j'aurai pu faire moi-même manuellement car en plus le résultat que j'attendais est absent.

    Bon, je le désinstalle et je restaure mes fichiers avec la save que j'avais fait avnt et là dès que je veux ouvrir un topic :
    Je sais ce que ça veut dire mais il n'y a pas de doublon, j'ai restauré mes anciens fichiers PHP et viré ceux que j'avais modifié en installant ce MOD.

    Je me dis que ça vient peut être de la DB, je la restaure aussi mais même résultat.

    Là je suis perdu et mon forum est planté.

    Une aide me serait plus qu'utile.

    Merci.
     
  2. padadam22
    padadam22 WRInaute accro
    Inscrit:
    23 Octobre 2010
    Messages:
    3 115
    J'aime reçus:
    0
    Tu as bien vidé tous les caches ?
     
  3. landry
    landry WRInaute discret
    Inscrit:
    3 Mai 2006
    Messages:
    208
    J'aime reçus:
    0
    Bonsoir padadam22,

    Oui, plusieurs fois, avec phpBB3 et manuellement via le ftp. Je n'ai jamais rencontré un bug pareil, je ne comprends pas.
    Je ne sais plus où chercher.
    J'ai restauré mes fichers Forum dans leur intégralité et restauré la DB mais rien n'y fait. On dirait un faux semblant, je pense qu'il n'y a pas d'erreur mais que le script lui en voit une.

    Que faire ...

    J'ai demandé à OVH de restaurer mon site à la veille, je verrai bien mais je n'y crois guère.

    J'ai lu quelque part, en anglais, que cela peut se produire si une fonction est désinstallée alors qu'elle est sur 'on'. C'était le cas. Mais bon, y'a bien un remède.
     
  4. padadam22
    padadam22 WRInaute accro
    Inscrit:
    23 Octobre 2010
    Messages:
    3 115
    J'aime reçus:
    0
    Et si tu supprimes complètement ta base et réinstalle la sauvegarde ?
     
  5. landry
    landry WRInaute discret
    Inscrit:
    3 Mai 2006
    Messages:
    208
    J'aime reçus:
    0
    Tu penses que c'est la DB qui déconne, je pourrais juste virer la partie concernat viewtopic et la remettre. Car le reste du forum fonctionne.
     
  6. landry
    landry WRInaute discret
    Inscrit:
    3 Mai 2006
    Messages:
    208
    J'aime reçus:
    0
    Finalement c'est pas la db, c'est bien phpbb3. J'ai restauré une sauvegarde encore plus vieille te là ça fonctionne.
    Donc je vais procéder par élimination afin de trouver le dossier, ou fichier, qui foire.

    En touts cas un grand merci pour ton soutien, sympa !!! :wink:
     
  7. padadam22
    padadam22 WRInaute accro
    Inscrit:
    23 Octobre 2010
    Messages:
    3 115
    J'aime reçus:
    0
    Content que tu ai trouvé :)
     
  8. landry
    landry WRInaute discret
    Inscrit:
    3 Mai 2006
    Messages:
    208
    J'aime reçus:
    0
    Merci, maintenant je vais passer les fichiers et dossiers un par un afin de trouver le coupable. :)
    a++
     
Chargement...
Similar Threads - Problème phpbb3 Fatal Forum Date
Problèmes d'indexations de Google Crawl et indexation Google, sitemaps Hier à 12:10
Problème d'indexation pour de nombreuses pages Débuter en référencement 10 Octobre 2020
Microdonnées : problème avec product Débuter en référencement 6 Octobre 2020
Probléme de texte gras, code HTML Demandes d'avis et de conseils sur vos sites 5 Octobre 2020
Search Console J'ai un problème : 5 pages indexés et 43 exclues Crawl et indexation Google, sitemaps 2 Octobre 2020
Search Console Problème d'indexations de pages produits Crawl et indexation Google, sitemaps 30 Septembre 2020
Search Console Probleme redirection nom de domaine et indexation google Crawl et indexation Google, sitemaps 16 Septembre 2020
Problème passerelle sur Prestashop e-commerce 8 Septembre 2020
Problème indexation Google desktop/mobile Problèmes de référencement spécifiques à vos sites 3 Septembre 2020
Search Console Problèmes chargements images Crawl et indexation Google, sitemaps 3 Septembre 2020