Problème phpbb3 : Fatal error: Cannot redeclare deregister_globals

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par landry, 12 Novembre 2011.

  1. landry
    landry WRInaute discret
    Inscrit:
    3 Mai 2006
    Messages:
    208
    J'aime reçus:
    0
    Bonjour,

    J'ai voulu installé un p****n de MOD de m*****e (oui je suis très énervé là :) ) afin de partager des posts via des ancres sur Facebook, plutôt que le topic en entier.

    J'ai installé cette daube de mvinny-Share-On. Il demande de modifier quelques fichiers PHPBB3, il se connecte à la DB et inclue 3 tonnes et demi de fichier annexes tout ça pour un résultat minable. En fait il ajoute quelques pov' icône, pas belles en prime, sur le premier topic. Chose que j'aurai pu faire moi-même manuellement car en plus le résultat que j'attendais est absent.

    Bon, je le désinstalle et je restaure mes fichiers avec la save que j'avais fait avnt et là dès que je veux ouvrir un topic :
    Je sais ce que ça veut dire mais il n'y a pas de doublon, j'ai restauré mes anciens fichiers PHP et viré ceux que j'avais modifié en installant ce MOD.

    Je me dis que ça vient peut être de la DB, je la restaure aussi mais même résultat.

    Là je suis perdu et mon forum est planté.

    Une aide me serait plus qu'utile.

    Merci.
     
  2. padadam22
    padadam22 WRInaute accro
    Inscrit:
    23 Octobre 2010
    Messages:
    3 104
    J'aime reçus:
    0
    Tu as bien vidé tous les caches ?
     
  3. landry
    landry WRInaute discret
    Inscrit:
    3 Mai 2006
    Messages:
    208
    J'aime reçus:
    0
    Bonsoir padadam22,

    Oui, plusieurs fois, avec phpBB3 et manuellement via le ftp. Je n'ai jamais rencontré un bug pareil, je ne comprends pas.
    Je ne sais plus où chercher.
    J'ai restauré mes fichers Forum dans leur intégralité et restauré la DB mais rien n'y fait. On dirait un faux semblant, je pense qu'il n'y a pas d'erreur mais que le script lui en voit une.

    Que faire ...

    J'ai demandé à OVH de restaurer mon site à la veille, je verrai bien mais je n'y crois guère.

    J'ai lu quelque part, en anglais, que cela peut se produire si une fonction est désinstallée alors qu'elle est sur 'on'. C'était le cas. Mais bon, y'a bien un remède.
     
  4. padadam22
    padadam22 WRInaute accro
    Inscrit:
    23 Octobre 2010
    Messages:
    3 104
    J'aime reçus:
    0
    Et si tu supprimes complètement ta base et réinstalle la sauvegarde ?
     
  5. landry
    landry WRInaute discret
    Inscrit:
    3 Mai 2006
    Messages:
    208
    J'aime reçus:
    0
    Tu penses que c'est la DB qui déconne, je pourrais juste virer la partie concernat viewtopic et la remettre. Car le reste du forum fonctionne.
     
  6. landry
    landry WRInaute discret
    Inscrit:
    3 Mai 2006
    Messages:
    208
    J'aime reçus:
    0
    Finalement c'est pas la db, c'est bien phpbb3. J'ai restauré une sauvegarde encore plus vieille te là ça fonctionne.
    Donc je vais procéder par élimination afin de trouver le dossier, ou fichier, qui foire.

    En touts cas un grand merci pour ton soutien, sympa !!! :wink:
     
  7. padadam22
    padadam22 WRInaute accro
    Inscrit:
    23 Octobre 2010
    Messages:
    3 104
    J'aime reçus:
    0
    Content que tu ai trouvé :)
     
  8. landry
    landry WRInaute discret
    Inscrit:
    3 Mai 2006
    Messages:
    208
    J'aime reçus:
    0
    Merci, maintenant je vais passer les fichiers et dossiers un par un afin de trouver le coupable. :)
    a++
     
Chargement...
Similar Threads - Problème phpbb3 Fatal Forum Date
Problème avec phpbb2 vers phpbb3 Débuter en référencement 18 Janvier 2009
Problème installation phpBB3-SEO-Premod_V_3-0-4 Développement d'un site Web ou d'une appli mobile 5 Janvier 2009
Problèmes Données structurées Crawl et indexation Google, sitemaps Dimanche à 09:07
problème avec mon site Demandes d'avis et de conseils sur vos sites 28 Novembre 2022
Probleme tag sur Google tag manager Demandes d'avis et de conseils sur vos sites 24 Novembre 2022
Probleme Tag sur Google Tag Manager Google Analytics 18 Novembre 2022
Gros problème sur la profondeur de mes pages Problèmes de référencement spécifiques à vos sites 30 Septembre 2022
Problème de htaccess chez Ionos URL Rewriting et .htaccess 12 Septembre 2022
Problème sur jquery avec fonction asynchrone Développement d'un site Web ou d'une appli mobile 6 Septembre 2022
Problème de crawl et d'indexation Crawl et indexation Google, sitemaps 1 Septembre 2022
WordPress Problème affichage style avec Elementor (titre, bordures, separateur) Administration d'un site Web 8 Août 2022
Problème d'indexation de backlinks Débuter en référencement 24 Juillet 2022
Problème d'indexation de backlinks Problèmes de référencement spécifiques à vos sites 21 Juillet 2022
Probleme de visibilité de ma page Facebook Facebook 5 Juillet 2022
problème avec le développeur Droit du web (juridique, fiscalité...) 22 Juin 2022
Problème désindexation des pages de Google Débuter en référencement 21 Juin 2022
Problème d'indexation de pages sur Google Problèmes de référencement spécifiques à vos sites 31 Mai 2022
problème de redirection non souhaitée Administration d'un site Web 28 Avril 2022
Problème d'indexation Produits Prestashop Crawl et indexation Google, sitemaps 28 Avril 2022
Problème d'affichage des campagnes Google Ads dans un tableau de bord Data Studio AdWords 26 Avril 2022