Problème pour configurer un virtualhost avec dernière version de Easyphp

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par John Smith, 17 Mai 2014.

  1. John Smith
    John Smith WRInaute occasionnel
    Inscrit:
    4 Avril 2007
    Messages:
    281
    J'aime reçus:
    2
    Bonjour à tous !

    Je tournais depuis des années avec une vielle version d'easyphp et je me suis dit qu'en ce joli jour de mai, j'allais installer la dernière version, c'est à dire la version Esayphp DevServer 14.1. J'ai préalablement sauvegardé mes fichiers de configuration en particulier le fichier httpd.conf dans lequel j'avais configuré un virtualhost pour accéder à mon site local de manière plus fun, à savoir en entrant l'URL http://www.monsite.local, comme il est expliqué dans ce tuto : http://www.phpsources.org/developper-un-site-en-local_98.html.

    J'avais fait tout comme il dit le monsieur et ça marchait super sur mon ancienne version d'Easyphp. Alors j'ai modifié le httpd.conf de ma nouvelle config en ajoutant le code suivant :

    Code:
    NameVirtualHost *:80
    
    <VirtualHost *:80>
        DocumentRoot "D:/Mon espace de travail/Mes sites Web/Mon super site"
        ServerName monsite.local
        ServerAlias www.monsite.local
    </VirtualHost>
    Sachant que dans mon fichier host, j'ai :

    Code:
    127.0.0.1       monsite.local
    127.0.0.1       www.monsite.local
    
    Or quand je rentre l'URL http://www.monsite.local, je ne tombe plus sur mon site mais sur la page localweb qui n'est rien d'autre que 127.0.0.1, soit l'adresse du web local qui est défini dans Easyphp... :(

    Quelqu'un saurait-il m'expliquer où se trouve le problème ? Je lui en serais infiniment reconnaissant !

    Merci.
     
  2. loubet
    loubet WRInaute impliqué
    Inscrit:
    19 Février 2003
    Messages:
    793
    J'aime reçus:
    0
    bonjour,
    le serveur a bien été redémarré ?
     
  3. Axiso
    Axiso WRInaute passionné
    Inscrit:
    8 Avril 2004
    Messages:
    1 209
    J'aime reçus:
    0
    Tu as bien relancé le serveur EasyPhp pour prendre en compte les modifications ?
    A tout hasard hein ...
     
  4. Axiso
    Axiso WRInaute passionné
    Inscrit:
    8 Avril 2004
    Messages:
    1 209
    J'aime reçus:
    0
    Pfff. Bon, si c'était bien ça le problème, on se partage le point ? C'est important les points pour la boutique cadeaux WRI :)
     
  5. John Smith
    John Smith WRInaute occasionnel
    Inscrit:
    4 Avril 2007
    Messages:
    281
    J'aime reçus:
    2
    Oui, vu que je suis sur le problème depuis 2h, je pense avoir testé toutes les manips de base...
     
  6. spout
    spout WRInaute accro
    Inscrit:
    14 Mai 2003
    Messages:
    8 782
    J'aime reçus:
    240
    Semi HS: easy game avec WampServer: Click => Apache => Alias Directories => Add an alias
     
  7. John Smith
    John Smith WRInaute occasionnel
    Inscrit:
    4 Avril 2007
    Messages:
    281
    J'aime reçus:
    2
    Houlà ! Je ne lis pas le chinois moi ! ;)
     
  8. John Smith
    John Smith WRInaute occasionnel
    Inscrit:
    4 Avril 2007
    Messages:
    281
    J'aime reçus:
    2
    Bon eh bien, j'ai en partie réglé le problème en installant un module qui s'appelle Virtual Hosts Manager 1.4 avec lequel j'ai créé mon adresse local et maintenant quand je tape www.monsite.local, je tombe bien sur mon site mais là, j'ai un autre problème qui à mon avis n'a pas de rapport. Il s'avère que j'ai un répertoire styles/ et un répertoire scripts/, or, il semblerait que je n'y ai pas accès. Quand je tente de lire www.monsite.local/styles/style.css, j'ai le message suivant :

    Code:
    Erreur du serveur!
    
    Le serveur a été victime d'une erreur interne et n'a pas été capable de faire aboutir votre requête. Soit le server est surchargé soit il s'agit d'une erreur dans le script CGI.
    
    Si vous pensez qu'il s'agit d'une erreur du serveur, veuillez contacter le webmestre.
    
    Error 500
    J'imagine que ça doit être un truc tout con mais comme je n'ai jamais eu le problème auparavant je ne me suis pas penché sur le problème. Est-ce que cela vous dit quelque chose ?
     
  9. John Smith
    John Smith WRInaute occasionnel
    Inscrit:
    4 Avril 2007
    Messages:
    281
    J'aime reçus:
    2
    Bon, je pose les questions et je réponds moi-même ! J'avais un .htaccess dans mes répertoires styles/ et scripts/ qui apparemment serve à la compression de je ne sais quoi :

    Code:
    # Compression
    SetOutputFilter DEFLATE
    AddOutputFilterByType DEFLATE text/html text/css text/plain text/xml application/x-javascript
    Et ça n'a pas l'air d'être le super kif avec la version d'Apache du nouveau Easyphp, est-ce que quelqu'un saurait ce qu'il faut que je modifie... Bien-sûr, il me reste la solution de virer ce .htpaccess mais si un autre moi a mis ça à une époque lointaine, c'est qu'il devait avoir une bonne raison, le bougre !
     
  10. loubet
    loubet WRInaute impliqué
    Inscrit:
    19 Février 2003
    Messages:
    793
    J'aime reçus:
    0
    en local, tu peux le virer sans te poser de question.
    en production, si cela permet ou non de compresser les données, là il faut se poser des questions.
     
  11. John Smith
    John Smith WRInaute occasionnel
    Inscrit:
    4 Avril 2007
    Messages:
    281
    J'aime reçus:
    2
    Oui je sais bien mais je veux exactement le miroir entre le local et le distant, c'est la raison pour laquelle je me suis cassé la tête avec mon histoire de www.monsite.local qui est la quasi copie de www.monsite.fr...
     
Chargement...
Similar Threads - Problème configurer virtualhost Forum Date
Probleme configurer: time delayer et window.location Développement d'un site Web ou d'une appli mobile 16 Avril 2010
Problème de référencement de mon site Problèmes de référencement spécifiques à vos sites Jeudi à 14:05
Search Console Problème Fil d'Ariane : Vous devez indiquer name ou item.name Crawl et indexation Google, sitemaps Mardi à 23:07
Problèmes d'indexation et robots.txt Crawl et indexation Google, sitemaps Lundi à 10:59
Problème Keyword Planner AdWords 10 Octobre 2019
Url redirigée en 301 mais indexée : problème sitemap ? Crawl et indexation Google, sitemaps 9 Octobre 2019
Problème d'indexation Débuter en référencement 8 Octobre 2019
probléme file_get_contents Développement d'un site Web ou d'une appli mobile 4 Octobre 2019
problème tache cron Développement d'un site Web ou d'une appli mobile 3 Octobre 2019
Google my business problème de référencement sur nom du site Débuter en référencement 30 Septembre 2019
  1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies.
    Rejeter la notice