Script ".js" fonctionnel depuis 4 ans sous IE6 et plus avec

Polyèdre

Nouveau WRInaute
Bonjour à tous,

Comme tous les ans, je procède à une mise à jour de mes sites et je suis confronté à un script ".js" d'effet d'apparition progressive d'une image qui est opérationnel depuis 4 ans sur les pages "index.html" de mes sites vues sous XP Pro avec IE6 et ce script ne tourne plus sur un nouveau poste équipé d'XP Pro avec IE7 quand on vient sur ces mêmes pages sans que rien n'est été modifié dans ces pages.

L'image vient avec retard et en seul bloc à un emplacement incorrect dans la page !!..

Auriez-vous eu à faire avec cette anomalie et comment se traite t-elle ?..

Merci de vos réponses si vous avez traité ce phénomène.

Polyèdre
 

u94082

WRInaute occasionnel
Re: Script ".js" fonctionnel depuis 4 ans sous IE6 et plus avec

Salut,

Sans voir le code ça va être chaud !

T'as déjà une indication de la ligne qui fait bugguer ? Utilises-tu Firefox (et sa super console javascript) ?
 

Polyèdre

Nouveau WRInaute
Re: Script ".js" fonctionnel depuis 4 ans sous IE6 et plus avec

Bonsoir "antinomx",

Je ne pense pas que ce soit le code en lui-même qui soit en cause car il s'inscrit parmi d'autres dans cette page qui va fonctionner tout à fait normalement si elle est vue avec IE6 (l'effet sur l'image se déroule comme d'habitude) et si on ouvre cette même page avec IE7 elle se retrouve déformée (taille des tableaux) et l'image vient globalement à une position qui n'est pas la sienne.

En cliquant le "www" sous mon avatar c'est cette page en question qui va s'ouvrir et tu pourras constater le disfonctionnement entre les 2 versions 6 et 7 de IExplorer si tu en dispose sur ta machine.

Je penche pour une interprétation différente du ".js" par le navigateur entre les 2 versions 6 et 7.

Ce type de problème s'était déjà manifesté lors du passage des versions 5 à 5,5 et à 6 pour d'autres types de codes ou pour des scripts divers.

Si d'autres avaient résolu ce problème je vous en connaître l'origine (config IE7, modif du script à faire, etc..)

Cordialement.
 

skyll

WRInaute passionné
Re: Script ".js" fonctionnel depuis 4 ans sous IE6 et plus avec

Polyèdre a dit:
L'image vient avec retard et en seul bloc à un emplacement incorrect dans la page !!..

Tu veux parler de l'image RJ-tech... avec fond transparent et qui apparait à droite d'un coup au bout dde 3 secondes ?

[HS]Houuuu la joli collec de balise :mrgreen: [/HS]
 

Polyèdre

Nouveau WRInaute
Re: Script ".js" fonctionnel depuis 4 ans sous IE6 et plus avec

Exact, c'est cette image (notre logo) qui jusqu'à présent vient avec un effet sous IE6 et qui débarque avec retard et d'un seul coup quand on ouvre le site avec IE7.
 

Furtif

WRInaute accro
Re: Script ".js" fonctionnel depuis 4 ans sous IE6 et plus avec

Te prends pas la tete, trouve un autre script pour ta page d'accueil.

Ce n'est pas ce qui manque sur le net...

:D
 

Polyèdre

Nouveau WRInaute
Re: Script ".js" fonctionnel depuis 4 ans sous IE6 et plus avec

Bonjour,

J'ai résolu mon problème en modifiant mon code et mes scripts pour qu'ils fonctionnent sous IE6 et sous IE7 (le facécieux !!..), je continu donc mes mises à jour :mrgreen:

Cordialement
 

Discussions similaires

Haut