1. ✅ Apprenez une METHODE qui marche pour votre SEO ! Formation à distance avec Olivier Duffez et Fabien Facériès + aide pour prise en charge du financement
    Rejeter la notice

Seules quelques pages de mon blog sont indexées.

Discussion dans 'Débuter en référencement' créé par TopiCo, 13 Mars 2011.

  1. TopiCo
    TopiCo Nouveau WRInaute
    Inscrit:
    13 Mars 2011
    Messages:
    8
    J'aime reçus:
    0
    Bonsoir (bonjour ?),

    Je venais vous voir car il m'arrive une chose étrange que je n'arrive pas à expliquer malgré mes différents tests et diagnostics : Google n'aime pas les pages de mon blog. Qu'il ne laisse pas de commentaires, pourquoi pas, qu'il ne clique jamais sur mes "like" et mes "tweet", why not, mais qu'il n'indexe aucun de mes articles.. C'est pas son rôle de machine avaleuse de données pour son rouleau compresseur de pertinence ?

    J'ai un wordpress depuis deux ans, mais seuls 4 pages sont indexés.
    Savez-vous ce qui peut expliquer cela ? Je veux dire, je ne vois aucun facteur bloquant (d'autant plus que j'ai une machine de guerre du référencement en la personne de Wordpress).
    Bien entendu, voici son adresse : http://blog.objets-publicitaires-pro.com/

    En grand merci à celui ou celle qui découvrira ce qui devrait me sauter aux yeux, je l'imagine, c'est souvent comme ça.
    Merci d'avance à la communauté ;)
     
  2. Marie-Aude
    Marie-Aude WRInaute accro
    Inscrit:
    5 Juin 2006
    Messages:
    16 368
    J'aime reçus:
    2
    Simple, l'en tête http renvoie une erreur 404
     
  3. TopiCo
    TopiCo Nouveau WRInaute
    Inscrit:
    13 Mars 2011
    Messages:
    8
    J'aime reçus:
    0
    Bonsoir,

    Comment cela ?
    Car chez moi, le sous-domaine fonctionne parfaitement : http://blog.objets-publicitaires-pro.com/
    Vous avez une erreur 404 ?
     
  4. Marie-Aude
    Marie-Aude WRInaute accro
    Inscrit:
    5 Juin 2006
    Messages:
    16 368
    J'aime reçus:
    2
    Je n'ai pas une erreur 404, mais le header renvoyé par la page est une erreur 404

    Tu le verras pas exemple avec un outil comme le validateur w3c http://validator.w3.org
     
  5. TopiCo
    TopiCo Nouveau WRInaute
    Inscrit:
    13 Mars 2011
    Messages:
    8
    J'aime reçus:
    0
    Désolé d'être un peu chiant :(
    Il est valide, et je n'arrive pas à trouver l'erreur 404.
    Le cache de Google lit parfaitement tous les liens de la page.
    Comment expliquer que les articles n'ont jamais été indéxés :s

    Désolé si j'ai loupé cette erreur 404, impossible de la retrouver de mon côté.
     
  6. steph@ne
    steph@ne WRInaute discret
    Inscrit:
    5 Avril 2008
    Messages:
    66
    J'aime reçus:
    0
  7. TopiCo
    TopiCo Nouveau WRInaute
    Inscrit:
    13 Mars 2011
    Messages:
    8
    J'aime reçus:
    0
    Là, j'avoue que je ne comprends pas.
    J'ai donc cela :
    ( http://validator.w3.org/check?uri=http%3A%2F%2Fblog.objets-publicitaires-pro.com%2F&charset=%28detect+automatically%29&doctype=Inline&group=0 ) qui me dit : votre page est valide.

    Je look le cache, tous les liens sont visibles.
    Je clique sur chacun des liens, chacun me renvoie à la page de l'article en question.
    Toutes les images s'affichent chez moi comme sur d'autres connexions/ordinateurs.

    Serait-ce un problème d'URL Rewritting ?

    Big Thx par avance ;)
     
  8. steph@ne
    steph@ne WRInaute discret
    Inscrit:
    5 Avril 2008
    Messages:
    66
    J'aime reçus:
    0
  9. TopiCo
    TopiCo Nouveau WRInaute
    Inscrit:
    13 Mars 2011
    Messages:
    8
    J'aime reçus:
    0
    Thx, je comprends un peu mieux.
    Mais tout cela est généré sous wordpress, vous pensez que je pourrais résoudre le problème en faisant quel type de manipulation ?
    Car je n'ai pas à l'heure actuelle accès au FTP.
    La redirection du http est mauvaise, si j'ai bien compris.

    Selon vous, c'est le type de redirection qui est mauvais, où le lien envoyé par "location" à changer ?
    ;)
     
  10. djb77
    djb77 Nouveau WRInaute
    Inscrit:
    3 Mars 2011
    Messages:
    14
    J'aime reçus:
    0
  11. Marie-Aude
    Marie-Aude WRInaute accro
    Inscrit:
    5 Juin 2006
    Messages:
    16 368
    J'aime reçus:
    2
    Ce n'est pas un comportement normal de wordpress. Même si tu n'as pas accès au ftp tu peux regarder le contenu du fichier header.php dans ton éditeur de thème, si il n'y a rien de bizarre, c'est au niveau htacess ou au niveau serveur

    A voir avec ton webmaster
     
  12. TopiCo
    TopiCo Nouveau WRInaute
    Inscrit:
    13 Mars 2011
    Messages:
    8
    J'aime reçus:
    0
    Merci pour vos réponses.
    J'ai eu accès à header.php
    > il commence par
    Code:
    <!DOCTYPE html Public
    . (Normal ?)
    > il n'y a pas de fichier htacess sur le serveur, donc le problème ne peut pas venir de là.
    > Il ne semble pas y avoir de code ajouté pour la redirection.. du moins, pas de "location" sur index, page ou encore header...

    Si quelqu'un a une idée, je lui en serai très reconnaisant :wink:
     
  13. steph@ne
    steph@ne WRInaute discret
    Inscrit:
    5 Avril 2008
    Messages:
    66
    J'aime reçus:
    0
    pas de .htaccess douteux dans tes répertoires ? c'est un cas classique de piratage.
     
  14. TopiCo
    TopiCo Nouveau WRInaute
    Inscrit:
    13 Mars 2011
    Messages:
    8
    J'aime reçus:
    0
    Bonjour,

    Pas de fichier htacess dans les répertoires :?
    Le problème ne peut donc pas venir de là je pense.
     
  15. TopiCo
    TopiCo Nouveau WRInaute
    Inscrit:
    13 Mars 2011
    Messages:
    8
    J'aime reçus:
    0
    J'ai donc eu accès au dossier me permettant de vérifier le permalien.
    C'est un permalien personnalisé avec cette valeur : /%category%/%postname%-%post_id%
    Je dois avouer que je ne vois pas où l'erreur 404 pourrait venir. Tout a l'air normal... 8O

    Un immense merci à celui qui débusque la couille dans le potage :mrgreen:
     
  16. Marie-Aude
    Marie-Aude WRInaute accro
    Inscrit:
    5 Juin 2006
    Messages:
    16 368
    J'aime reçus:
    2
    Re...
    la couille dans le potage n'est pas dans les documents que tu peux voir en dehors du fichier .htaccess qui doit obligatoirement se situer à la racine, sinon wordpress ne servirait pas les pages de ton blog (as tu vérifié le contenu de celui ci ?)

    Pour header.php ce n'est pas ce que tu as mis qui suffit, il faut le contenu jusqu'à </head>

    si ces deux fichiers ne donnent pas de solution, le reste est à voir au niveau du paramétrage de ton serveur -> avec ton webmaster impérativement
     
Chargement...
Similar Threads - Seules blog indexées Forum Date
Seules mes URL mobiles sont référencées Problèmes de référencement spécifiques à vos sites 6 Novembre 2018
Astuce Comment être bien référencé avec blog de Podcast et/ou vidéo ? Débuter en référencement 10 Juillet 2020
Monétisation d'un blog/annuaire professionnel Monétisation d'un site web 2 Juillet 2020
Blog avec lien en widget néfaste ? Netlinking, backlinks, liens et redirections 7 Juin 2020
WordPress monétiser un blog Monétisation d'un site web 1 Juin 2020
Avis sur mon blog voyage Demandes d'avis et de conseils sur vos sites 22 Mai 2020
Problème url blog Demandes d'avis et de conseils sur vos sites 29 Avril 2020
les blogs skyrock Débuter en référencement 28 Avril 2020
WordPress Url des articles de blog pas sous /blog... Demandes d'avis et de conseils sur vos sites 24 Avril 2020
Redirection www chez Blogger et nom de domaine OVH Netlinking, backlinks, liens et redirections 9 Avril 2020