Aide pour un problème http–https sur My Ranking Metrics

Discussion dans 'Problèmes de référencement spécifiques à vos sites' créé par Icipierrot, 19 Juin 2018.

  1. Icipierrot
    Icipierrot WRInaute occasionnel
    Inscrit:
    30 Octobre 2013
    Messages:
    339
    J'aime reçus:
    14
    Bonjour,

    Ce matin à 5h31, j'ai effectué un contrôle de mon site (mon www) avec My Ranking Metrics. Je me suis alors aperçu que l'outil a crawlé 2084 URL, alors que je n'en ai que 1256 sur mon GSA.

    Après un échange par e-mail, Olivier m'informe que j'ai un problème http–https. Et effectivement seul l'index en http pointait vers son équivalent en https, les réglages avaient sauté suite à une migration.

    Après en avoir avisé mon développeur, celui-ci a ajouté un code dans le htaccess.

    J'ai bien été vérifié sur redirect-checker.org, et effectivement toutes les URL en http sont désormais en 301, pointant vers leur équivalent https qui répond en 200.

    Une fois ce constat, j'ai effectué un 2e crawl à 9H50 avec My Ranking Metrics, soit 20 minutes après avoir réparé l'erreur http–https.

    Seulement voilà, le résultat me montre toujours 2084 URL, malgré le fait que je n'en ai que 1256 sur le domaine en https. Le résultat me montre que 33 % des pages crawlées sont en http, alors que pourtant d'après mes tests la redirection vers https est bien en place.

    Et de fait me revoici à la case départ. Quelqu'un pourrait-il me mettre le pied à l'étrier ? Ai-je vraiment un problème de redirection http–https, ou est-ce que j'ai tout simplement mal réglé le crawling de l'outil My Ranking Metrics ?

    Pour info et pour terminer cette lecture, voici les réglages que j'ai effectués :

    • Site analysé : emprunter-malin.com
    • URL de départ : https://www.emprunter-malin.com/
    • Protocoles : aucune restriction (HTTP et HTTPS)
    • Nombre maximal d'URL à explorer : 2 200
    • Motif d'inclusion : aucun
    • Motif d'exclusion : .jpg OR .jpeg OR .png OR .gif
    • User-Agent pour le site : Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
    • User-Agent pour le robots.txt : Googlebot
    • Vitesse de l'exploration : 1.0 requête par seconde
    • Ignorer le robots.txt : non
    • Prendre en compte les liens externes ayant un attribut rel="nofollow" : non
    • Limiter l'exploration au sous-domaine www.emprunter-malin.com : oui
    • CMS déclarés : aucun
    • Données Google Analytics : compte "Emprunter-malin", propriété "Emprunter-malin", vue "Toutes les données du site Web", trafic "organic" uniquement, sur les 90 derniers jours (du 21 mars 2018 inclus au 18 juin 2018 inclus)
    • Données Google Search Console : compte "****", propriété https://www.emprunter-malin.com/, sur tous types d'appareil, sur les 90 derniers jours (du 20 mars 2018 inclus au 17 juin 2018 inclus)

    Merci d'avance.
     
  2. WebRankInfo
    WebRankInfo Admin
    Membre du personnel
    Inscrit:
    19 Avril 2002
    Messages:
    19 137
    J'aime reçus:
    350
    Le rapport d'audit indique qu'il y a 690 URL en http qui reçoivent des liens internes follow. Même si elles se font rediriger vers leur équivalent https, il est clair qu'il ne devrait pas y avoir ces liens.
    Le rapport fournit la liste complète des cas concernés, avec à chaque fois l'URL source et l'URL cible.
    Ce qui permet de corriger tous ces problèmes.
    Une fois qu'ils auront tous été corrigés, un nouvel audit permettra de s'attaquer au reste de la masse noire (encore qu'il est possible de le faire avec le rapport actuel).
     
  3. Icipierrot
    Icipierrot WRInaute occasionnel
    Inscrit:
    30 Octobre 2013
    Messages:
    339
    J'aime reçus:
    14
    OK, vu, merci. À ma décharge, je n'aurais pas pu trouver tout seul.

    Avant lorsque que l'URL du site était en http, j'avais déjà composé pas mal d'articles. Ainsi tous les liens internes avant le passage en SSL pointent vers des URL http.

    C'était notamment le cas de mon plug-in «GDPR Cookie Consent», dont je n'avais pas pensé à mettre à jour l'URL de destination.

    En ce qui concerne tous les autres liens internes vers des URL en http, je vais les faire changer par mon développeur via une commande MySQL, ce qui m'évitera de me les taper tous un par un. Cela dit j'ai vu également qu'il existait des plug-ins WordPress pour changer du contenu.

    En attendant bravo pour la précision de My Ranking Metrics, j'ai déjà commencé à apporter pas mal de corrections sur des trucs que je n'avais pas vus.
     
    WebRankInfo apprécie ceci.
  4. Icipierrot
    Icipierrot WRInaute occasionnel
    Inscrit:
    30 Octobre 2013
    Messages:
    339
    J'aime reçus:
    14
    Je reviens sur cette discussion afin d'apporter mon expérience à ceux qui vive la même mésaventure.

    Après concertation avec mon développeur, il semble que la redirection des URL http vers https ait sauté, probablement suite à une mise à jour d'un plug-in. Nous pensons que le plug-in Yoast est en cause, car il inclut des réglages de redirection.

    Conclusion : toujours vérifier les redirections après la mise à jour ou l'ajout de plug-ins.

    Enfin, il restait plein de liens en http dans mon contenu. J'ai tout d'abord utilisé le plug-in "Better Search Replace", mais sans grand succès. Ensuite mon développeur a lui-même changé tous les liens en http pour du https, directement dans la base de données. Succès, ça marche.

    Conclusion : il ne suffit pas de passer un site de http vers https, il faut aussi changer tous les liens.

    Conclusion de la conclusion, quand vous perdez du trafic sans savoir d'où ça vient, vérifiez aussi vos redirections.
     
  5. WebRankInfo
    WebRankInfo Admin
    Membre du personnel
    Inscrit:
    19 Avril 2002
    Messages:
    19 137
    J'aime reçus:
    350
    ou alors lancez un audit gratuit RM Tech, vous verrez bien si les pastilles sont toutes au vert :)

    + sérieusement, tous ces fondamentaux doivent être en place avant de se demander pourquoi son référencement va mal.
     
    Icipierrot apprécie ceci.
Chargement...
Similar Threads - Aide problème http–https Forum Date
Aide réciproque appréciée, dubitatif sur certains problèmes SEO Problèmes de référencement spécifiques à vos sites 6 Juin 2018
Petit Problème GOOGLE un peu d'aide MERCI ! Débuter en référencement 16 Janvier 2015
Problème indexation avec snapshot html. Fonctionne à moitié. Besoin d'aide !! Problèmes de référencement spécifiques à vos sites 6 Janvier 2015
Problème référencement après 4 ans d'activité [Besoin d'aide] Problèmes de référencement spécifiques à vos sites 19 Mars 2014
Problème d'affichage : besoin de votre aide ! Développement d'un site Web ou d'une appli mobile 30 Mars 2013
Débutante demande aide pour problème avec slider Développement d'un site Web ou d'une appli mobile 27 Octobre 2012
besoin d'aide sur probleme de div déployables ... Développement d'un site Web ou d'une appli mobile 9 Septembre 2012
ENORME problème de code malveillant - Besoin d'aide SVP ! Référencement Google 8 Mai 2012
[Aide] Léger problème d'intégration... Développement d'un site Web ou d'une appli mobile 4 Mai 2012
Problème avec google et yahoo,pouvez-vous m'aider ? Débuter en référencement 20 Janvier 2011
  1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies.
    Rejeter la notice