Bascule en https : bascule ok mais le site http est toujours accessible

WRInaute discret
Bonjour,

J'ai effectué le changement en https et tout s'est passé correctement. Dans search console, je dispose donc des deux sites, celui en http et celui en https.

Toutes les redirections fonctionnent et le site est parfaitement indexé par Google après quelques semaines.

Ce que je ne comprends pas, c'est que le site http est encore accessible 8O 8O

Comment est-ce possible, quelle redirection ai-je zappée ?????
 
WRInaute discret
En fait la redirection du http fonctionnait bien initialement et je ne sais pas ce qui a pu évoluer depuis. 8O

Ce qui me sidère, c'est déjà le principe, comment un site, qui a priori n'existe plus et qui ne fonctionne qu'en https peut-il encore ressurgir ?

Est-ce que je dois faire une manip depuis search console ? Mais je ne vois rien qui permette de rediriger http vers https

Du coup, ça va être considéré en duplicate content, dur !!

Bref, je cale un peu. Et concernant un out de test, est-ce que tu as une idée stp ??? :?
 
WRInaute discret
Ok mais j'avais déjà sur ma page htaccess

Code:
RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://monsite.fr/$1 [R=301,L]

Quoique je note que sur OVH, ce serait

Code:
RewriteEngine on
RewriteCond %{SERVER_PORT} 80
RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

et le tout entre les balise WP :
Code:
# BEGIN WordPress
# END WordPress

Faut-il préférer le code OVH ? :?
 
WRInaute discret
Merci beaucoup pour le rappel des redirections htaccess, je n'avais pas testé la formule dédiée à OVH et elle fonctionne parfaitement :wink: :D
 
Discussions similaires
C
Réponses
4
Affichages
2K
christele2
C
Haut