Certificat SSL et GIT sur Debian

sigma2008

WRInaute impliqué
Bonjour,

Je veux suivre ce tutoriel, en appliquant apt-get update j'ai cette erreur :

Code:
Reading package lists... Done
W: There is no public key available for the following key IDs:
9D6D8F6BC857C906
W: There is no public key available for the following key IDs:
7638D0442B90D010
 NO_PUBKEY EF0F382A1A7B6500
W: There is no public key available for the following key IDs:
7638D0442B90D010
W: There is no public key available for the following key IDs:
7638D0442B90D010
 NO_PUBKEY CBF8D6FD518E17E1
W: Ignoring Provides line with DepCompareOp for package libapt-inst
W: Ignoring Provides line with DepCompareOp for package libapt-pkg
W: Ignoring Provides line with DepCompareOp for package libespeak-dev
W: Ignoring Provides line with DepCompareOp for package libespeak1
W: Ignoring Provides line with DepCompareOp for package libgpgme11-dev
W: Ignoring Provides line with DepCompareOp for package kodi-api-guilib
W: Ignoring Provides line with DepCompareOp for package kodi-api-pvr
W: Ignoring Provides line with DepCompareOp for package libparse-cpan-meta-perl
W: Ignoring Provides line with DepCompareOp for package libjpeg62
W: Ignoring Provides line with DepCompareOp for package lsb
W: Ignoring Provides line with DepCompareOp for package lsb-core
W: Ignoring Provides line with DepCompareOp for package php-psr-log-implementation
W: Ignoring Provides line with DepCompareOp for package php-seclib
W: Ignoring Provides line with DepCompareOp for package php-sabre-http
W: Ignoring Provides line with DepCompareOp for package php-math-biginteger
W: Ignoring Provides line with DepCompareOp for package pkg-config
W: Ignoring Provides line with DepCompareOp for package pypy-cffi
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package sagenb-export
W: Ignoring Provides line with DepCompareOp for package sagenb-export

En essayant comême malgré cette erreur d'installer git j'ai cette erreur :

Code:
The following packages have unmet dependencies:
 git : Depends: libc6 (>= 2.16) but 2.11.3-4+deb6u1 is to be installed
       Depends: libcurl3-gnutls (>= 7.16.2) but it is not going to be installed
       Depends: liberror-perl but it is not going to be installed
       Depends: git-man (> 1:2.11.0) but it is not going to be installed
       Depends: git-man (< 1:2.11.0-.) but it is not going to be installed
       PreDepends: dpkg (>= 1.17.13) but 1.15.11 is to be installed
       Breaks: bash-completion (< 1:1.90-1) but 1:1.2-3 is to be installed
 libc-dev-bin : Depends: libc6 (> 2.24) but 2.11.3-4+deb6u1 is to be installed
 libc6-dev : Depends: libc-dev-bin (= 2.11.3-4+deb6u1) but 2.24-11+deb9u1 is to be installed
 locales : Depends: libc-bin (> 2.24) but 2.11.3-4+deb6u1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Dans source list j'ai :

Code:
deb http://deb.debian.org/debian/ stretch main
deb http://security.debian.org/ stretch/updates main
deb http://deb.debian.org/debian/ stretch-updates main

deb http://ftp.fr.debian.org/debian jessie main

Pouvez vous m'aider SVP ?
Merci.
 

spout

WRInaute accro
Re: Sertificat SSL et GIT sur Debian

Vieux tuto, c'est plus comme ça que ça s'installe, c'est plus facile maintenant, cfr. doc officielle.
 

sigma2008

WRInaute impliqué
Re: Sertificat SSL et GIT sur Debian

Merci Spout pour ta réponse, t'as pas un tuto ? je veux utiliser le sertificat gratuit de letsencrypt.org
 

sigma2008

WRInaute impliqué
Re: Sertificat SSL et GIT sur Debian

Certbot ne s'installe pas il m'affiche la même erreur :

Code:
Hit http://ftp.fr.debian.org jessie Release.gpg
Hit http://security.debian.org stretch/updates Release.gpg                                                             
Hit http://security.debian.org/ stretch/updates/main Translation-en                                                    
Ign http://security.debian.org/ stretch/updates/main Translation-fr                                                    
Hit http://ftp.fr.debian.org/debian/ jessie/main Translation-en      
Hit http://ftp.fr.debian.org/debian/ jessie/main Translation-fr                                                        
Hit http://security.debian.org stretch/updates Release                                                                 
Hit http://ftp.fr.debian.org jessie Release                                                                            
Ign http://security.debian.org stretch/updates/main amd64 Packages                                                     
Hit http://security.debian.org stretch/updates/main amd64 Packages                                       
Ign http://ftp.fr.debian.org jessie/main amd64 Packages                                                  
Hit http://deb.debian.org stretch Release.gpg                           
Hit http://ftp.fr.debian.org jessie/main amd64 Packages
Hit http://deb.debian.org/debian/ stretch/main Translation-en
Hit http://deb.debian.org/debian/ stretch/main Translation-fr
Hit http://deb.debian.org stretch-updates Release.gpg
Hit http://deb.debian.org/debian/ stretch-updates/main Translation-en
Ign http://deb.debian.org/debian/ stretch-updates/main Translation-fr
Hit http://deb.debian.org stretch Release         
Hit http://deb.debian.org stretch-updates Release                       
Ign http://deb.debian.org stretch/main amd64 Packages                                
Hit http://deb.debian.org stretch-updates/main amd64 Packages/DiffIndex              
Hit http://deb.debian.org stretch/main amd64 Packages

Reading package lists... Done
W: There is no public key available for the following key IDs:
9D6D8F6BC857C906
W: There is no public key available for the following key IDs:
7638D0442B90D010
 NO_PUBKEY CBF8D6FD518E17E1
W: There is no public key available for the following key IDs:
7638D0442B90D010
 NO_PUBKEY EF0F382A1A7B6500
W: There is no public key available for the following key IDs:
7638D0442B90D010
Reading package lists... Done

Reading package lists... Done
W: There is no public key available for the following key IDs:
9D6D8F6BC857C906
W: There is no public key available for the following key IDs:
7638D0442B90D010
 NO_PUBKEY CBF8D6FD518E17E1
W: There is no public key available for the following key IDs:
7638D0442B90D010
 NO_PUBKEY EF0F382A1A7B6500
W: There is no public key available for the following key IDs:
7638D0442B90D010
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 gcc : Depends: cpp (>= 4:6.3.0-4) but 4:4.4.5-1 is to be installed
       Depends: gcc-6 (>= 6.3.0-9~) but it is not going to be installed
 libaugeas0 : Depends: libc6 (>= 2.14) but 2.11.3-4+deb6u1 is to be installed
 libc-dev-bin : Depends: libc6 (> 2.24) but 2.11.3-4+deb6u1 is to be installed
 libc6-dev : Depends: libc-dev-bin (= 2.11.3-4+deb6u1) but 2.24-11+deb9u1 is to be installed
 libffi-dev : Depends: libffi6 (= 3.2.1-6) but it is not going to be installed
 libssl-dev : Depends: libssl1.1 (= 1.1.0f-3+deb9u1) but it is not going to be installed
 locales : Depends: libc-bin (> 2.24) but 2.11.3-4+deb6u1 is to be installed
 openssl : Depends: libc6 (>= 2.15) but 2.11.3-4+deb6u1 is to be installed
           Depends: libssl1.1 (>= 1.1.0) but it is not going to be installed
 python : Depends: python2.7 (>= 2.7.13-1~) but it is not going to be installed
          Depends: libpython-stdlib (= 2.7.13-2) but it is not going to be installed
          PreDepends: python-minimal (= 2.7.13-2) but 2.6.6-3+squeeze7 is to be installed
 python-apt : Breaks: python (>= 2.7) but 2.7.13-2 is to be installed
 python-dev : Depends: libpython-dev (= 2.7.13-2) but it is not going to be installed
              Depends: python2.7-dev (>= 2.7.13-1~) but it is not going to be installed
 python-virtualenv : Depends: python-pip-whl (>= 8.1.1-2) but it is not going to be installed
                     Depends: python-pkg-resources but it is not going to be installed
 virtualenv : Depends: python3 but it is not going to be installed
              Depends: python3-virtualenv but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
 

sigma2008

WRInaute impliqué
Toujours le même problème :

Code:
root@nsxxxxxx:/etc/apt# apt-get install python-certbot-apache -t jessie-backports
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libc-dev-bin : Depends: libc6 (> 2.24) but 2.11.3-4+deb6u1 is to be installed
 libc6-dev : Depends: libc-dev-bin (= 2.11.3-4+deb6u1) but 2.24-11+deb9u1 is to be installed
 locales : Depends: libc-bin (> 2.24) but 2.11.3-4+deb6u1 is to be installed
 python-certbot-apache : Depends: certbot (>= 0.10.2~) but it is not going to be installed
                         Depends: python-acme but it is not going to be installed
                         Depends: python-augeas but it is not going to be installed
                         Depends: python-certbot but it is not going to be installed
                         Depends: python-mock but it is not going to be installed
                         Depends: python-pkg-resources but it is not going to be installed
                         Depends: python-zope.component but it is not going to be installed
                         Depends: python-zope.interface but it is not going to be installed
                         Depends: python:any (< 2.8)
                         Depends: python:any (>= 2.7.5-5~)
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
root@nsxxxxxx:/etc/apt#
 

sigma2008

WRInaute impliqué
Oui voila ce que donne apt-get update :

Code:
Get:1 http://security.debian.org stretch/updates Release.gpg [1601 B]
Get:2 http://security.debian.org/ stretch/updates/main Translation-en [96.6 kB]
Ign http://security.debian.org/ stretch/updates/main Translation-fr   
Get:3 http://security.debian.org stretch/updates Release [61.3 kB]                              
Ign http://security.debian.org stretch/updates/main amd64 Packages                                      
Get:4 http://security.debian.org stretch/updates/main amd64 Packages [292 kB]
Get:5 http://deb.debian.org stretch Release.gpg [2479 B]                  
Get:6 http://deb.debian.org/debian/ stretch/main Translation-en [5395 kB]
Get:7 http://deb.debian.org/debian/ stretch/main Translation-fr [1894 kB]
Get:8 http://deb.debian.org stretch-updates Release.gpg [1601 B]      
Get:9 http://deb.debian.org/debian/ stretch-updates/main Translation-en [3583 B]
Ign http://deb.debian.org/debian/ stretch-updates/main Translation-fr
Get:10 http://deb.debian.org stretch Release [118 kB]          
Get:11 http://deb.debian.org stretch-updates Release [89.4 kB]                 
Ign http://deb.debian.org stretch/main amd64 Packages                                    
Ign http://deb.debian.org stretch-updates/main amd64 Packages                            
Get:12 http://deb.debian.org stretch/main amd64 Packages [9500 kB]
Get:13 http://deb.debian.org stretch-updates/main amd64 Packages [6499 B]                                       
Fetched 17.5 MB in 2s (6634 kB/s)                                                                               
Reading package lists... Done
W: Ignoring Provides line with DepCompareOp for package libapt-inst
W: Ignoring Provides line with DepCompareOp for package libapt-pkg
W: Ignoring Provides line with DepCompareOp for package libespeak-dev
W: Ignoring Provides line with DepCompareOp for package libespeak1
W: Ignoring Provides line with DepCompareOp for package libgpgme11-dev
W: Ignoring Provides line with DepCompareOp for package kodi-api-guilib
W: Ignoring Provides line with DepCompareOp for package kodi-api-pvr
W: Ignoring Provides line with DepCompareOp for package libparse-cpan-meta-perl
W: Ignoring Provides line with DepCompareOp for package libjpeg62
W: Ignoring Provides line with DepCompareOp for package lsb
W: Ignoring Provides line with DepCompareOp for package lsb-core
W: Ignoring Provides line with DepCompareOp for package php-psr-log-implementation
W: Ignoring Provides line with DepCompareOp for package php-seclib
W: Ignoring Provides line with DepCompareOp for package php-sabre-http
W: Ignoring Provides line with DepCompareOp for package php-math-biginteger
W: Ignoring Provides line with DepCompareOp for package pkg-config
W: Ignoring Provides line with DepCompareOp for package pypy-cffi
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package sagenb-export
W: Ignoring Provides line with DepCompareOp for package sagenb-export
W: You may want to run apt-get update to correct these problems
 

sigma2008

WRInaute impliqué
En appliquant ce code "apt-get dist-upgrade" j'ai cette erreur :

Code:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libc-dev-bin : Depends: libc6 (> 2.24) but 2.11.3-4+deb6u1 is installed
 libc6-dev : Depends: libc-dev-bin (= 2.11.3-4+deb6u1) but 2.24-11+deb9u1 is installed
 locales : Depends: libc-bin (> 2.24) but 2.11.3-4+deb6u1 is installed
E: Unmet dependencies. Try using -f.
 

Discussions similaires

Haut