Fichier Robots.txt et variable en fin de .php

econologie

WRInaute discret
J'aimerais interdire aux bot de reférencer mes pages qui finissent par la variable : "&prt=1" ( print )

Est ce possible et si oui comment ?
Comme il y a des variables avant puis je mettre une ligne du type :

Disallow: -www.mondomaine.com/articles.php?lng=fr&pg=XX&prt=1

avec XX= tout ce qu'on veut ? ( je connais pas la syntaxe )

Merci
 

jeanluc

WRInaute accro
Bonjour,

Pour ton problème, il n'y a pas de solution valable pour tous les robots avec le robots.txt.

Je mettrais un attribut rel="nofollow" dans tous les liens qui pointent vers les pages qui finissent pas &prt=1 et j'ajouterais un
Code:
<meta name="robots" content="noindex,nofollow">
dans ces pages pour le cas où un zozo (externe à ton site) aurait fait un lien direct vers une de ces pages.

Jean-Luc
 

pippo

Nouveau WRInaute
Salut,

Google a introduit il y a quelque temps la fonction jocker: *
cf ICI

Il te suffit dès lors de mettre:

Code:
User-agent: Googlebot
Disallow: /*&prt=1

Cette fonction n'est pas prise en compte par les autres moteurs de recherche.
 

econologie

WRInaute discret
jeanluc a dit:
Je mettrais un attribut rel="nofollow" dans tous les liens qui pointent vers les pages qui finissent pas &prt=1

Merci mais cela me semble impossible comme solution puisque le &prt=1 est sur 90% des pages de mon site ( option d'impression des articles cf mon WWW )

Je vais plutot tenter la fonction "jocker" merci :)
 

econologie

WRInaute discret
pippo a dit:
Il te suffit dès lors de mettre:

Code:
User-agent: Googlebot
Disallow: /*&prt=1

Cette fonction n'est pas prise en compte par les autres moteurs de recherche.

Cela fait maintenant 5 jours que j'ai mis cette commande dans le robots.txt mais les page &prt=1 apparaissent encore dans google ( du moins certaines...) il y aurait une manip pour "purger" google de page indésirables ?

Merci
 

pippo

Nouveau WRInaute
yvan02 a dit:
j'ai aussi une question, comment supprimer toutes les pages qui commencent par /index.php?id_lang=1 ?

Il faut mettre

Code:
Disallow: /index.php?id_lang=1
sans astérisque.

Les moteurs ignorent toutes les pages commençant par les arguments interdits.
 

Discussions similaires

Haut