Modifier la version de PHP

Crash84

WRInaute discret
Bonjour,

Pour les besoins de mon site je dois passer à PHP 5, or la mise à jour de mon fichier htaccess ne semble pas fonctionner. Je mets bien "SetEnv PHP_VER 5_4" mais après quand je mets mon nouveau fichier plus rien ne fonctionne. Du coup je suppose que je fais une mauvaise manipulation. Dois-je laisser le "SetEnv PHP_VER 5_4" tout le temps et je le mets, j'enregistre, puis je mets mon nouveau fichier ?
 

zeb

WRInaute accro
les fichiers htaccess c'est fait pour rester (ta question est pas claire)

Quoi qu'il en soit, si tu était sous php 4 il y a fort a parier que le code ne soit pas forcement compatible php 5 (il me semble de mémoire que la gestion objet a beaucoup évoluée entre ces deux versions)
 

_Soul

WRInaute impliqué
Prend php 5.3, ta pas mal de scripts acheté qui ne marche plus avec la 5.4, en particulier ioncube loader.

Après sa dépend de ton hébergeur.
 

fooki

Nouveau WRInaute
Comme le dit zeb, ton fichier htaccess doit être tout le temps présent pour indiquer à apache d'utiliser la version 5.4 de php pour les fichiers contenus dans ce dossier.

Le plus simple pour vérifier si ton fichier htaccess fonctionne est d'utiliser un fichier :

phpversion.php avec comme contenu :
Code:
<?php
echo phpversion();
?>

Si tu vois bien la version 5.4 ton fichier htaccess fonctionne et tu ne dois plus le modifier.
 

Discussions similaires

Haut