Postfix bouncing emails

WhiteSpi

WRInaute occasionnel
Salut,

Je galere depuis 2 jours sur mon serveur postfix...
On est 5 a avoir acces au serveur.

J'arrive desormais a recevoir et envoyer des email depuis mon compte.
Mes collegues par contre ne peuvent rien recevoir, le serveur ne les considere pas comme faisant partie du systeme.

On dirait que postfix n'arrive pas a lire mon /etc/passwd ...

mon main.cfg ressemble a ceci:

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific: Specifying a file name will cause the first
# line of that file to be used as the name. The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
#smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
#smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
#smtpd_use_tls=yes
#smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
#smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

#myhostname = ks300575.kimsufi.com
myhostname = whizlogic.co.uk
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
local_recipient_maps = unix:passwd.byname $alias_maps
myorigin = /etc/mailname
mydestination = whizlogic.co.uk, ks300575.kimsufi.com, localhost.kimsufi.com, localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command =

mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all

smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain =
smtpd_sasl_application_name = smtpd
broken_sasl_auth_clients = yes

smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination

smtpd_tls_security_level = may


home_mailbox = Maildir/
smtp_tls_key_file = /etc/postfix/tls/smtpd.key
smtp_tls_cert_file = /etc/postfix/tls/smtpd.crt
smtp_tls_CAfile = /etc/postfix/tls/cacert.pem
smtp_tls_session_cache_database = btree:$data_directory/smtp_tls_session_cache
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes

smtpd_tls_key_file = /etc/postfix/tls/smtpd.key
smtpd_tls_cert_file = /etc/postfix/tls/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/tls/cacert.pem
smtpd_tls_session_cache_database = btree:$data_directory/smtpd_tls_session_cache
smtpd_use_tls = yes

smtpd_tls_received_header = yes
smtpd_tls_ask_ccert = yes
smtpd_tls_loglevel = 3

tls_random_source = dev:/dev/urandom

# TLS PART END
(Logs enlevés)

Quelqu'un a t'il une idée??


Merci bien,

Seb
 

Bool

WRInaute passionné
Hello,

je ne connais pas vraiment postfix, mais quand je vois les termes sur lesquels il bloque je pense à du Exim Filter : $h_X-Spam-Flag / finish / if / then / endif / save

T'aurais pas laissé trainer des fichiers .forward utilisant des règles Exim par hasard ?
 

WhiteSpi

WRInaute occasionnel
Bien vu !

Effectivement, certains profiles avaient un ancien exim .forward qui trainait.
Les messages ne "bounce" plus.

Mais ils n'arrivent toujours pas dans les Maildir des utilisateurs...

Merci de ton aide,

Seb
 

Bool

WRInaute passionné
Bon c'est déjà ça ;)

Mais ils n'arrivent toujours pas dans les Maildir des utilisateurs...
Là par contre c'est curieux : les utilisateurs sont bien reconnus et cela pointe bien sur le bon dossier, sinon les fichiers .forward n'auraient pas été traités, non ?
Ce ne sera pas simplement un soucis de droits d'accès ? Y a rien à ce sujet dans les logs ?
 

WhiteSpi

WRInaute occasionnel
Bool a dit:
Bon c'est déjà ça ;)

Mais ils n'arrivent toujours pas dans les Maildir des utilisateurs...
Là par contre c'est curieux : les utilisateurs sont bien reconnus et cela pointe bien sur le bon dossier, sinon les fichiers .forward n'auraient pas été traités, non ?
Ce ne sera pas simplement un soucis de droits d'accès ? Y a rien à ce sujet dans les logs ?

Malheureusement les logs sont propre.
Les .forward je les ai enlevés, donc ils ne peuvent plus poser probleme.
Point de vue droit d'acces, j'ai tout vérifié 10 fois... je ne crois vraiment pas que ce soit le probleme.

:roll:
 

WhiteSpi

WRInaute occasionnel
Bon c'est bon c'est moi qui suis fatigué....
Je regardais dans Maildir/cur au lieu de Maildir/new ...

Merci pour ton aide :)
 

Discussions similaires

Haut