Prb: apache-ssl ne gere pas le php

Mitirapa

WRInaute passionné
Bonjour,
j'ai fais un apt-get install apache-ssl

j'ai fait un virtual host dans le /etc/apache-ssl/httpd.conf comme ceci:
<VirtualHost *:443>
ServerName -www.domain.tld
SSLEnable
DocumentRoot /var/www/domain/
</VirtualHost>

cela fonctionne bien pour des pages html
mais pas pour mes pages php

dans le modules.conf je n'ai pas de
LoadModule php4_module /usr/lib/apache/1.3/libphp4.so

mais si je le rajoute et redemarre apache-ssl il me dit qu'il etait deja chargé
et il n'y est pas dans /etc/apache-ssl/httpd.conf non plus (donc je sais pas d'où il se charge)

bref si je vais sur -https://www.domain.com/test.html c'est OK
si -https://www.domain.com/test.php il me demande de telecharger le fichier et au final je telecharge mon code php brut

Savez vous vers où je dois chercher pour regler ce petit (gros) probleme ?
note: mon apache "normal" (http) par contre pas de problemes

(posté aussi sur sivit, donc je mettrais aussi la solution ici si elle est la bas)
 

nikoshr

WRInaute occasionnel
Le module php ne serait pas compilé en statique, par hasard?
Code:
apachectl -l
pour vérifier.

Essaie
Code:
<VirtualHost *:443>
ServerName -www.domain.tld
SSLEnable
DocumentRoot /var/www/domain/
AddType application/x-httpd-php .php
</VirtualHost>
Avec un peu de chance, ca suffira.
 

Mitirapa

WRInaute passionné
j'avais testé
AddType application/x-httpd-php .php
et cela n'avait rien changé, mais surement que j'avais fait une erreur , car maintenant ca a l'air ok
 

Discussions similaires

Haut