Problème avec easyphp

Meeuuuhhh

WRInaute passionné
Bonjour,

Voilà, j'essaie de faire fonctionner easyphp pour travailler en local (sous vista) et ça ne fonctionne pas.

J'ai ces erreurs là :

Code:
Warning: mysql_query() [function.mysql-query]: Accès refusé pour l'utilisateur: 'ODBC'@'@localhost' (mot de passe: NON) in C:\Program Files\EasyPHP 3.0\www\site\index.php on line 44

Warning: mysql_query() [function.mysql-query]: A link to the server could not be established in C:\Program Files\EasyPHP 3.0\www\site\index.php on line 44
Accès refusé pour l'utilisateur: 'ODBC'@'@localhost' (mot de passe: NON)

Je viens de voir aussi cette erreur : Quand je clique sur l'icone Easyphp, une boite de dialogue s'affiche et m'indique "le serveur n'a pu être installé : Le service spécifié n'existe pas en tant que service installé. (1060)"

Ca, ça ne le faisait pas au début.

J'ai cherché sur google, apparemment, je suis loin d'être le seul. Il n'empêche que leurs solutions ne fonctionnent pas chez moi.

J'ai essayé, en vrac :
- Remplacer ' ' par 'mysql' dans la variable password du fichier connex.php.
- Arrêter la vérification d'utilisation des autres ports dans configuration.
- Discuter avec le PC pour lui expliquer qu'il me fatigue.
- Réactualiser 200 fois la page index.php dans l'espoir d'un miracle.

Aucune de ces solutions ne fonctionne, donc je m'en remets à vous, ô géniaux wrinautes : Auriez-vous une idée SVP ?

Merci d'avance.
 

Altenide

WRInaute impliqué
réinstalles easy-php dans un autre répertoire que le répertoire 'programme' de vista. Dans l'administration tu recréés un nouvel utilisateur, auquel tu donnes des droits, un mot de passe et tu te connectes avec lui.
 

e-kiwi

WRInaute accro
le mieux, désinstalle easyphp et installe wamp, bien plus à jour, complet, plus de lib, etc ...
 

dmathieu

WRInaute accro
- La dernière version date peut-être de Janvier. Mais cette dernière version est la première qui propose PHP 5.
En sachant que PHP4 n'est plus maintenu depuis aout dernier, c'est ce que j'appelle être à la ramasse.

- J'ai beau chercher sur le site, il est impossible de trouver une quelconque information concernant les versions de Apache, PHP et MySQL utilisées par l'application.
C'est pas ce que j'appelle du sérieux.

Personnelement, ça me suffit pour dire que le logiciel n'est pas utilisable. Mais si tu veut que je continue, je peux.
 

UsagiYojimbo

WRInaute accro
+1 Pour wamp, qui permet de choisir les versions d'apache, mysql, php sans se prendre la tête (gestion sous forme de plugins).
 

dmathieu

WRInaute accro
J'ai rarement vu un logiciel indiquer sur son propre site "on est plus maintenu. Allez vous faire voir".
C'est justement une impression que de dire que le logiciel n'est plus maintenu : Ils ne tiennent pas l'application à jour des nouveautés du langage.
 

Discussions similaires

Haut