Probleme de redirection + SSL personne n'a la reponse ?

fredisap

Nouveau WRInaute
Bonjour,
je suis vraiment débutant aussi bien dans le domaine de la création de site internet que celui du referencement ( normal les deux ne vont pas sans l'autre :lol: ).

suite à ce que j'ai pu lire , j'ai modifié mon fichier .htaccess en rajoutant :

RewriteEngine On
RewriteCond %{HTTP_HOST} !^www\.exemple\.com [NC]
RewriteRule (.*) http://www.exemple.com/$1 [QSA,R=301,L]

or je suis sur OVH, et il s'agit d'une boutique oscommerce.
Les pages SSL qui correspondent à l'ouverture du compte, de la session...
s'ecrivent sur OVH de cette forme https://ssl2.ovh.net/~login/

donc mon problème est que vu que j'ai fait une redirection selon le code cité plus haut,
mes pages sécurisées ne fonctionnent plus

Comment faire donc pour qu'elles ne soient pas redirigées ?
merci de votre aide .
 

bruno212

WRInaute occasionnel
Il faut que tu écrives des règles différentes pour les connexions sécurisées.

Comme l'url n'est pas le même lorsque tu utilises ssl, c'est logique que ça ne marche plus.
 

fredisap

Nouveau WRInaute
désolé, mais je ne m'y connais pas suffisament :oops: , tu peux m'aiguiller ? que dois je mettre comme règle ?
merci
 

bruno212

WRInaute occasionnel
fredisap a dit:
désolé, mais je ne m'y connais pas suffisament :oops: , tu peux m'aiguiller ? que dois je mettre comme règle ?
merci

Hello,

Je ne suis pas assez bon pour te proposer une réponse à la volée...

Mais regarde le tutoriel suivant:
https://www.webrankinfo.com/analyses/aut ... riting.php

Ensuite, essaie de le mettre en pratique, et si tu as un problème, reviens sur le forum avec une question précise.

bonne chance
 

fredisap

Nouveau WRInaute
Voici l'adresse du site en construction :http://www.e-kidshoes.com/index.php
si tu te positionne sur le lien" ouvrir une session "ou sur "creer un compte", tu peux voir dans la barre des taches que le lien est bien de la forme :https://ssl2.ovh.net/~login/page.php mais lorsque tu clique dessus, l'adresse est redirigée donc le SSL n'est pas pris en compte.
d'ou le besoin d'eviter la redirection pour ces pages là ainsi que celles qui en découlent
 

fredisap

Nouveau WRInaute
Malgre toutes mes recherches, j'ai même demandé à OVH ils m'ont dit que c'etait de la pure programation donc pas de leur ressort.
je ne trouve pas la réponse à mon problème. :cry:
Il doit etre quand même possible de pouvoir forcer une URL avec les WWW et empecher la redirection pour les pages sécurisées .

En tant que débutant, je lance un grand S.O.S
 

fredisap

Nouveau WRInaute
voila désolé je débute il y a peut etre des cos qui n'ont pas lieu d'etre

$Id: $
#
# This is used with Apache WebServers
#
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
#
# Example:
#
# <Directory "/usr/local/apache/htdocs">
# AllowOverride Options
# </Directory>
#
# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers

#<IfModule mod_setenvif.c>
# <IfDefine SSL>
# SetEnvIf User-Agent ".*MSIE.*" \
# nokeepalive ssl-unclean-shutdown \
# downgrade-1.0 force-response-1.0
# </IfDefine>
#</IfModule>

# If Search Engine Friendly URLs do not work, try enabling the
# following Apache configuration parameter

# AcceptPathInfo On

# Fix certain PHP values
# (commented out by default to prevent errors occuring on certain
# servers)

# php_value session.use_trans_sid 0
# php_value register_globals 1

RewriteEngine On
RewriteCond %{HTTP_HOST} !^www\.e-kidshoes\.com [NC]
RewriteRule (.*) http://www.e-kidshoes.com/$1 [QSA,R=301,L]
 

bruno212

WRInaute occasionnel
Bonjour,

essaie de commenter les lignes de réécriture en bas du .htaccess
en ajoutant un # devant les 3 dernières lignes

Ensuite va sur : https://ssl2.ovh.net/~login/page.php et regarde s'il est toujours redirigé sur ton domaine, si c'est le cas, c'est que ce n'est pas le .htaccess qui pose problème.

Cordialement
 

fredisap

Nouveau WRInaute
Bonjour Bruno212, merci de t'interresser à mon cas,

pour les 3 dernières lignes c'est moi qui les ai rajouté, si je les enlève cela fonctionne nickel les pages ne sont pas redirigées vers www.mo_domaine et j'ai donc bien la page https://ssl2.ovh.net/~login/page.php qui s'affiche Nickel, session nickel, securisation nickel.

Par contre si je laisse les 3 derniere ligne toujours redirection vers http://www.mon_domaine.com/page.php. Donc pas de session, pas de sécurisation...
 

bruno212

WRInaute occasionnel
Je sais pas pourquoi la condition est validée avec ces trois lignes, c'est peut-être la configuration d'OVH.

Je n'ai pas d'hébergement chez eux, donc je n'en sais rien et je peux pas tester.

Mais bon, tu peux te passer de cette redirection. Configure dans Google Webmaster Tool https://www.google.ch/webmasters/tour/tour1.html ton domaine préféré (c'est-à-dire avec www) et construit tes urls internes avec le www, pratiquement personne n'atterira sur le http://exemple.com , et si c'est le cas, il sera redirigé au premier vers http://www.exemple.com .

à plus

Bruno
 

Discussions similaires

Haut