Problème URL Rewriting en local avec Wamp

Ashaan

Nouveau WRInaute
Bonjour à tous ! =)

Alors voilà, je vous expose mon problème, assez récurrent d'après ce que j'ai pu voir. Donc, je suis en train de mettre mon site en local, afin de pouvoir bosser tranquillement sur sa nouvelle version. Et au moment de mettre en place l'url rewriting, un problème. Quand je clique sur un lien (quel qu'il soit), à partir de l'index, ça m'envoie la bonne url, mais pas le bon affichage :

piou.jpg


L'index de wampserver, mais sans images !
Alors j'ai déjà pas mal cherché sur le net :
- rewrite_module activé pour apache
- des allowoverride none tous remplacés par des allowoverride none dans httpd.conf
- la ligne qu'il faut est décommenté dans httpd.conf
- J'ai essayé l'astuce donnée ici : https://www.webrankinfo.com/forum/t/url-rewriting-en-local-avec-wamp.99390/
Mais sans succès, Internal server Error :/

Ensuite, je vous donne l'arborescence des fichiers, si ça peut venir de là.. C:\wamp\www\KHDestiny ; et mon htaccess se trouve dans ce même dossier, KHDestiny.

Voilà tout ce que j'ai fait.. est-ce que j'ai oublié quelque chose ?

Hum, petit extrait de mon htaccess tant qu'à faire :
Code:
Options +FollowSymlinks

RewriteEngine on

RewriteRule ^news-(.+)-(.+)\.html$  									/index.php?rub=news&id=$1&page=$2 [L]
RewriteRule ^news-(.+)\.html$ 											/index.php?rub=news&id=$1 [L]

RewriteRule ^contact-(.+)\.html$  										/index.php?rub=contact&page=$1 [L]
RewriteRule ^contact\.html$  											/index.php?rub=contact [L]

On m'a dit qu'il n'était pas très propre, mais apparemment, mon site est codé de tel manière qu'il n'y a que cet url rewriting de possible. Et aussi, dernière chose à savoir, je suis un gros novice.. je n'y connais rien en php, url rewriting, etc, même si je comprends le principe. Notre programmeur nous ayant quitté, je suis obligé de m'atteler à des tâches pour lesquelles je ne suis pas à la base défini, donc soyez indulgents, s'il vous plaît. :$

Merci d'avance ! =)
 

dmathieu

WRInaute accro
Le / dans /index.php fait qu'il appelle index.php à la racine de l'url.
Mets /KHDestiny/index.php et tu aura correctement le index.php de ton site.
 

Ashaan

Nouveau WRInaute
@ Kazhar : c'est l'astuce donnée dans le lien que j'ai mis dans mon premier post.. et ça me donne internal server error. Mais instinctivement, vu que le htacess est déjà placé dans le dossier contenant mon site (KHDestiny pour ma part), il n'y a pas besoin de rajouter /KHDestiny dans le fichier.. non ?

@ Forty(che) : Merci. :D Ca marche impeccable, y reste quelques bugs encore, mais ça ne vient pas de l'url rewriting.. et c'est pas vraiment dérangeant.
En tout cas, je peux bosser sur cette nouvelle version sans peine ! Encore une fois, je n'suis pas déçu de la rapidité et des compétences des personnes de ce forum. =]

Encore merci ! ;)
 

Discussions similaires

Haut