1. ✅ Apprenez une METHODE qui marche pour votre SEO ! Formation à distance avec Olivier Duffez et Fabien Facériès + aide pour prise en charge du financement
    Rejeter la notice

[Wordpress]Problème affichage article dans sous-catégorie

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par jinkee, 11 Juin 2017.

  1. jinkee
    jinkee Nouveau WRInaute
    Inscrit:
    12 Avril 2007
    Messages:
    30
    J'aime reçus:
    0
    Bonjour à toutes et à tous,

    Voilà, j'ai un soucis qui me dépasse depuis 3 jours maintenant...J'entame un nouveau site Web sur Wordpress (en phase de construction en ligne actuellement https://goo.gl/b5RLQQ) ou j'ai effectué mon menu ainsi qu'une catégorie possédant des sous catégorie (jusque là tout va bien) :D

    j'ai indiqué pour chaque sous catégorie, la catégorie parent. Cependant lorsque j'écris mon tout 1er article, je spécifie comme d'habitude la sous catégorie auquel l'article doit correspondre. Et là c'est le drame...

    L'article se met bien à jour sur la page d'accueil comme je le souhaite, mais lorsque je vais sur la sous catégorie adéquate, l'article ne s'affiche pas, introuvable....Ce n'est pas une erreur 404 mais bien l'URL de la sous catégorie comme si cette dernière n'avait aucun article lui correspondant...

    J'ai surement zappé quelque chose que je ne vois pas ou un problème qui me dépasse...C'est pour ça que je fais appel aux expert Wordpress :D

    Héberger chez OVH
    Pas de plug-in installé
    Permalien activé sur nom de l'article

    Merci pour vos éclaircissements par avance :)
     
  2. jinkee
    jinkee Nouveau WRInaute
    Inscrit:
    12 Avril 2007
    Messages:
    30
    J'aime reçus:
    0
    Bonjour,

    Je reviens vers vous suite à de multiples tests:

    le rewrite_mod est bien activé et le htaccess se met bien à jour lorsque je change le réglage des permaliens (plutôt une bonne nouvelle)

    La structure des catégories et l'affichage des articles se font très bien lorsque le réglage des permaliens est en mode simple mais pas idéal pour le référencement (du type ?p=123)...

    Par contre je me suis aperçu que j'avais mis un "." pour enlever le préfixe category mais en le supprimant tout fonctionne nickel mais maintenant je me retrouve avec une URL du type nomsite.extension/category/categorie_parent/sous-categorie/nom_article

    Ma question (surement très bête de ma part):
    Comment supprimer ce préfixe "category" sans que cela puisse impacter sur les URL et l'affichage de mes articles dans les sous-categories ? :D

    Merci
     
Chargement...
Similar Threads - [Wordpress]Problème affichage article Forum Date
Référencement url sur Google - Affichage positions sur mobile différents d'un OS à un autre ? Référencement Google 7 Août 2020
En test : affichage des informations de licence dans Google Images YouTube, Google Images et Google Maps 28 Février 2020
Affichage chiffre d'affaires et taux de conversion zéro Google Analytics 26 Février 2020
WordPress Problème affichage accent sur Wordpress Développement d'un site Web ou d'une appli mobile 17 Février 2020
Position zéro et Featured Snippet : modification affichage Référencement Google 23 Janvier 2020
Astuce pour continuer l'affichage des étoiles dans les SERP de GOOGLE: balises de données structurée Référencement Google 6 Janvier 2020
Nouvel affichage Google : Sujets abordés par l'éditeur Référencement Google 4 Janvier 2020
Problème affichage des derniers articles wordpress page accueil Administration d'un site Web 20 Novembre 2019
Affichage Google : Principales activités à découvrir Référencement Google 16 Octobre 2019
Affichage des urls dans google : url de la home et urls des autres pages d'un site Problèmes de référencement spécifiques à vos sites 1 Octobre 2019