comment différer une video youtube a l'affichage

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par j-mi, 26 Décembre 2008.

  1. j-mi
    j-mi WRInaute accro
    Inscrit:
    17 Mai 2005
    Messages:
    3 358
    J'aime reçus:
    0
    bonjour

    j'ai mis une video youtube sur l'index de mon site (voir WWW)

    C'est bien et cool, mais ça me plais pas de la façon que la video youtube fait pour se charger dans ma page .
    1 mon site va trop vite pour s'afficher, et la video youtube de ce fait tarde un peu a apparaire ...
    Le resulta bin c'est hypper moche quand ma page se contruit ...

    Que puis-je faire pour palier le phenoméne et soit avoir la video qui se charge en meme temp que ma page

    ou simplement quel serait l'astuce pour faire un différé de chargement (style chargement ajax)

    Hier j'ai tenté plein de choses, mais j'avoue que charger un <object>
    en ajax il faut etre fortiche pour que ça marche...

    Et charger dans un <body on load ()> itou
     
  2. LiFi
    LiFi WRInaute impliqué
    Inscrit:
    14 Juillet 2008
    Messages:
    609
    J'aime reçus:
    0
    peut etre remplacer ta video par une image comme ca elle s'affiche en meme temps que le reste de la page. Un script onClick sur l'image pour faire apparaitre un div avec la vidéo mise en lecture automatique qui alors semblera répondre au clic, donc normal qu'il y ait un petit délai avant qu'elle démarre.

    Je ne suis pas sur, mais je pense que si tu charges la vidéo en mode lecture automatique dans un div qui serait caché, la vidéo ne démarrerait pas avant d'être affichée.
    avec un div style=display:none.

    Pas sur du tout, il faut essayer si vraiment cela te derange, personnellement tel qu'il est maintenant ton site (on voit bien le delai pour l'affichage de l'apercu de la vidéo) cela ne me derangerait pas du tout, c'est un détail.
     
  3. j-mi
    j-mi WRInaute accro
    Inscrit:
    17 Mai 2005
    Messages:
    3 358
    J'aime reçus:
    0
    C'est pas gagné ...
    j'ai meme tenté une php avec un delay dedans pour apres tirer le truc en ajax ...
    ajax css et js
    et meme iframe .
    Rien n'y fait cette video se charge apres le chargement de mon site .
    Et c'est la construction du lecteur dans ma page qui fait cet effet d'image non presente 1 sec mon desagrément

    Non hein LiFi, moi je vois une page comme ça qui dit portail Web 2.0 avec une pareille construction de la page je fuis et je reviens plus jamais sur le site .J'ai essayé a la maison ... mais a chaque fois que je reviens vers le pc la page est tj la ....
    donc il faut bien que je corrige ...

    j'avais pensé mon propre lecteur et la video sur mon ftp , mais ça craint
    1/ j'ai trop de visites ...
    2/ c pas ma video

    je ne sais plus quoi faire pour que ça donne parfait.
     
  4. saypee
    saypee WRInaute accro
    Inscrit:
    7 Mai 2005
    Messages:
    2 861
    J'aime reçus:
    0
    Bonjour J-mi, question bete : t'as essayé avec daily ? Il parrait que c'est plus rapide.