Problème de log et htacces

Nathalie35

Nouveau WRInaute
Bonjour,
Je suis en train de me pencher sur l'analyse de log de mon site et je rencontre deux problèmes.
Le premier est que GG crawl mon site avec les urls:

www.monsite.fr et www.monsite.fr/index.php

pourtant dans mon fichier Htacces j'ai le code :
RewriteEngine on
RewriteCond %{HTTP_HOST} ^nature-randonnee.fr$
RewriteRule ^(.*) https://www.nature-randonnee.fr/$1 [QSA,L,R=301]

En dessous j'ai :

RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

Peut-être que les deux commandes entrent en "collision" ? ( je ne maîtrise absolument pas le truc)


Le second problème est que ma page 404.php est très régulièrement crawler ! je viens de la Disallow dans robot.txt.
Dans mon Htacces j'ai la ligne : ErrorDocument 404 https://www.nature-randonnee.fr/404.php or le logiciel d'analyse que j'utilise m'indique que ma page n'est pas configurée correctement, car elle ne renvoie pas le code réponse 404 ?! Que dois je faire du coup ?

Merci de votre aide.
 

spout

WRInaute accro
Pas de redirection de index.php
6pyFxst.png


Les 404 répondent en 302 suivi de 200 :
qk7NC90.png
 

Nathalie35

Nouveau WRInaute
Ben oui ça je l'avais bien compris :) mais du coup pourquoi les codes de mon ficher Htacces indiqué plus haut ne fonctionne pas?
 

Nathalie35

Nouveau WRInaute

rick38

WRInaute passionné
Pour l'index.php tu peux ajouter :
Code:
RewriteRule ^index.php$ / [L,R=301]

Pour le 404, il y a une redirection quelque part qui ne devrait pas y être... le fichier 404.php fait une redirection en PHP ?
 

Nathalie35

Nouveau WRInaute
Pour l'index.php tu peux ajouter :
Code:
RewriteRule ^index.php$ / [L,R=301]
Merci c 'est ajouté !

Pour le 404, il y a une redirection quelque part qui ne devrait pas y être... le fichier 404.php fait une redirection en PHP ?

je n'en vois pas d'autre
 

Nathalie35

Nouveau WRInaute
Essaie en remplacant avec ca dans ton htaccess :

Options +FollowSymlinks
Options -Indexes

RewriteEngine On
RewriteCond %{SERVER_PORT} 80 [OR]
RewriteCond %{HTTP_HOST} ^nature-randonnee\.fr$ [NC]
RewriteRule ^(.*) https://www.nature-randonnee.fr/$1 [QSA,L,R=301]

RewriteRule ^index.php$ / [L,R=301]

ErrorDocument 404 https://www.nature-randonnee.fr/404.php

Voila, Merci beaucoup :) A priori mes Pb de redirection sont résolus. Reste juste ma 404 qui ne renvoie toujours pas de code reponse 404 :'( ( d après SEO POWER SUITE)
 
Dernière édition:

rick38

WRInaute passionné
Voila, Merci beaucoup :) A priori mes Pb de redirection sont résolus. Reste juste ma 404 qui ne renvoie toujours pas de code reponse 404 :'( ( d après SEO POWER SUITE)

Tu peux éditer le fichier 404.php en ajoutant header('HTTP/1.0 404 Not Found'); avant tout envoi de html, mais en principe il n'y a pas à faire ça, là c'est comme si la directive ErrorDocument 404 du .htaccess était ignorée, peut-être vérifier la conf Apache si c'est un serveur dédié. Une page non trouvée ne devrait pas rediriger, elle devrait bien charger ton 404.php mais l'url devrait rester celle de la page non trouvée.
 

Nathalie35

Nouveau WRInaute
Voila, Merci beaucoup :)
Tu peux éditer le fichier 404.php en ajoutant header('HTTP/1.0 404 Not Found'); avant tout envoi de html, mais en principe il n'y a pas à faire ça, là c'est comme si la directive ErrorDocument 404 du .htaccess était ignorée, peut-être vérifier la conf Apache si c'est un serveur dédié. Une page non trouvée ne devrait pas rediriger, elle devrait bien charger ton 404.php mais l'url devrait rester celle de la page non trouvée.

Je suis en mutualisé chez OVH. Je vais tenter avec ton code. Merci
 

rick38

WRInaute passionné
Je suis en mutualisé chez OVH. Je vais tenter avec ton code. Merci

Bon, pas la peine, j'ai trouvé ton problème, le lien doit être relatif et non absolu si on ne veut pas de redirection, donc il faut changer par :
ErrorDocument 404 /404.php
 
Dernière édition:

Discussions similaires

Haut