Problème d'indexation de pages

Discussion dans 'Crawl et indexation Google, sitemaps' créé par Morel35, 3 Mai 2019.

  1. Morel35
    Morel35 Nouveau WRInaute
    Inscrit:
    3 Mai 2019
    Messages:
    15
    J'aime reçus:
    0
    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : Ocean WP
    • Extensions en place : Ocean Extra / Elementor Pro / Yoast SEO / Askimet / Woocommerce / UpdraftPlus
    • Nom de l’hébergeur : OVH
    • Adresse du site : https://www.vetinox.fr/
    Problème(s) rencontré(s) :

    Bonjour à tous,

    Après des mois de travail, je viens de lancer le site internet https://www.vetinox.fr/

    Or je me rends compte que l’ensemble des pages du site, hormis la page d’accueil, ne sont pas indexées sur Google…
    Sous Google Search Console j’ai pu remarquer qu’elles étaient en mode exclues (et non en mode erreur) avec différents états. La plupart sont « Détectée, actuellement non indéxée » sans que je ne sache pourquoi (mes pages produit principalement), et sinon je me suis rendue compte que de nombreuses pages (celles de mon menu entre autres) avaient le statut « Page en double : L’URL envoyée n’a pas été sélectionnée comme URL canonique » avec en URL canonique ma page d’accueil… Je ne comprends pas pourquoi…

    J’ai vérifié, et selon moi il n’y a pas de soucis avec mon sitemap : https://www.vetinox.fr/sitemap_index.xml ni avec mon fichier robot.tkt :http://vetinox.fr/robots.txt

    Bref je suis vraiment perdue, même avoir consulté toute l’aide Google qui y est dédiée, je ne trouve pas la solution pour corriger ce problème majeur…

    Quelqu’un saurait-il d’où vient ce problème et comment le résoudre pour que l’ensemble de mes pages soient correctement indexées ?

    Par avance, merci bcp à ceux qui me liront.

    Belle journée.
     
  2. Johanwri
    Johanwri WRInaute occasionnel
    Inscrit:
    13 Mars 2018
    Messages:
    278
    J'aime reçus:
    58
    1 - Il y a combien de temps que tu as mis en ligne ton site ?
    Si cela fait 1 semaine, il faut un peu de temps pour que tes pages s'indexent
    Actuellement tu as 5 pages indexees http://bit.ly/2JllwOd

    2 - Est ce que tu as declare ton sitemap dans la Search Console ?

    3 - La redirection http <> https n'est pas faite, tes pages sont accessibles en http et https (peut etre ce qui cause le message page en double)
    Exemple
    http://www.vetinox.fr/produits/
    http://www.vetinox.fr/societe/
    http://www.vetinox.fr/sitemap_index.xml
     
  3. Morel35
    Morel35 Nouveau WRInaute
    Inscrit:
    3 Mai 2019
    Messages:
    15
    J'aime reçus:
    0
    Bonjour,

    Merci beaucoup pour ta réponse.

    1 - J'ai mis en ligne le site depuis mardi dernier. Lors de ma première connexion à la google search console, uniquement une page était correctement indexée, celle de page d'accueil. Concernant les 4 autres pages que tu vois indexées, elles le sont car j'ai demandé une indexation pour chacune. Cependant, ce n'est pas selon moi la bonne solution de demander une indexation page par page, car il y a soucis d'indexation globale sur le site.

    2 - Oui mon sitemap est déclaré sous la Search console, il détecte bien l'ensemble des URL, j'ai le message " traitement du sitemap réussi"

    3 - Concernant la redirection http<>https, je suis surprise de ton message, en effet je viens de voir sur tes liens que cela ne fonctionnait pas ! J'ai l'impression que cela ne fonctionne que sur la page d'accueil ? Pour info j'ai mis en place cette redirection via mon fichier htaccess. Sais-tu d'où peut provenir ce dysfonctionnement ?

    Bon dimanche et bon weekend, et encore merci :)
     
  4. Johanwri
    Johanwri WRInaute occasionnel
    Inscrit:
    13 Mars 2018
    Messages:
    278
    J'aime reçus:
    58
    1 - Non il ne faut pas demander une indexation page par page.
    Le sitemap doit permettre de lancer l'indexation.
    Une possibilite est aussi d'utiliser les reseaux sociaux en postant sur Twitter, Facebook, Pinterest (pour les produits) ca peut aider

    3 - Effectivement la redirection http<>https est uniquement sur la home. Peux tu donner le code que tu as mis dans ton htaccess, il n'est probablement pas correct
     
  5. Morel35
    Morel35 Nouveau WRInaute
    Inscrit:
    3 Mai 2019
    Messages:
    15
    J'aime reçus:
    0
    Donc mon problème pourrait venir de ce problème de redirection http<>https
    Je ne comprends pas je pensais avoir mis le bon code sous mon fichier htaccess...

    Voici ce que j'y ai mis :

    # Redirection vers HTTPS

    RewriteCond %{SERVER_PORT} ^80$

    RewriteRule ^(.*)$ https://%{SERVER_NAME}%{REQUEST_URI} [L,R]


    # Redirection du site sans www vers www

    RewriteEngine On

    RewriteCond %{HTTP_HOST} ^vetinox.fr [NC]

    RewriteRule ^(.*)$ http://www.vetinox.fr/$1 [L,R=301]
     
  6. Morel35
    Morel35 Nouveau WRInaute
    Inscrit:
    3 Mai 2019
    Messages:
    15
    J'aime reçus:
    0
    Je viens de le remplacer par ce code (après avoir lu qu'il était adapté à un hébergement OVH), mais cela ne change rien...

    RewriteEngine on
    RewriteCond %{SERVER_PORT} 80
    RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
     
  7. Johanwri
    Johanwri WRInaute occasionnel
    Inscrit:
    13 Mars 2018
    Messages:
    278
    J'aime reçus:
    58
    Ton code n'est pas bon

    Essaye
    Code:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    

    ou
    Code:
    # BEGIN WordPress
    <IfModule mod_rewrite.c
    RewriteEngine On
    RewriteBase /
    RewriteCond %{HTTPS} off
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    
     
  8. Morel35
    Morel35 Nouveau WRInaute
    Inscrit:
    3 Mai 2019
    Messages:
    15
    J'aime reçus:
    0
    Bonjour,

    Merci une nouvelle fois pour votre message.
    Je viens de tester les deux codes dans mon fichier htaccess et cela ne fonctionne pas...
    Le premier ne change rien, et le deuxième provoque une erreur sur le site...
     
  9. Johanwri
    Johanwri WRInaute occasionnel
    Inscrit:
    13 Mars 2018
    Messages:
    278
    J'aime reçus:
    58
    Ca avait marche pour un autre utilisateur WP https://www.webrankinfo.com/forum/t/besoin-daide-pour-configurer-mon-htaccess.194388/#post-1582229

    Quelle est l'erreur sur le site avec le code 2 ?

    Si ces 2 codes ne marchent pas essaye

    Code:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{HTTPS} !=on
    RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    Et si cela ne fonctionne pas il y a la possibilite de passer par un plugin https://wordpress.org/plugins/https-redirection/
    mais en dernier recours, il n'y a pas de raison de ne pas reussir a trouve le bon code dans le htaccess
     
  10. Morel35
    Morel35 Nouveau WRInaute
    Inscrit:
    3 Mai 2019
    Messages:
    15
    J'aime reçus:
    0
    Ce code ne fonctionne toujours pas, je ne comprends pas.. :(
     
  11. Morel35
    Morel35 Nouveau WRInaute
    Inscrit:
    3 Mai 2019
    Messages:
    15
    J'aime reçus:
    0
    En effet j'aimerais éviter l'utilisation d'un plugin, il y a forcément une raison qui bloque cette redirection http<>https...
     
  12. Johanwri
    Johanwri WRInaute occasionnel
    Inscrit:
    13 Mars 2018
    Messages:
    278
    J'aime reçus:
    58
    On est d'accord que tu remplace le code par defaut du htaccess par ceux ci, tu n'ajoute pas ces codes en plus du code par defaut ?
     
  13. Morel35
    Morel35 Nouveau WRInaute
    Inscrit:
    3 Mai 2019
    Messages:
    15
    J'aime reçus:
    0
    Je viens de réussir ! Juste avant de lire ton message, mon erreur venait bien de là, je laissais le code par défaut... Mes excuses pour cette erreur. Ca y est mon site se redirige bien automatiquement en https !

    Je vais désormais vérifier sous ma google search console que le pb d'indexation venait de la.
    (je vous le redirais dans ce post)

    En tout cas mille mercis pour votre aide !
     
  14. Johanwri
    Johanwri WRInaute occasionnel
    Inscrit:
    13 Mars 2018
    Messages:
    278
    J'aime reçus:
    58
    Parfait ! Tu peux preciser quel code a fonctionne entre les 3 que je t'ai donne pour qu'un autre utilisateur qui a le meme probleme puisse mettre le bon
     
  15. Morel35
    Morel35 Nouveau WRInaute
    Inscrit:
    3 Mai 2019
    Messages:
    15
    J'aime reçus:
    0
    Du coup j'ai laissé le dernier code que tu m'avais indiqué. Je viens de renvoyer mon sitemap à la search console, j'attends de voir ce que cela va donner, je croise les doigts, mais j'ai bon espoir :)

    Encore merci pour ton aide !
     
  16. Morel35
    Morel35 Nouveau WRInaute
    Inscrit:
    3 Mai 2019
    Messages:
    15
    J'aime reçus:
    0
    Re-bonjour,

    Depuis la correction, j'ai renvoyé mon sitemap sous Google Search Console (qui m'indique une dernière lecture au 6 mai et donc après la correction de la redirection http<>https).

    Pourtant j'ai toujours la plupart de mes pages en statut "exclues" avec comme message "Détectées, actuellement non indexées" et lorsque j'inspecte les URL concernées je n'ai aucune info... (cf capture d'écran). Je ne comprends pas pourquoi toutes mes URL ne sont pas validées et indexées...
     

    Fichiers attachés:

  17. Johanwri
    Johanwri WRInaute occasionnel
    Inscrit:
    13 Mars 2018
    Messages:
    278
    J'aime reçus:
    58
    Sur la page Sitemap que dit l'etat ?
    Et que dit le nombre d'URL découvertes ?
     
  18. Morel35
    Morel35 Nouveau WRInaute
    Inscrit:
    3 Mai 2019
    Messages:
    15
    J'aime reçus:
    0
    Sur la page sitemap l'état est "opération effectuée" et le nombre d'URL est de 103 URL découvertes
     
  19. Johanwri
    Johanwri WRInaute occasionnel
    Inscrit:
    13 Mars 2018
    Messages:
    278
    J'aime reçus:
    58
    Donc les URL sont bien detectees.
    L'indexation ne se fera pas en 24 heures ; sans compter que demain est un jour ferie.
     
  20. Morel35
    Morel35 Nouveau WRInaute
    Inscrit:
    3 Mai 2019
    Messages:
    15
    J'aime reçus:
    0
    Vous pensez que je dois patienter et attendre quelques jours afin de voir si l'indexation se réalise ?
     
  21. Johanwri
    Johanwri WRInaute occasionnel
    Inscrit:
    13 Mars 2018
    Messages:
    278
    J'aime reçus:
    58
    Oui, il faut surveiller et patienter un peu.
    Je pense que populer sur les reseaux sociaux peut aider a booster
    Concernant les produits, chaque fiche produit me semble pauvre en contenu, il faudrait essayer de faire des descriptions plus longues.
    Ameliorer aussi le maillage interne, par exemple dans l'article qui parle de la SPA, faire un lien vers le produit

    (le jour ferie c'etait une blague)
     
  22. Morel35
    Morel35 Nouveau WRInaute
    Inscrit:
    3 Mai 2019
    Messages:
    15
    J'aime reçus:
    0
    Je me doutais qu'il s'agissait d'une blague ;)

    En effet je vais enrichir mon contenu en parallèle et patienter. Pour les réseaux sociaux, ce n'est malheureusement pas prévu pour tout de suite. Je vais suivre cela de près dans les jours à venir et je vous tiendrais informé si le pb est bel et bien réglé.

    Merci bcp pour vos messages !
     
  23. Furtif
    Furtif WRInaute passionné
    Inscrit:
    9 Août 2005
    Messages:
    2 492
    J'aime reçus:
    146
    Tu as des erreurs 500 sur tes pages produits :
    Exemple : https://www.vetinox.fr/produit/cage-de-contention/
    Invalid links: 20
    Erreur 500 (Internal Server Error) : Les causes et solutions pour éviter une erreur500. Bien que l'erreur HTTP 500 signifie Internal Server Error (Erreur interne du serveur), le problème se situe dans la plupart des cas dans un fichier / répertoire de votre site Internet.

    Tu devrais egalement revoir ta structure des pages produits (duplicate h1-h2) :
    https://www.vetinox.fr/produit/cage-de-contention/
    13 headings
    <h1>Cage de contention
    <h1>Cage de contention

    <h2>En savoir plus
    <h2>Description
    <h2>Informations complémentaires
    <h2>Produits apparentés
    <h2>Produits apparentés

    <h2>Ensemble de 6 cages en polyester
    <h2>Ensemble de 6 cages en acier inoxydable
    <h2>Ensemble de 3 cages en polyester

    <h3>(Missing heading)
    <h4>Navigation
    <h4>Catégories
    <h4>Activer votre Garantie Produit

    Contenu tres pauvre egalement
     
  24. Morel35
    Morel35 Nouveau WRInaute
    Inscrit:
    3 Mai 2019
    Messages:
    15
    J'aime reçus:
    0
    Bonjour,

    Merci pour bcp pour ton message. Peux-tu stp m'indiquer comment tu as détecté ces erreurs 500 ?

    En effet j'ai du taff niveau SEO sur les pages produits !
     
  25. Morel35
    Morel35 Nouveau WRInaute
    Inscrit:
    3 Mai 2019
    Messages:
    15
    J'aime reçus:
    0
    Bonjour,

    J'ai travaillé l'optimisation du site sur la partie technique et performance (que je poursuis pour ensuite passer au contenu), mais actuellement le pb d'indexation est toujours le même... Les seules pages indexées (les 7 pages, mise à part la page d'acceuil qui était la seule page indexée à la base) sont indexées car j'ai demandé une indexation (chose que je ne souhaite pas faire pour l'ensemble des pages).

    J'entends que mon positionnement s'améliorera avec le temps & avec un bon taff SEO, mais là j'ai le sentiment que Google refuse d’indexer mes pages et je ne comprends pas pourquoi... Quelqu'un a-t-il une idée ?
     
Chargement...
Similar Threads - Problème indexation Forum Date
Problèmes d'indexation et robots.txt Crawl et indexation Google, sitemaps 14 Octobre 2019
Problème d'indexation Débuter en référencement 8 Octobre 2019
Search Console Problème indexation page produit - prestashop 1.6 Débuter en référencement 25 Juin 2019
Problème indexation partielle Crawl et indexation Google, sitemaps 3 Juin 2019
Problème d'indexation, Sitemaps non lus et baisse drastique du référencement/trafic Débuter en référencement 22 Mars 2019
Problème ou retard indexation de mondomaine.com Débuter en référencement 16 Mars 2019
WordPress Problème indéxation suite à migration HTTP vers HTTPS Problèmes de référencement spécifiques à vos sites 31 Janvier 2019
WordPress Problème d'indexation depuis quelques jours Crawl et indexation Google, sitemaps 17 Janvier 2019
Analyse google search console : liste des problèmes d'indexation Crawl et indexation Google, sitemaps 13 Janvier 2019
Problème indexation page Problèmes de référencement spécifiques à vos sites 31 Décembre 2018
  1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies.
    Rejeter la notice