Besoin d'aide pour configurer mon htaccess

popeye59

Nouveau WRInaute
Bonjour,

J'aurai besoin d'aide pour configurer mon fichier htaccess svp.
J'ai passé mon site de "http" a "https" et j'aimerai regiriger les personnes qui viennent de lien http vers le https (et que ca aide google aussi a comprendre que le http n'est plus actif (pas de double url avec contenu identique)

J'aurai donc voulu mettre dans mon fichier htaccess le code suivant:
"
RewriteEngine on
RewriteCond% {HTTP_HOST} ^ monsite.fr [NC, OR]
RewriteCond% {HTTP_HOST} ^ www.monsite.fr [NC]
(*). RewriteRule ^ $ https: //monsite.fr/$1 [L, R = 301, NC]
"

mais je m'appercois qu'il y a deja des informations dans mon fichier htaccess
"
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress
"
(mon site est un site wordpress)

Etant donné que je ne suis pas bon en rewriting j'ai tenté differentes techniques pour completé le code actuel avec l'ajout de code mais a chaque fois mon site plante.
Qqun pourrait il m'aider pour me dire quoi ajouter exactement depuis le code actuel svp?
Merci d'avance pour votre aide

Exemple de code que j'ai tenté:
"
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
RewriteCond% {HTTP_HOST} ^ monsite.fr [NC, OR]
RewriteCond% {HTTP_HOST} ^ www.monsite.fr [NC]
(*). RewriteRule ^ $ https: //monsite.fr/$1 [L, R = 301, NC]
</IfModule>
# END WordPress
"
 

popeye59

Nouveau WRInaute
En effectuant d'autres test avec d'autres type de code, j'ai reussi a faire fonctionner la redirection:
Voici le code mis a jour:

"
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
RewriteCond %{HTTPS} !=on
RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
</IfModule>
# END WordPress
"

Malgré cela, je reste curieux de savoir pourquoi mon precedant code non fonctionnait pas.
Alors, a titre d'infirmation, je suis tout de meme preneur d'une reponse.
Merci beaucoup.
 

popeye59

Nouveau WRInaute
J'ai parlé trop vite, le nouveau code de mon précédant message (message numero 2) ne foncrtionne pas non plus.
Le site ne plante pas, mais la redirection ne s'effectue pas...

J'ai donc besoin de votre précieuse aide.
Merci
 

popeye59

Nouveau WRInaute
Bonjour,

Merci pour votre retour.
J'avais bien etudié cette page, mais les codes proposés ne fonctionnent pas non plus avec mon site. Ou alors je l’intégre mal da,s le code deja actuel de mon fichier htaccess.

Une autre option?
Quun pourrait il m'aider par rapport a mon code actuel?

Merci
 

Johanwri

WRInaute occasionnel
B
Quun pourrait il m'aider par rapport a mon code actuel?
Tu peux essayer et dire si ok ou message d'erreur

Code:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress
 

popeye59

Nouveau WRInaute
Bonjour,

Non, cela ne fonctionne pas.
En forcant l'adresse en http, je reste sur cette adresse non scurisé.
De ce fait, pour le moment (temporaire) j'utilise l'extression "Really Simple SSL" de wordpress pour forcer a rester en https.
Cependant je préférerai le faire de manière propre en utilisant le fichier htaccess.

Voici mon site: naturopathe lille
Merci pour votre aide.
 

Johanwri

WRInaute occasionnel
Je fais mes redirections au niveau du serveur, je ne peux pas essayer sur mes sites.
Voici 3 propositions
Essaye dans l'ordre et dis si l'une fonctione

1
Code:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{HTTPS} !=on
RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

si ca ne marche pas essaye
2
Code:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{HTTPS} !=on
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

Si ca ne marche pas non plus essaye
3
Code:
<IfModule mod_rewrite.c
RewriteEngine On
RewriteBase /
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
 

popeye59

Nouveau WRInaute
Le code numero 2 semble etre la bonne solution!
Un grand merci. Je n'aurai pas réussis seul. Et mon herbergeur était loin de savoir repondre a cela...

Pouvez vous effectuer un test de votre coté pour me confirmer que tout est ok pour vous?
je vous redonne le lien: naturopathe lille
Encore un grand merci.
Bonne journée
 
Dernière édition:

Johanwri

WRInaute occasionnel

popeye59

Nouveau WRInaute
Une page n'est pas securisee a cause de mixed content
Page https://victorledoux-naturopathe.fr/trouble-du-sommeil/

Bien vu, j'avais vérifié toute les pages exceptés celle la.
Un grand merci pour ta précieuse aide. Génial!

En désinstallant définitivement Really simple SSL, je me suis uppercut qu'en le désactivant ce matin, il avait automatiquement désactivé le https de la home page.
Je me suis empressé de le remettre. Par contre cela n’était pas visible sur le site, surement garce a la redirection htaccess.

Encore merci
 

popeye59

Nouveau WRInaute
Mince, je viens d'effectuer un nouveau test sur cette page en supprimant passant de https a http:
http://victorledoux-naturopathe.fr/trouble-du-sommeil/

résultat: la page reste en http :(
J'avais pourtant essayé avant et cela fonctionnait correctement, ce n'est plus la cas.
Arrivez vous a reproduire le même probleme que moi?
Jai vidé le cache et essayé sur une autre connexion et ordinateur, le problème persiste.
 

Johanwri

WRInaute occasionnel
Arrivez vous a reproduire le même probleme que moi?

Oui pareil
Essaye de modifier le code du htaccess avec les differents codes des posts precedents (post 8)
Il est imperatif de mettre en place ce code sans le plugin Really simple SSL (supprime totalement pas uniquement desactive)
 

popeye59

Nouveau WRInaute
Cette fois ci, la 3e option de code fonctionne.
Ce matin, il ne fonctionnait pas (mais j'avais juste desactivé le really simple SSL et pas reellement supprimé.

Je ferai d'autres test dans la journée pour m'assurer que cest encore ok.
Encore merci pour vos retour et votre reactivité
 

Discussions similaires

Haut