[Résolu] Encodage en Unicode

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par John Smith, 16 Novembre 2007.

  1. John Smith
    John Smith WRInaute occasionnel
    Inscrit:
    4 Avril 2007
    Messages:
    341
    J'aime reçus:
    8
    Bonjour,

    J'ai un petit soucis. Un internaute bien intentionné vient de m'écrire en me signalant que mon site n'était pas codé en Unicode et qu'il ne s'affiche pas bien sur son navigateur...

    J'avoue que je ne saisis pas bien. J'ai pour ma part fait des tests sur IE, Firefox et Opera. Je ne comprends pas bien le problème.
    Je lui demande donc des explications et il rencherit comme suit :

    (Il s'agit visiblement d'un internaute étranger, donc peut-être autre navigateur ?!!!)

    Au secours ! Je ne comprends rien !

    Quelqu'un peut-il m'expliquer très clairement comme à un néophyte de quoi il retourne. Grand merci !
     
  2. bozoleclown
    bozoleclown WRInaute impliqué
    Inscrit:
    24 Novembre 2005
    Messages:
    693
    J'aime reçus:
    0
    url ?

    as tu défini un charset ?
     
  3. 5_legs
    5_legs WRInaute passionné
    Inscrit:
    30 Avril 2006
    Messages:
    1 521
    J'aime reçus:
    0
    Bonsoir

    Dans le source de la page en question, as-tu quelque chose de ce style :

    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

    ?

    Sweet
     
  4. John Smith
    John Smith WRInaute occasionnel
    Inscrit:
    4 Avril 2007
    Messages:
    341
    J'aime reçus:
    8
    Je ne mets pas systématiquement l'adresse de mon site, mais bon :
    http://dictionnairedelazone.fr

    Effectivement, j'ai dû omettre ce meta-tag...
     
  5. John Smith
    John Smith WRInaute occasionnel
    Inscrit:
    4 Avril 2007
    Messages:
    341
    J'aime reçus:
    8
    Non effectivement, est-ce que ça règle le problème d'affichage des caractères accentués ? Car visiblement, c'est là qu'est le problème. Ce cher internaute m'a envoyé une copie d'écran et les caractères accentués ne s'affichent pas bien. Ce que je ne comprends pas c'est pourquoi je n'ai pas le problème sur mes trois navigateurs ? Comment reproduire le problème chez moi dans ce cas ?
     
  6. darkjukka
    darkjukka WRInaute impliqué
    Inscrit:
    28 Avril 2007
    Messages:
    574
    J'aime reçus:
    0
    Met cette balise meta et demande lui de retester, le soucis doit certainement venir de là ;)
     
  7. Sir Dipp
    Sir Dipp WRInaute impliqué
    Inscrit:
    21 Juillet 2003
    Messages:
    899
    J'aime reçus:
    0
    Salut,

    A mon avis sa configuration est n'est pas cochée par : Sélection automatique de l'encodage

    Il à certainement dû la forcer à UTF-8 et du coup il voit mal les accents.

    A+
     
  8. John Smith
    John Smith WRInaute occasionnel
    Inscrit:
    4 Avril 2007
    Messages:
    341
    J'aime reçus:
    8
    Eh bien finalement, le meta tag semble suffir d'après l'internaute bien intentionné. Merci.
     
Chargement...
Similar Threads - [Résolu] Encodage Unicode Forum Date
[résolu] recupération de flux xml et erreur encodage des caractères Développement d'un site Web ou d'une appli mobile 27 Janvier 2016
[résolu] SimpleXML et encodage caractères Développement d'un site Web ou d'une appli mobile 18 Août 2007
Problème images en https (forum phpbb) [résolu] Développement d'un site Web ou d'une appli mobile 18 Novembre 2017
[Résolu] Redirection 301 FR vers EN sur Prestashop uniquement sur outils Google ? Problèmes de référencement spécifiques à vos sites 11 Septembre 2017
[résolu] Passage à HTTPS, comment tester une page ? Développement d'un site Web ou d'une appli mobile 7 Septembre 2017
[Résolu] Redirection d'une famille d'URL URL Rewriting et .htaccess 9 Mars 2017
[Résolu] Diaporama et SEO Débuter en référencement 17 Janvier 2017
[résolu]Redirection monsite.fr/index.html sur monsite.fr et seo URL Rewriting et .htaccess 16 Janvier 2017
[resolu]Publicité facebook lié au compte instagram Facebook 12 Décembre 2016
[résolu] Récupérer des valeurs issues de javascript pour les mettre en base MySQL Développement d'un site Web ou d'une appli mobile 18 Juillet 2016
[résolu] Faire une redirection sauf pour mon adresse IP URL Rewriting et .htaccess 15 Juin 2016
[Résolu] 2 descriptions pour une même url selon requête Crawl et indexation Google, sitemaps 1 Juin 2016
[résolu] Action onchange sur FORM/SELECT qui ne fonctionne qu'à la première action ?!? Développement d'un site Web ou d'une appli mobile 31 Mai 2016
[résolu] Sessions : lire le contenu alors qu'on ne sait pas comment il est nommé... Développement d'un site Web ou d'une appli mobile 25 Mai 2016
[résolu] Avoir un paramètre de session "dynamique" ? Développement d'un site Web ou d'une appli mobile 25 Mai 2016
[résolu] Hauteur de div selon état d'un bouton radio Développement d'un site Web ou d'une appli mobile 23 Mai 2016
[résolu] Carte Google Maps avec "zones de densité" Développement d'un site Web ou d'une appli mobile 5 Novembre 2015
Balise NoIndex ignorée par Google? [résolu] Débuter en référencement 13 Janvier 2015
[Résolu] sites référents sans lien vers mon site Demandes d'avis et de conseils sur vos sites 7 Janvier 2015
Lorsqu'on a créé un site, faut-il mettre un lien vers son site dans le footer ? [Résolu] Débuter en référencement 31 Décembre 2014