Validateur W3C plus que 2 erreurs

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par emeric72, 27 Août 2006.

Tags:
  1. emeric72
    emeric72 Nouveau WRInaute
    Inscrit:
    27 Août 2006
    Messages:
    4
    J'aime reçus:
    0
    Bonjour,

    Je patine un peu depuis hier. J'ai evacué des erreus assez simples jusqu'à présent, il m'en reste 2 à élucider (en fait 4, mais une erreur est faite trois fois !!)

    Evidemment un bonne balise des familles background ! qui m'embète un peu.

    ET puis du slice !!! aussi

    Voici l'url de mon site
    http://echographe.neuf.fr/ voici les erreurs sur la page index

    sur la page http://www.validateur.ca/
    Celle-ci me prends bien la tête
    <td colspan="5" background="images/index_06.jpg"
    height="33" width="9">

    Error Line 94 column 33: there is no attribute "BACKGROUND".
    <td colspan="5" background="images/index_06.jpg" height="33">
    Je pense que c'est l'attribut background derrière mon tableau , je ne vois pas trop

    Et puis j'en ai trois autres qui sont les mêmes:

    Error Line 285 column 34: end tag for element "P" which is not open.
    <!-- End ImageReady Slices --> </p>

    Remarque: je ne suis pas un super pro du code, les pages ont été faites avec Nvu et un kit graphique que j'ai améliroré, ceci doit expliquer cela !!

    Si des idées ou des pistes je suis preneur parce que là j'ai la tête comme un pastèque!
     
  2. Kekoah
    Kekoah WRInaute occasionnel
    Inscrit:
    5 Novembre 2005
    Messages:
    289
    J'aime reçus:
    0
    Pour ton background, essaye ceci
    <td colspan="5" style="background-image:url(images/index_06.jpg);" height="33" width="9">

    sinon enlève aussi tes 3 lignes <!-- End ImageReady Slices --> </p> tu devrais passer à la validation, je viens de tester en recopiant ta source :)
     
  3. dorian53
    dorian53 WRInaute passionné
    Inscrit:
    10 Avril 2005
    Messages:
    1 886
    J'aime reçus:
    1
    Salut,

    Error Line 285 column 34: end tag for element "P" which is not open.
    La plus simple, il manque l'ouverture du <p>

    Pour le background passe plutot par du css.
    L'attribut "background" n'existe pas pour un <td>
     
  4. hebmaster
    hebmaster WRInaute impliqué
    Inscrit:
    22 Décembre 2005
    Messages:
    918
    J'aime reçus:
    0
    presque tous les attributs de la mise en forme d'une balise doivent se mettre à l'interieur de style="..."
     
  5. dx.radio
    dx.radio Nouveau WRInaute
    Inscrit:
    28 Mars 2005
    Messages:
    33
    J'aime reçus:
    0
    Tu mets ca avant </head>
    <style type="text/css">
    <!--
    .image {background:url(images/index_06.jpg);
    height:33px;
    width:9px; }
    -->
    </style>

    puis : <td colspan="5" class="image"> </td>

    Pour </p> je pense que tu n'as pas ouvert la balise par <p>

    J'avais pas vu la solution de @Kekoah plus haut à laquelle je n'ai pas pensée sur le moment qui est effectivement la plus simple - mais bon habitude des feuilles de styles
     
  6. emeric72
    emeric72 Nouveau WRInaute
    Inscrit:
    27 Août 2006
    Messages:
    4
    J'aime reçus:
    0
    merci pour ces réponses, je teste cela en live et vous donne les réponses correctes

    le <td colspan="5" style="background-image:url(images/index_06.jpg);" height="33" width="9">

    m'a généré un autre erreur plus bas sur un autre background va falloir que j'uniformise tout le monde

    Je vous tiens au courant de suite
     
  7. emeric72
    emeric72 Nouveau WRInaute
    Inscrit:
    27 Août 2006
    Messages:
    4
    J'aime reçus:
    0
    Bonne pioche pour Kekoah

    Il fallait transformer ceci
    <td colspan="5" background="images/index_06.jpg" height="33" width="9">

    Par ceci
    <td colspan="5" style="background-image:url(images/index_06.jpg);" height="33" width="9">

    Ce qui m'a généré d'autres erreurs dans tous les attributs background, ce que j'ai changé. Je vais faire le reste sur mon site avec un bon rechercher remplacer des familles cela devrait vite etre expédié.

    J'ai trifouillé les slices mais nvu me remets à chaque fois la balise </P>, la seule page que j'ai corrigé est
    http://echographe.neuf.fr/SolutionsIRMSCAN.html mais il me reste ces %µ%§/§; *** balises </P>
     
  8. Kekoah
    Kekoah WRInaute occasionnel
    Inscrit:
    5 Novembre 2005
    Messages:
    289
    J'aime reçus:
    0
    Etrange, j'avais testé en enlevant la balise </p>.. ce qui ne changeait rien au design puis en validant sur le w3c validator et ta page passée valide

    ou sinon il te faudra l'ouvrir en ajoutant ceci <p> avant
     
  9. emeric72
    emeric72 Nouveau WRInaute
    Inscrit:
    27 Août 2006
    Messages:
    4
    J'aime reçus:
    0
    Ca y est, j'en ai une de bonne !!

    A la ligne

    <p align="center"><!-- ImageReady Slices Essai -->

    il fallait rajouter le </p> qui n'y était pas tout de suite à la fin de la ligne c'est pour cela que cela renvoyait l'erreur 30 lignes plus bas.

    <p align="center"><!-- ImageReady Slices Essai --> </p>


    Bon merci kekoah, dx radio, dorian53 et hebmaster pour leurs pistes.

    On se sent toujours moins seul au moins et cela permet assez vite de croiser les avis et de voir les pistes probantes. @ Plus
     
  10. nicolas34500
    nicolas34500 Nouveau WRInaute
    Inscrit:
    2 Juin 2006
    Messages:
    23
    J'aime reçus:
    0
    2 erreurs seulement ??? C'est bien ! Si tu as Firefox, installe le plugin Firebug et vois l'état délabré de WRI : une erreurr par page !
     
Chargement...
Similar Threads - Validateur W3C erreurs Forum Date
Nouveau validateur W3C unifié: Unicorn Développement d'un site Web ou d'une appli mobile 28 Juillet 2010
Validateur multipage W3C : problème validation Développement d'un site Web ou d'une appli mobile 27 Avril 2010
Validateur W3C : version française ? Développement d'un site Web ou d'une appli mobile 25 Décembre 2007
Validateur w3c Développement d'un site Web ou d'une appli mobile 17 Septembre 2007
Erreur validateur w3c Développement d'un site Web ou d'une appli mobile 18 Août 2007
Validateur W3C trés intéressant ! Développement d'un site Web ou d'une appli mobile 24 Février 2007
Validateur w3c local Administration d'un site Web 26 Novembre 2004
Entity/Service - Validateurs de champ Développement d'un site Web ou d'une appli mobile 25 Mai 2012
Message d'avertissement dans le validateur HTML Développement d'un site Web ou d'une appli mobile 9 Avril 2009
Que faire avec cette analyse du validateur Xhtml ? Débuter en référencement 4 Décembre 2007
Validateur de robots.txt ? Débuter en référencement 12 Avril 2006
validateur de lien-invalide Débuter en référencement 2 Mars 2006
Recherche validateur XHTML et vérificateur de liens Développement d'un site Web ou d'une appli mobile 19 Juillet 2005
probleme de validateur htm Débuter en référencement 5 Juin 2005
Validateur XHTML1.1 Strict... Monique, au secours !!! Administration d'un site Web 10 Mai 2004
probleme pour apporter les corrections sur au validateur w3. Administration d'un site Web 1 Septembre 2003
WebAssembly, un nouveau standard de langage w3c Développement d'un site Web ou d'une appli mobile 8 Décembre 2019
W3C ou mobile speed, qui est le plus important ? Débuter en référencement 23 Janvier 2018
Comment arranger ce message d'erreur W3C ? [Content-Security-Policy HTTP header] Administration d'un site Web 28 Avril 2017
Schema Markup ou w3c valide all in one seo wordpress Débuter en référencement 26 Octobre 2016