Balise hreflang ne fonctionne pas

Denys06

Nouveau WRInaute
Bonjour à tous, j’aurais grandement besoin de votre aide s’il vous plait.
En effet j'ai configuré il y a bientôt un an des balises hreflang sur mon site internet : http://www.slotcar-union.com.

Toutefois je n'ai pas l'impression que ma modification ne fonctionne pas car j'ai 2085 balises title en double.

Dans Google Webmaster Tools il m'est aussi indiqué :
20216 Balises "hreflang"
2230 Balises "hreflang" qui contiennent des erreurs

J'aurais besoin de votre aide pour identifier pourquoi il me reste 2230 erreurs (qui provoque mon duplicate content).

Voici des exemples de liens données par Google qui contiennent les erreurs :

URL d'origine : http://www.slotcar-union.com/en/100-spare-parts
Autre version de l'URL : http://www.slotcar-union.com/it/100-pezzi-di-ricambio

URL d'origine : http://www.slotcar-union.com/en/12-scalextric-straights-straight-borders
Autre version de l'URL : http://www.slotcar-union.com/de/12-scalextric-gerade-und-gerade-borders

En analysant mon code source, saurez-vous expliquer pourquoi je dispose de toutes ces erreurs ?
En espérant que vous pourrez grandement m'aider car cela fait très longtemps que je bloque sur ce problème..
 

Denys06

Nouveau WRInaute
Bonjour et merci beaucoup pour ta réponse,

Qu’appelles-tu le code "minifié" ? S'agit-il du code :

hreflang="fr"

Dans l'aide Google il est pourtant indiqué que l'on peut mettre ce code à la place du fr-FR ou fr-BE pour ne pas limiter la langue à une simple région.

Dans le lien que tu m’as donné il est indiqué que "Le nœud est vide" mais je n'ai pas plus d'information ou de ligne d'erreur.

Auras-tu plus d'informations ou plus d'idée à me soumettre pour m'aider ?
Merci
 

Denys06

Nouveau WRInaute
Bonjour,

J'ai retiré la minification du code, cela n'a rien changé à mon problème de "Type non spécifié" avez-vous une nouvelle idée s'il vous plait ?

Voyez-vous vous quelque chose qui cloche dans mon code qui pourrais provoquer le duplicate content dont je dispose malgré le fait que j'ai selon moi bien appliqué les balises "hreflang" ?

Je laisse le code non compressé sur ma boutique quelques jours le temps que vous puissiez jeter un œil.
Merci d'avance pour toute aide possible
 

zeb

WRInaute accro
essaye de renseigner > <meta property="og:description" content="" /> je me demande si ce champ non renseigné ne provoque pas le plantage de tes <link> juste en dessous, d'où le "Le nœud est vide. Vérifiez que cela est intentionnel et supprimez-le éventuellement." renvoyé 7 fois par le testeur google sur ce qui peut être tes 7 <link>
 

Denys06

Nouveau WRInaute
Bonjour zeb et merci pour ton soutient dans la résolution de mon problème.

J'ai testé avec une autre url disposant d'une description content, mais cela ne résout pas mon souci sur le testing tool de Google :

https://developers.google.com/structured-data/testing-tool/?url=http://www.slotcar-union.com/fr/digital-132/3801-carrera-digital-132-30704-formula-e-andretti-autosport-mandretti-no28-4007486307049.html

Une autre idée :) ?

Ensuite il est vrai que le testing tool m'indique 7 erreurs, c'est bizarre car comme tu me l'indique j'ai 7 langues différentes sur mon site, cela doit être lié, mais d'où peut bien provenir ces erreurs ?
 

zeb

WRInaute accro
Toujours dans l'idée d'un truc mal fermé qui provoquerait une erreur en cascade du parseur regarde du côté de tes commentaires conditionnels a destination d'IE.

je verrais bien un truc du genre en ligne 6 de cette page (d'une façon générale essaye de passer le validateur W3C pas que ce soit indispensable mais ça écartera les souci de parseur) :

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr"> <!--<![endif]-->
 

Bobdu35

Nouveau WRInaute
Bonjour,

Je suis un peu dans le même cas, la balise n'est pas vu sous Google Search Console
J'ai un site en 2 langues : fr et en

Dois-je mettre dans le <head> ces 2 balises ou l'une ou l'autre selon la langue utilisée ?


Code:
<link rel="alternate" href="www.netplanning.fr" hreflang="fr" />
<link rel="alternate" href="www.netplanning.fr/?lg=en" hreflang="en" />

D'avance merci pour votre aide.
 

Discussions similaires

Haut