Pas d'image Facebook avec un lien ?

Discussion dans 'Facebook' créé par Crash84, 3 Mai 2012.

  1. Crash84
    Crash84 WRInaute discret
    Inscrit:
    27 Juin 2010
    Messages:
    226
    J'aime reçus:
    0
    Bonjour,

    Je suis le webmaster du site Arles-Avignon.com, et j'ai remarqué que sur ma page Facebook (lien) il n'y a pas d'images lorsque je partage un lien et je ne comprends pas vraiment pourquoi.

    Avez-vous des idées ?

    Merci !
     
  2. 1eB
    1eB WRInaute discret
    Inscrit:
    26 Janvier 2012
    Messages:
    77
    J'aime reçus:
    0
    Bonjour,

    Il faut préciser dans les meta tag, de la page partagée, avec opengraph quelle image facebook doit utiliser.

    Code:
    <html xmlns="http://www.w3.org/1999/xhtml" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="https://www.facebook.com/2008/fbml" xml:lang="fr">
    
    <meta property="fb:admins" content="xxxxxxxx" />
    <meta property="og:site_name" content="Nom de votre site" />
    <meta property="og:title" content="Titre de la page" />
    <meta property="og:type" content="website | article tout dépend de ce que vous mettez en avant" />
    <meta property="og:url" content="L'url que facebook doit enregistrer" />
    <meta property="og:image" content="L'url de l'image que facebook devra afficher" />
    <meta property="og:description" content="La description associée au lien partagé." />
    https://developers.facebook.com/docs/opengraph/
     
  3. Crash84
    Crash84 WRInaute discret
    Inscrit:
    27 Juin 2010
    Messages:
    226
    J'aime reçus:
    0
    Il faut que je mette ce code dans header ?
     
  4. 1eB
    1eB WRInaute discret
    Inscrit:
    26 Janvier 2012
    Messages:
    77
    J'aime reçus:
    0
    Exactement.

    Ceci est un exemple avec la première version d'open graph, dont on trouve la description à cette adresse : https://developers.facebook.com/docs/opengraphprotocol/

    La nouvelle version permet de faire plus de choses mais est aussi un peu plus complexe à mettre en oeuvre.
     
  5. Crash84
    Crash84 WRInaute discret
    Inscrit:
    27 Juin 2010
    Messages:
    226
    J'aime reçus:
    0
    Par contre je comprends pas trop trop ...
    Je mets ce code dans le header ok, mais j'efface ce qui été déjà là ? Et je mets quoi à la place du lien de l'image car chaque article en a une différente.
     
Chargement...
  1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies.
    Rejeter la notice