Problème avec mediawiki: redimensionnement d'image kaput^^

csseur

WRInaute discret
Bonsoir,

j'utilise la dernière version de mediawiki (1.6.5) sur un hébergement mutualisé chez 1and1.

Le redimensionnement d'image avec GD marche mais les images sont d'une qualité éxécrable dés lors que la taille change par rapport à celle d'origine.

J'ai envoyé un mail, la librairie GD est bien installée chez 1and1, je ne comprends pas d'ou ca vient.


Et comme indiqué dans l'aide:
# $wgUseImageResize - Set $wgUseImageResize to true if you want to enable dynamic server side image resizing (Thumbnails)

j'ai mis sur true bien évidemment dans LocalSettings.php...


please, help :cry:


amicalement,
fred
 

gomoz

WRInaute discret
peut être tout simplement que c'est le comportement normal. Le redimentionnement fait toujours perdre en qualité si les images en questions sont un peu compliqués (même avec les logiciels tels gimp, photoshop et compagnie alors avec la librairie GD...).

A moins que ça fonctionne mieux sur un autre, je doute que tu puisse faire quoique ce soit.
 

csseur

WRInaute discret
j'ai essayé avec les images du thème nuvola de KDE et d'autres icones pour tester, sur la wikipédia francophone elles se redimensionnent correctement, là sur mon wiki une icone représentant une palette graphique avec du vert rouge et bleu, devient presque un gros macaron marron quand c'est agrandit.

Ya un réel problème vu que je teste avec des images qui sont bien redimensionnées sur les wikipédia...

version de GD trop ancienne chez 1and1? modifications de leur part?
 

gomoz

WRInaute discret
ou alors wikipedia a modifié la facon de redimentioner les images. Mets le lien de ton wiki ou au moins un exemple avant/après pour voir ?

Après ca peut etre aussi le type de l'image qui est mal géré. Tu as essayé avec du png, du gif et du jpg ?
 

csseur

WRInaute discret
re,

dsl pr le retard^^
voici un visuel:




en haut a gauche: les images redimensionnées sur mon wiki, remarquez la deuxième ou le rouge de la palette est presque devenu marron...
en haut à droite: l"image redimensionnée sur wikipédia.
en bas: l'image originale

je viens d'upgrader vers la toute dernière version de mediawiki, et je ne comprend tjs pas.

a moins que j'ai raté une doc, mais bon j'ai deja installé pas mal d'extensions et tout, je connais bien mediawiki maintenant, mais c'est la première fois que je peux tester l'upload d'image, avant j'étais chez un hébergeur ou ca ne marchait pas.

quelqu'un chez 1and1 aurait aussi ce problème? :?


@++
 

gomoz

WRInaute discret
essaye d'abort en local si tu veux.

A mon avis (en voyant tes images) c'est un problème dans le code. L'image doit passer à un moment ou un autre en 256 couleurs (gif).


édit: ou peut etre pas en fait, je ne sais pas trop. En tous cas si en local ca marche tu sera fixé.
 

Discussions similaires

Haut