Problème fonction HEADER !

Discussion dans 'Administration d'un site Web' créé par Strack, 25 Mars 2005.

  1. Strack
    Strack Nouveau WRInaute
    Inscrit:
    10 Mars 2005
    Messages:
    6
    J'aime reçus:
    0
    Bonjour à tous, je rencontre ce probleme sur mon module de donwload, quand je veux downloader une fichier :

    J'ai essaye avec un meta refresh mais il me redirige sur une page vide avec des bugs de design, je ne sais plus comment faire, c'est depuis que jai adapte mon module sur mon design :

    http://www.gtasanandreas-fr.com/download/pafiledb.php

    Merci a vous
     
  2. jeroen
    jeroen WRInaute passionné
    Inscrit:
    30 Août 2002
    Messages:
    2 131
    J'aime reçus:
    0
    dans le code, tu envoie une information au navigateur (echo, ...) avant d'envoyer le header....
     
  3. Genzo
    Genzo WRInaute impliqué
    Inscrit:
    18 Juin 2004
    Messages:
    545
    J'aime reçus:
    0
    Il faut qu'il n'y ait aucun affichage (en php ou en html) avant d'envoyer des données à l'header. Ne serait-ce qu'un seul espace planterait la fonction, et donc l'affichage de l'erreur à l'écran.
     
  4. JeunZ
    JeunZ WRInaute accro
    Inscrit:
    18 Février 2004
    Messages:
    3 942
    J'aime reçus:
    0
    Meme un espace devant une balise <? peut etre la cause de cette erreur ;-)
     
  5. olivieri
    olivieri WRInaute impliqué
    Inscrit:
    3 Février 2003
    Messages:
    689
    J'aime reçus:
    0
    J'ai eu un cas identique et c'était un retour chariot en fin de fichier après le ?>
     
  6. Strack
    Strack Nouveau WRInaute
    Inscrit:
    10 Mars 2005
    Messages:
    6
    J'aime reçus:
    0
    Donc en gros je peut faire comment pour résoudre sa ? Jy connais pas des massses la dedans lol :)
     
  7. JeunZ
    JeunZ WRInaute accro
    Inscrit:
    18 Février 2004
    Messages:
    3 942
    J'aime reçus:
    0
    Vérifier que tu n'as pas une fonction php qui fait un echo avant les balises <html> etc...

    Et vérifier qu'il n'y a pas avant tes balises <? un espace...
     
  8. olivieri
    olivieri WRInaute impliqué
    Inscrit:
    3 Février 2003
    Messages:
    689
    J'aime reçus:
    0
    pour mon cas, c'etait un fichier include, et le fait de faire le include ressortait un caractère. Regarde par la aussi si tu fait un include.
     
  9. Strack
    Strack Nouveau WRInaute
    Inscrit:
    10 Mars 2005
    Messages:
    6
    J'aime reçus:
    0
    Merci pour vos reponse !

    Donc en gros jai sa comme ligne dans le fichier download.php de /inlcudes
    : en rouge la ligne qui pose probleme apparement

    Mais avant que je mette le module dans mon design (sur pafiledb.php jai mis le design de mon index, mais pas d'include) et avant que je lintegre il n'y avait pas de prob :s
     
Chargement...
Similar Threads - Problème fonction HEADER Forum Date
Problème de fonctions synchrone/asynchrone Développement d'un site Web ou d'une appli mobile 24 Janvier 2021
probleme avec fonction else if Développement d'un site Web ou d'une appli mobile 12 Mars 2016
Probleme avec les fonctions {if}{else if}{else} Développement d'un site Web ou d'une appli mobile 8 Mai 2015
Problème indexation avec snapshot html. Fonctionne à moitié. Besoin d'aide !! Problèmes de référencement spécifiques à vos sites 6 Janvier 2015
probleme fonctionnement script Développement d'un site Web ou d'une appli mobile 4 Janvier 2015
problème fonction e-commerce Google Analytics 25 Octobre 2012
Problème chez Online avec la fonction mail Développement d'un site Web ou d'une appli mobile 31 Août 2010
Problème fonction URL compatible. Développement d'un site Web ou d'une appli mobile 18 Août 2010
problème fonction mail Administration d'un site Web 6 Avril 2010
Probleme avec la fonction time() Développement d'un site Web ou d'une appli mobile 12 Février 2010
Problème avec la fonction include Développement d'un site Web ou d'une appli mobile 7 Décembre 2009
Problème fonction mail() : email envoyé 3 fois. Développement d'un site Web ou d'une appli mobile 27 Avril 2009
Problème avec mes fonctions latex sur mon site URL Rewriting et .htaccess 17 Novembre 2008
Joomla, probleme d'affichage en fonction de la resolution Développement d'un site Web ou d'une appli mobile 3 Octobre 2008
Problème fonction date à devenir fou Développement d'un site Web ou d'une appli mobile 31 Mai 2008
fonction mail() pour php : probleme fichiers joints Développement d'un site Web ou d'une appli mobile 28 Février 2008
probleme avec boucle While et fonction php mail() Développement d'un site Web ou d'une appli mobile 25 Octobre 2007
Problème de style avec la fonction mail() [résolu] Développement d'un site Web ou d'une appli mobile 17 Octobre 2007
problème avec le paramètre from de la fonction mail() Développement d'un site Web ou d'une appli mobile 24 Septembre 2007
[Résolu]Problème menu en fonction du naviguateur Développement d'un site Web ou d'une appli mobile 30 Juin 2007