[Résolu] Une tite erreur qui me chiffonne

Voila un tit truc qui marche pas :

Code:
RewriteRule ^([a-z]*)\.php$ /nomdurepertoire/index.php?parametre=$1 [L]

Et bien ca marche pas :-(

en fait le lien est un mot qui peut aller de 2 lettres à ... + ... j'ai testé {0,} mais ca ne marche pas non plus... mais par contre quand y'a juste trois lettres par exemple, et que je mets {3}, là ca marche

des idées ?
 
Re: Une tite erreur qui me chiffonne

finstreet a dit:
Voila un tit truc qui marche pas :

Code:
RewriteRule ^([a-z]*)\.php$ /nomdurepertoire/index.php?parametre=$1 [L]

Et bien ca marche pas :-(

en fait le lien est un mot qui peut aller de 2 lettres à ... + ... j'ai testé {0,} mais ca ne marche pas non plus... mais par contre quand y'a juste trois lettres par exemple, et que je mets {3}, là ca marche

des idées ?

Tu n'aurais pas une autre règle un peu avant qui "matche" le cas 2 lettres?

Note aussi que ta règle matche uniquement des lettres minuscules (ni majuscules, ni chiffres, ni accents...).

Jacques.
 
bah ca sera que des minuscules, et pis ca peut vraiment pas etre inférieur à 2 :) c'est un nombre prédéfini que je connais avant... au max 15 possibilités
 
tu peux essayer :

Code:
RewriteRule ^([a-z]+)\.php$ /nomdurepertoire/index.php?parametre=$1 [L]
 
finstreet a dit:
bah ca sera que des minuscules, et pis ca peut vraiment pas etre inférieur à 2 :) c'est un nombre prédéfini que je connais avant... au max 15 possibilités

Et une autre rewriterule dans ton fichier qui s'appliquerait aussi? Ou une rewritecond qui fait que ta règle ne s'applique pas?

Au fait, il se passe quoi exactement?

Jacques.
 
si tu veux au moins deux lettres en minuscule, la règle suivante doit marcher :
Code:
RewriteRule ^([a-z][a-z]+)\.php$ /nomdurepertoire/index.php?parametre=$1 [L]
 
finstreet a dit:
Tous les tests finissent par un Internal Server Error

Et que disent les logs d'erreur dans ce cas?

Au fait, je suppose que si tu appelles l'URL "de destination" directement, avec le fameux paramètre à 2 lettres, ça marche?

Et avec la règle de redirection sur le nom de domaine canonique, c'est la seule qui traîne?

Jacques.
 
euh j'ai pas de log :) pas accès en tout cas

sinon oui le paramètre c bien celui là qui est récupéré

sinon oui c bien la seule qui traine, le ndd est tout vide :)
 
c'est normal : ca boucle
il faut ajouter un test pour exclure les fichiers ou les répertoires existants :
Code:
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^([a-z][a-z]+)\.php$ /nomdurepertoire/index.php?parametre=$1 [L]
 

➡️ Offre MyRankingMetrics ⬅️

pré-audit SEO gratuit avec RM Tech (+ avis d'expert)
coaching offert aux clients (avec Olivier Duffez ou Fabien Faceries)

Voir les détails ici

coaching SEO
Discussions similaires
Haut